Jump to content
Sign in to follow this  
Aodhan

Virtual Mall update going on

Recommended Posts

Hey all-

 

I've been on a long hiatus from the boards, mainly owing to my "real" job, and getting my site to a functioning level.

 

I've had a lot of requests and questions regarding the Virtual Mall contrib, so I am in the process of making it compatible with MS1. As soon as that is done, I'll upload it with a little bit better documentation as well. :D

 

Aodhan

Share this post


Link to post
Share on other sites

Might want to look at current snapshot or at least snapshot after 3/24/03.

 

8)

 

Some major changes worth having.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Agreed,

Love the possibilities here.

 

Ive installed the them mod (as of 7/03) on a fresh install of 2.2 & all works until inserting an image from the stores.php

 

Error:

 

Fatal error: Call to undefined function: tep_get_uploaded_file() in /home/yaddah/public_html/catalog/admin/stores.php on line 56

 

all code in stores.php looks good, could there be a change in the tep functions?

 

Thanks again, looking forward to this contribution.

Share this post


Link to post
Share on other sites

Just remove all the routine of tep_get_uploaded_file and so on up to the tep_redirect line (not included) and paste this code to be able to post and list your Virtual mall images:

 

 

 

 

 

      if ($store_image = new upload('store_image', DIR_FS_CATALOG_IMAGES)) {

     tep_db_query("update " . TABLE_STORES . " set store_image = '" . tep_db_input($store_image->filename) . "' where store_id = '" . tep_db_input($store_id) . "'");

     }

 

Regards


---------------------------------------------

Life goes'on - Tupac Shakur

Share this post


Link to post
Share on other sites

Hello John!

 

Thanks for your wonderful contrib.

 

I tried to install or rather integrate with the MS1, as Virtual Mall 1.1 is only compatible with MS1, but did not have 100% sucess. It works with the parent categories as SHOPS perfectly.

 

However, in the orders_products, the store_id is not inserted and multiple emails are not sent. Mostlikely it may be due to my mistakes in inserting the codes.

 

Is your contrib ready for the MS2? I would verymuch appreciate. Most helpful would be if you could post the entire code with the MS2 changes files. Because its not the question of the time but the functionality that gives a problem in inserting the code.

 

Thanking you in advance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×