Jump to content
Sign in to follow this  
Ajeh

[Contribution] Shoppe Enhancement Controller v1.0a 05-1-2003

Recommended Posts

Hello!...

I've downloaded and installed SEC 1.0a upon a fresh copy of OsCommerce snapshot 20030518. I've actually replaced all the files BEFORE uploading the hole thing to the server and begin the TEP install procedure.

 

Later I've loaded the SEC MySQL files with phpMyAdmin and all seems fine to me, I mean: no errors are shown... But I cannot find the quantity discount fields or a quantity discount switch anywhere in the admin area.

 

Would someone please tell me where to look for this feature in the zillions of things added to OSC with this cool add-on?

 

In the documentation I found a section dedicated to Product Pricing and Discounts that says:

 

Product pricing has several new options:

Retail is Free:  No   Yes  

Retail is Call for Price:  No   Yes  

Retail is Show Room Only:  No   Yes  

Retail Display Price Includes Attributes  No   Yes

 

But I can't find those option anywhere... I feel like I'm missing something. :roll:

Perhaps I should replace the files again, since in my admin area and in the products' details I can't find any of those at all.

 

Any insight?

 

Thanks to all!

Mauro.

Share this post


Link to post
Share on other sites

and Linda's controller on cvs 5/18 version. Both are clean install.

 

I spend hours to get the stroller and cvs 5/18 to work. I'm so afraid that I may break it again.

 

IF anyone has experience, please let me know.

 

Thanks

 

Wendy

Share this post


Link to post
Share on other sites
Just did a fresh install of  5/18 snapshot, then SEC v1.0 A...

I'm wanting to use this in english, german and spanish.  

 

Testing this locally on a windows machine running Foxserv (php, mysql, apache bundle)

 

All seems fine except I get error

 

Fatal error: Failed opening required 'includes/languages/german/shoppe_enhancement_controller_languages.php' (include_path='.;c:php4pear') in d:websitesexstampscatalogincludeslanguagesshoppe_enhancement_controller.php on line 112

 

Here's my line 112 of shoppe_enhancement_controller.php

 

// Language specific definitions

require(DIR_WS_LANGUAGES . $language . '/' . 'shoppe_enhancement_controller_languages.php');

require(DIR_WS_LANGUAGES . $language . '/' . 'loginbox.php');

require(DIR_WS_LANGUAGES . $language . '/' . 'header_tags.php');

///////////////////////////////////////////////////////////////////

 

I don't know PHP too well, probably something simple. Do I have to put something to replace the '/' ?

 

Steve, did you edit each of the language files as stated in the READMe.txt to include:

 

// BOF: WebMakers.com Added: Shoppe Enhancement Controller

require(DIR_WS_LANGUAGES . 'shoppe_enhancement_controller.php');

// EOF: WebMakers.com Added: Shoppe Enhancement Controller

Share this post


Link to post
Share on other sites
I fixed mine by adding the LPD_MANUFACTURERS_ID to the configuration table. I also managed to hack a fix to display only the product_image field with a variable I call LPD_PRODUCTS_IMAGE_BIG & separate table in categories.php, making sure to include the else "echo hidden field". I have hacked my categories back considerably to include the dozen or so extra fields in my products table. I used your $newfields example to make it easier to update the queries. However, I have a few fields that never seem to retrieve existing data when I do a product edit, and in a couple of cases, I managed to wipe out a whole row of data when I did an update. Not sure what's happening there. Maybe I can email you the file with a note about the problem fields?

 

Make sure you have addressed each section of code for the fields. Example: take any of the fields listed in $new_fields and locate all the places where this field it referenced, then follow the same pattern.

 

Also, I managed to get the enable/disable categories contribution working nicely with SEC 1.0a.  

 

That will help others know that it can be done ... :D

 

Last thing, I can't get the image popups to work in admin. Again, I hacked one of the popup files & renamed it popup_image_big.php and changed references to the product_image field which I'm using. Now when I mouse over the image, I see the full path to the correct image in the browser status bar ('bimage' was empty before) but it doesn't find the image upon popup. Is this a bug, or just a problem specific to my installation?

 

The popups are a lot of fun to work with.

 

I use popup_image2.php as a guide for how to create additional ones.

 

Usually it is a simple typo causing the issue when they do not work.

Share this post


Link to post
Share on other sites
Hi again, Linda,

 

My missing data is no doubt, due to incorrect usage of the tep_draw_checkbox_field, because when I switched to a text field, it retreived the data. How do I change this to a working checkbox?

 

I haven't tried checkboxes ... but I do have radio buttons ... LPD_PRODUCTS_STATUS

 

See if that helps you out any.

Share this post


Link to post
Share on other sites
************************************************************  

I also always see the following warning message:  

******************************************  

Warning: Cannot set time limit in safe mode in /home/virtual/site41/fst/var/www/html/catalog/install/includes/functions/general.php on line 47  

***************************************************  

It appeared when I installed ms1 as well. What did cause this?  

 

You may take a look at my site at:  

www.thesnapstore.com/catalog/default.php  

 

This sounds more like a server issue for the safe mode setting of which I tell my hosting guru the problem and he fixes that on his end as I haven't access nor a clue on this ... 8)

 

You may also notice that on the top where the HOME, Special, What's NEW boxes located I have blank boxes. But when I point my mouse to it it does show some words. What did I do wrong here?  

 

These expect the images:

button_blank_left.gif

button_blank_middle.gif

button_blank_right.gif

 

They are included in one of the image folders, but you may wish to make your own.

Share this post


Link to post
Share on other sites
Linda,

 

I have two more warnings in the My Store Admin section:

 

Warning: Missing argument 2 for tep_get_zone_name() in /home/virtual/site41/fst/var/www/html/catalog/admin/includes/functions/general.php on line 259

 

Warning: Missing argument 3 for tep_get_zone_name() in /home/virtual/site41/fst/var/www/html/catalog/admin/includes/functions/general.php on line 259

 

They all point to the same file but I don't see anything wrong.

 

Are they related to the store front warning in my previous post?

 

Did you start with a clean MySQL database or an old existing one that you had from another version?

Share this post


Link to post
Share on other sites
I think the problem stems from the 'Category' box.  

One more thing, how do I set it up to display one product per row?

 

Thanks.

 

I cannot get your site to load to look at this.

Share this post


Link to post
Share on other sites
Linda,

 

I found a small HTML formatting bug in the catalog header.php.  The login link has an extra quote mark just before the class attribute.

 

Also, in categories.php there is an improperly nested <nobr> tag for the categories links.

 

Minor stuff, but some browsers may have problems with these.

 

Thanks for spotting those.

 

I removed the extra one in front of the word class on the login.

 

I have not looked at the categories.php very closely other than a few changes as that was designed by Jim Bray and always seemed to work nicely ...

 

I will would have to fool with that one to see what's up.

Share this post


Link to post
Share on other sites
Hi Linda

Finally got this one installed working ok and am now adding my old contributions. Just added administrators 1.4.6 and when i go to Customer orders page I am getting the following:

Warning: Division by zero in /home/simweb/public_html/admin/includes/classes/split_page_results.php on line 33

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'MAX_DISPLAY_SEARCH_RESULTS_ORDERS' at line 1

 

select o.orders_id, o.customers_name, o.payment_method, o.date_purchased, o.last_modified, o.currency, o.currency_value, s.orders_status_name, ot.text as order_total from orders o left join orders_total ot on (o.orders_id = ot.orders_id), orders_status s where o.orders_status = s.orders_status_id and s.language_id = '1' and ot.class = 'ot_total' order by o.orders_id DESC limit -0, MAX_DISPLAY_SEARCH_RESULTS_ORDERS

 

Any clues?

 

Check the README.txt and make sure you have all of the language file settings. MAX_DISPLAY_SEARCH_RESULTS_ORDERS is a new define statement in /includes/languages/shoppe_enhancement_controller.php

Share this post


Link to post
Share on other sites
Hello!...

I've downloaded and installed SEC 1.0a upon a fresh copy of OsCommerce snapshot 20030518. I've actually replaced all the files BEFORE uploading the hole thing to the server and begin the TEP install procedure.

 

Later I've loaded the SEC MySQL files with phpMyAdmin and all seems fine to me, I mean: no errors are shown... But I cannot find the quantity discount fields or a quantity discount switch anywhere in the admin area.

 

Would someone please tell me where to look for this feature in the zillions of things added to OSC with this cool add-on?

 

In the documentation I found a section dedicated to Product Pricing and Discounts that says:

 

Product pricing has several new options:

Retail is Free:  No   Yes  

Retail is Call for Price:  No   Yes  

Retail is Show Room Only:  No   Yes  

Retail Display Price Includes Attributes  No   Yes

 

But I can't find those option anywhere... I feel like I'm missing something. :roll:

Perhaps I should replace the files again, since in my admin area and in the products' details I can't find any of those at all.

 

Any insight?

 

You should see the new fields in the products table.

 

Everything is added/edited in the categories.php for the discounts on a per product basis.

Share this post


Link to post
Share on other sites
and Linda's controller on cvs 5/18 version.  Both are clean install.

 

I spend hours to get the stroller and cvs 5/18 to work.  I'm so afraid that I may break it again.  

 

IF anyone has experience, please let me know.

 

If you have a clean 05-18-2003 osCommerce snapshot, and SEC v1.0a ...

 

Just load the SEC v1.0a files from /CHANGED FILES and /NEW FILES right on top of the osCommerce files.

 

NOTE: delete the folder /CHANGED 05_18_2003 as that was not suppose to be part of the zip file ... I goofed ... :shock:

 

Follow the README.txt for the code to add to general.php and the language files.

 

Rename application_top.php.txt to application_top.php

 

Load the oscommere.sql file from 05-18-2003 snapshot

 

Load the two SECv1.0a sql files for the structure and data changes

 

You should not need to do any major re-writes here. Just cut and paste a few lines of code in the general.php and english.php

 

Next configure the Admin for the new shop.

 

Now, test out the new Catalog and Admin with the sample data.

Share this post


Link to post
Share on other sites

Hi Linda,

 

When will the SEC be updated to snapshots above 05_18_2003 ?

I'm just wondering if I should install the one your on now or install a later snapshot and wait for your next update.

 

 

Cheers

Paul

Share this post


Link to post
Share on other sites
I want to add more then four breaks (more like 10).

Any 1 know how this can be done ?

 

Thanks.

 

I am working on a method for an unlimited number of discounts that might work to include in your specs on your site, rather than just raising the limit to 10.

 

Taking the limit to 10 can be done, but I am concerned about the next person who decides they want 11, or 15 or 20.

 

Sorry this is taking so long.

Share this post


Link to post
Share on other sites
I think the problem stems from the 'Category' box.  

One more thing, how do I set it up to display one product per row?

 

Thanks.

 

I cannot get your site to load to look at this.

 

Sorry about that - server was down. The URL is:http://koi.dnsvelocity.com/~arospeed/

 

I am not seeing where you need the one product per row. Could you be a bit more specific?

Share this post


Link to post
Share on other sites
Hi Linda,

 

When will the SEC be updated to snapshots above  05_18_2003 ?

I'm just wondering if I should install the one your on now or install a later snapshot and wait for your next update.

 

Hi Paul,

 

I am releasing one more update SEC v1.0b for the 05-18-2003 snapshot and then I will look at the 05-26-2003, 05-27-2003 and 05-28-2003 snapshots and pick which one appears the best for the next release.

 

I am trying to finalize a few cleanups on language files, a couple bugs, etc. that were found, and a couple enhancements.

 

So SECv1.0b should be any time. Depends on how late I work tonight ... 8)

Share this post


Link to post
Share on other sites
I think the problem stems from the 'Category' box.  

One more thing, how do I set it up to display one product per row?

 

Thanks.

 

I cannot get your site to load to look at this.

 

Sorry about that - server was down. The URL is:http://koi.dnsvelocity.com/~arospeed/

 

I am not seeing where you need the one product per row. Could you be a bit more specific?

 

Linda, I'm referring to the 'Categories' box in the middle on the main page. The first part is I would like to make the width smaller since it's too wide. My total page width should be 750.

 

Let's ignore the I row per item. New design.

 

Thanks.

Share this post


Link to post
Share on other sites

Linda,

 

I can't get the html editor working in the categories page. It looks like the javascript function editor_generate() is missing altogether.


Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

Share this post


Link to post
Share on other sites
Linda, I'm referring to the 'Categories' box in the middle on the main page. The first part is I would like to make the width smaller since it's too wide. My total page width should be 750.

 

Let's ignore the I row per item. New design.

 

Thanks.

 

Did you want it to look more like this:

 

http://www.8thoctave.com/osc_freecall_0518/default.php

Share this post


Link to post
Share on other sites
Linda,

 

I can't get the html editor working in the categories page.  It looks like the javascript function editor_generate() is missing altogether.

 

Would you believe I left a chunk of code out of the SECv1.0 and the SECv1.0a?

 

It will be in the SECv1.0b release.

 

Rather embarrassing to say the least. The new files that I did include makes it display without errors ... it just doesn't do anything ... :roll:

 

Thanks for letting me know.

Share this post


Link to post
Share on other sites
Linda, I'm referring to the 'Categories' box in the middle on the main page. The first part is I would like to make the width smaller since it's too wide. My total page width should be 750.

 

Let's ignore the I row per item. New design.

 

Thanks.

 

Did you want it to look more like this:

 

http://www.8thoctave.com/osc_freecall_0518/default.php

 

Yes, but not centered.

Share this post


Link to post
Share on other sites
Linda, I'm referring to the 'Categories' box in the middle on the main page. The first part is I would like to make the width smaller since it's too wide. My total page width should be 750.

 

Let's ignore the I row per item. New design.

 

Thanks.

 

Did you want it to look more like this:

 

http://www.8thoctave.com/osc_freecall_0518/default.php

 

Yes, but not centered.

 

How do you want it laid out? Right now I have it set for the 1st column being the Main Category image and the second being the Category names.

Share this post


Link to post
Share on other sites

I would like it pretty much the way it is. The first column will have the categories and a calendar right below it. The middle column will have the specials on top and categories at the bottom. Then, the third column will have all other boxes from column_right.

When I click any tab like Suspension - it page width looks okay. But on the main page where categories box is located, it's too wide.

 

Thanks for your help.

 

Linda, I'm referring to the 'Categories' box in the middle on the main page. The first part is I would like to make the width smaller since it's too wide. My total page width should be 750.

 

Let's ignore the I row per item. New design.

 

Thanks.

 

Did you want it to look more like this:

 

http://www.8thoctave.com/osc_freecall_0518/default.php

 

Yes, but not centered.

 

How do you want it laid out? Right now I have it set for the 1st column being the Main Category image and the second being the Category names.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×