Jump to content
Sign in to follow this  
Ajeh

[Contribution] Shoppe Enhancement Controller v1.0a 05-1-2003

Recommended Posts

Thanks, Linda! It was the 2 configuration_group table entries. I'm just blown away with how smart this code is! I spent the day modifying my templates & just finished merging the /admin side. This is just amazing!

 

Thanks Lee ... :D

 

I tried to put in all of the best features of Quantity Controller, Attributes Sorter and Copier, Free Call for Price and include a lot of new features that I heard people were asking for in addition to the updates I thought were needed.

 

Polishing it off with several of the most wanted add-ons with updates to the new code and a few tweaks here and there brought this about in a way that, well frankly, rather impressed myself too! 8)

 

I still have a number of features to add in and some clean up to do. But it is coming along well.

Share this post


Link to post
Share on other sites

Linda!

Thank you very much for your hard work!!!

I've just installed SEC v1.0a in fresh snapshot from 18 May.

- I've uploaded New files

- I've uploaded Changed files

- I've uploaded Changed 18_05 files (is it right?)

- I made changes in english.php anf general.php files

- I replaced login.php styleseeet.css and aplicathion_top.php (in there folders)

 

And I have some questions:

1. Something is wrong in stylesheet.css

I have white letters on white backgraund in header horizontal menu under "advanced search" (HOME ...)

2. There is no any buttons PREV | PRODUCT LISTING | NEXT at product_info page

Must one to switch it on? Where?

Or must I install it by myself over SEC ?

 

You can compare

my test site http://ms1.business-gift.ru/product_info.p...0&products_id=6

 

and Linda site http://www.8thoctave.com/osc_freecall/prod...products_id=154

 

By the way, why there is difference in URL? I mean "cPath=".

 

3. There are tld.txt & sikiller.txt files in catalog/include

How one can use it? And what for?

 

Thank you very much in advance!

And forgive me is I've missed the explanation because of my English.[/b]

Share this post


Link to post
Share on other sites

Hiya Linda,

 

I have just installed SEC 1.0 on 21st May Snapshot. I am really amazed to see the hardwork and time you have put into getting the to setup into one Big Contibution. :thumbsup: thumbsup:

 

 

I am switching from Loaded 5 to OsCommerce 2.2 CVS snapshots. It easy to keep upto date.

 

Once again, Thanks for a wonderful contribution.

Share this post


Link to post
Share on other sites
And  I have some questions:

1. Something is wrong in stylesheet.css  

I have white letters on white backgraund in header horizontal menu under "advanced search" (HOME ...)

 

The stylesheet uses some images that are in another folder that you can either use those images or make your own. Look for the button_blank_left.gif button_blank_middle.gif button_blank_right.gif

 

2. There is no any buttons PREV | PRODUCT LISTING |  NEXT at product_info page  

Must one to switch it on? Where?

Or must  I install it by myself over SEC ?

 

Check the NEW FILES/catalog/includes/languages/english/images/buttons and there are several new buttons there.

 

You can compare  

my test site http://ms1.business-gift.ru/product_info.p...0&products_id=6  

 

and Linda site http://www.8thoctave.com/osc_freecall/prod...products_id=154

 

By the way, why there is difference in URL? I mean "cPath=".

 

Depends on the route you took to get to the product on whether or not you see the cPath in the URL.

 

3. There are tld.txt & sikiller.txt files in catalog/include

How one can use it? And what for?

[/b]

 

Those are part of osCommerce and I do not address those files.

Share this post


Link to post
Share on other sites
Hiya Linda,

 

I have just installed SEC 1.0 on 21st May Snapshot. I am really amazed to see the hardwork and time you have put into getting the to setup into one Big Contibution.  :thumbsup: thumbsup:  

 

 

I am switching from Loaded 5 to OsCommerce 2.2 CVS snapshots. It easy to keep upto date.

 

Once again, Thanks for a wonderful contribution.

 

You are quite welcome ...

 

Hope you have as much fun discovering all the features built in to SEC as I did developing them ... :D

Share this post


Link to post
Share on other sites
- I've uploaded Changed 18_05 files (is it right?)

 

Looking inside those files, it seemed that nothing should be done with the 05/18/03 Changed Files. If that really is the case, I think it is confusing to have them in there, with no explanation in the ReadMe.

 

3. There are tld.txt & sikiller.txt files in catalog/include

How one can use it? And what for?

 

It looks like tld.txt file is needed to validate email addresses and spiders.txt is for the search engine spider killer feature. Move these files into the appropriate location.


Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

Share this post


Link to post
Share on other sites
- I've uploaded Changed 18_05 files (is it right?)

 

Looking inside those files, it seemed that nothing should be done with the 05/18/03 Changed Files. If that really is the case, I think it is confusing to have them in there, with no explanation in the ReadMe.

 

3. There are tld.txt & sikiller.txt files in catalog/include

How one can use it? And what for?

 

It looks like tld.txt file is needed to validate email addresses and spiders.txt is for the search engine spider killer feature. Move these files into the appropriate location.

 

I don't see them in either SEC v1.0 or SEC v1.0a ... which folder are you finding them in?

Share this post


Link to post
Share on other sites
I don't see them in either SEC v1.0 or SEC v1.0a ... which folder are you finding them in?

 

SECv1_0aCHANGED 05_18_2003

 

Though on second glance, I don't see the tld.txt file in your package and I had thought that the spiders.txt file was in the changed files folder, but it is also in the 5/18 changed folder.


Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

Share this post


Link to post
Share on other sites
I don't see them in either SEC v1.0 or SEC v1.0a ... which folder are you finding them in?

 

SECv1_0aCHANGED 05_18_2003

 

Though on second glance, I don't see the tld.txt file in your package and I had thought that the spiders.txt file was in the changed files folder, but it is also in the 5/18 changed folder.

 

Good Grief!?! I finally figured out what you guys are seeing ... :shock:

 

When I made the updates to 05/18/2003 I had a temp folder to help me see the differences from osCommerce snapshot 03-24-2003 to osCommerce snapshot 05-18-2003

 

I must of forgot to delete that folder when I was done.

 

Now I can see where the confusion comes from.

 

The CHANGED 05_18_2003 folder is not referenced in the docs nor the README.txt because it was never supose to be there ... :roll:

 

Gads ... umm ... pretend that folder isn't there ... :D

Share this post


Link to post
Share on other sites
Gads ... umm ... pretend that folder isn't there ... :D

 

Though, it may be hard for some of us to believe, you are only human. :wink:

 

:?: Is there a way to kill the Quick Return to Catalog button in the admin? This doesn't appear to be working form me. I added in the administrator login contrib from Loaded5 and this button only will take me back to the login page. That and it displays on the login page, which is not desireable.

 

Thanks,

 

Randy


Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

Share this post


Link to post
Share on other sites

You could comment it out ... but what I would try first is an IF statement not to show it when on the login page ...

 

That is a really handy button when working with products, categories, product attributes, specials, etc.

 

You can move from anywhere in the Categories/Products then off somewhere else in the Admin ... click that and be right back were you were on either the category or product you were last working on.

Share this post


Link to post
Share on other sites
You could comment it out ... but what I would try first is an IF statement not to show it when on the login page ...

 

That is a really handy button when working with products, categories, product attributes, specials, etc.

 

You can move from anywhere in the Categories/Products then off somewhere else in the Admin ... click that and be right back were you were on either the category or product you were last working on.

 

That would be fine but the button still takes me back to the login page, not to the Categories/Products page. The url has login.php?in_login=yes&retpage=%2Fcatalogtest%2Fadmin%2F, not the url to the Categories/Products page. Any suggestions?


Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

Share this post


Link to post
Share on other sites
That would be fine but the button still takes me back to the login page, not to the Categories/Products page.  The url has login.php?in_login=yes&retpage=%2Fcatalogtest%2Fadmin%2F, not the url to the Categories/Products page.  Any suggestions?

 

Any way I can peek at this?

Share this post


Link to post
Share on other sites

I. Let me clarify one thing!

 

As far as I understood

IT IS NOT NESSASARY TO DO ANYTHING WITH FILES IN FOLDER SEC_v1.0a/CHANGED 05_18_2003.

 

If it is right -->>

my instalation algoritm was incorrect!!!

1. Copy from SEC_1.0/NEW FILES

2. Copy from SEC_1.0/CHANGED FILES

3. Copy from SEC_1.0/CHANGED 05_18_2003.

 

Because last step upload files from step 2!!!

 

So I must repit step 2!!!

 

Am I Right?

 

II. About TABLE PRICES.

 

Is it possible to get one algoritm?

Or I can do it just now?

 

I'll try describe this on my business example:

I made business gift.

 

So I sell GOOD+SERVISE.

For example T-Shirt + Custom Logo.

Let customer want to have N t-shirts + his Logo

 

To place logo I must do a pice of work S1 - it is one for all copies!!!

For preparation work.. to get stamp (tampon, clishe...) for placing logo

 

So total price will be calculated as

 

TOTAL= N*(price_t-shirt) + S1 + N*(price_for_printing _logo)

 

And here I have got TABLE PRICES!!!

 

Let T-shirt price - 5$

Stamp - 20$

Price for print 1 item - 1$

 

So

If N=10, total order price=80$ (10*5+20+10*1), Price for unit=8$ (80/10)

If N=40, total order price=260$, Price for unit=6,5$

If N=100, total order price=620$, Price for unit=6,2$

 

So thank you, Linda, very much!!!

 

But can I realase such calculation in oscommerce?

 

Hope you undestand me!

 

III And one funny thing

In standart snapshop there is product (ID=3)

"Microsoft IntelliMouse Pro" and manufacture WARNER!!!

It is just mistake... but not so funny!!!

 

when I saw it for the first time in my fresh installation snapshot for SEC, I decided that somebody has changed it from admin!!! :x

And what he can change more?

 

So I delited all installation and made frech install again!!! :D

 

Linda, as TEAM MEMBER please correct it!!!

Share this post


Link to post
Share on other sites

I had that same problem when I updated & it was driving me nuts because I could see in phpmyAdmin that I had the correct values. However, I also had quite a few duplicate items in my configuration table when I did the update which I to to eliminate. In the case of the zone id in group 1, I eliminated the original entry, kept the newer one, and manually entered the correct number via phpmyadmin, even though it was already there. I know this sounds crazy, but it worked for me. I also re-entered (manually) the correct values in zones_to_geo_zones and deleted a 2nd entry that had crept in there from the update. Then the error went away. Still didn't see the value from the zone drop down showing, but I just tried it again in Admin->Config & it worked. so, go figure!

 

Hi

I have just installed this contribution with the recommended snapshot and all looks pretty funky except for one small problem.

In admin/configuration.php when looking at configuration-mystore I get the following:

Warning: call_user_func(tep_cfg_get_zone_name) [function.call-user-func]: First argument is expected to be a valid callback in /home/name/public_html/admin/includes/functions/general.php on line 1233

Any clues please anyone  :D

Share this post


Link to post
Share on other sites
I. Let me clarify one thing!

 

As far as I understood  

IT IS NOT NESSASARY TO DO ANYTHING WITH FILES IN FOLDER SEC_v1.0a/CHANGED 05_18_2003.

 

If it is right -->>  

my instalation algoritm was incorrect!!!

1. Copy from SEC_1.0/NEW FILES

2. Copy from SEC_1.0/CHANGED FILES

3. Copy from SEC_1.0/CHANGED 05_18_2003.

 

Because last step upload files from step 2

 

YES!!!

 

I repeate step1 and step 2.

 

And There is another thing!!!

Share this post


Link to post
Share on other sites
I had that same problem when I updated  & it was driving me nuts because I could see in phpmyAdmin that I had the correct values. However, I also had quite a few duplicate items in my configuration table when I did the update which I to to eliminate. In the case of the zone id in group 1, I eliminated the original entry, kept the newer one, and manually entered the correct number via phpmyadmin, even though it was already there. I know this sounds crazy, but it worked for me. I also re-entered (manually) the correct values in zones_to_geo_zones and deleted a 2nd entry that had crept in there from the update. Then the error went away. Still didn't see the value from the zone drop down showing, but I just tried it again in Admin->Config & it worked. so, go figure!

 

Hi

I have just installed this contribution with the recommended snapshot and all looks pretty funky except for one small problem.

In admin/configuration.php when looking at configuration-mystore I get the following:

Warning: call_user_func(tep_cfg_get_zone_name) [function.call-user-func]: First argument is expected to be a valid callback in /home/name/public_html/admin/includes/functions/general.php on line 1233

Any clues please anyone  :D

Hi

Just to reiterate error message:

"Warning: call_user_func(tep_cfg_get_zone_name) [function.call-user-func]: First argument is expected to be a valid callback in /home/simweb/public_html/admin/includes/functions/general.php on line 1233"

I have checked general.php and there appears to be no blank lines or spacing after the closing ?> see below

 

return $ip;

}

// BOF: WebMakers.com Added: Shoppe Enhancement Controller

require(DIR_WS_FUNCTIONS . 'webmakers_added_functions.php');

// EOF: WebMakers.com Added: Shoppe Enhancement Controller

?>

 

I have also checked for duplicate entries in configuration table and the zone tables but it all looks ok to me. I did by mistake upload the now famous changed_05_18_2003 folder by mistake first though, would this have had any effect?

Bit stumped here at the moment chaps (and you Linda :D )


thanks

Rich

"May the seam be with you"

Share this post


Link to post
Share on other sites
1. Copy from SEC_1.0/NEW FILES

2. Copy from SEC_1.0/CHANGED FILES

3. Copy from SEC_1.0/CHANGED 05_18_2003.

 

Only do steps 1 and 2 ... if you did step 3 then you should be able to repeat step 2 to fix this.

 

Let T-shirt price - 5$

Stamp - 20$

Price for print 1 item - 1$

 

So  

If N=10, total order price=80$ (10*5+20+10*1), Price for unit=8$ (80/10)

If N=40, total order price=260$, Price for unit=6,5$

If N=100, total order price=620$, Price for unit=6,2$

 

Set the T-Shirt products_price to 5

Make an Attribute called:

 

Product Option Logo

Product Value Printing

 

Add attribute to T-Shirt

 

options_values_price 1

Units 1

Units price 20

 

Units*Units Price is a one time charge regardless of quantity.

 

So this should work for you as long as units * units_price= 20

 

This was meant to be used both as a one time charge and to have the ability to break down that charge under various conditions for reporting. But it works as a one time charge.

 

I am also adding an attributes one time charge based on it's own quantity breaks in the next release.

 

III And one funny thing

In standart snapshop there is product (ID=3)  

"Microsoft IntelliMouse Pro" and manufacture WARNER!!!

It is just mistake... but not so funny!!!

 

Such is life ... eventually this will be corrected I am sure.

Share this post


Link to post
Share on other sites
Just to reiterate error message:

"Warning: call_user_func(tep_cfg_get_zone_name) [function.call-user-func]: First argument is expected to be a valid callback in /home/simweb/public_html/admin/includes/functions/general.php on line 1233"

 

I have also checked for duplicate entries in configuration table and the zone tables but it all looks ok to me. I did by mistake upload the now famous changed_05_18_2003 folder by mistake first though, would this have had any effect?

Bit stumped here at the moment chaps (and you Linda  :D )

 

Reload the CHANGED FILES folder. The Other folder basically took you back to 05-18-2003 before the CHANGED FOLDER was loaded.

Share this post


Link to post
Share on other sites
That would be fine but the button still takes me back to the login page, not to the Categories/Products page.  The url has login.php?in_login=yes&retpage=%2Fcatalogtest%2Fadmin%2F, not the url to the Categories/Products page.  Any suggestions?

 

Boo Boo on the coder's part ... ie me ... :shock:

 

I should of made that button disappear until it had a proper value.

 

I will add that to the next update. Thanks for spotting it!

Share this post


Link to post
Share on other sites

Something wrong with one of the variables here, is it too long or something, the code looks OK to me...

(notice TABLE_HEADING_PRODUCT_ATTRIBUTE_IS_FREE is being shown instead of 'Free' as defined in products_attirbutes.php)

Products Attributes      

 

1 |  

 

ID   Product Name   FILE NAME   Option Name   Option Value   Sort    Value Price   Prefix   TABLE_HEADING_PRODUCT_ATTRIBUTE_IS_FREE   Action  

 

31        Size   Large (L)  0   0.0000   +   1        

30        Size   Extra Large (XL)  0   0.0000   +   1        

29        Size   Extra Extra Large (XXL)  0   0.0000   +   1        

28        Size   3 Extra Large (XXXL)  0   0.0000   +   1        

 

32       ColorSize    3 Extra Large (XXXL)BlackBoneCharcoalCremeDark BlueDillExtra Extra Large (XXL)Extra Large (XL)Forest GreenGreenLarge (L)Light BlueMedium (M)Medium BlueMossNaturalNavyPlatinumRoyal BlueSageSandSmall (S)TanTaupeWhiteYellow                  

 

This is a fresh install of SEC 1.0a with the 05/18 snapshot, i have deleted all the default options/attributes, this is on the Admin Product Attributes page on the bottom, it came like this right out of the box...

 

Any clues?


Rhett Nye

Island Ink-Jet Systems Inc.

www.islandinkjet.com

"1000 Locations Forecast by 2005"

Share this post


Link to post
Share on other sites
Hi Kevin

It is the 18.5.03. snapshot I have used.

Zones table is as follows:

Field Type Null Default  

zone_id   int(11) No    

zone_country_id   int(11) No  0  

zone_code   varchar(32) No    

zone_name   varchar(32) No    

There is a drop down for zones and when you select a zone is does not appear in the table?

 

check in the database:

 

tep_cfg_pull_down_zone_list(

 

in the the configuration table configuration title Zone / set_function should be set to above

Share this post


Link to post
Share on other sites
Something wrong with one of the variables here, is it too long or something, the code looks OK to me...

(notice TABLE_HEADING_PRODUCT_ATTRIBUTE_IS_FREE is being shown instead of 'Free' as defined in products_attirbutes.php)

 

Check that all the language files are loaded in the Admin and that you added the cut and pastes from README.txt

Share this post


Link to post
Share on other sites

Hi,

Linda, thanks for the great contribution! I was wondering if it is compatible with the contribution called Option Feature Type. This contribution allows text input boxes in your product attributes. Correct me if I'm wrong, but I think I read somewhere that the Attribute Sorter contribution did not work with this.

 

I would like the best of both worlds, but I'm not sure it is possible. If it's not compatible currently, do you plan on including something to the Option Feature Type in a future release of SEC? That would be on my wishlist.

 

 

Thanks again,

 

Steve :)

Share this post


Link to post
Share on other sites
here's the link:http://tep.sourceforge.net/snapshots/tep_snapshot-20030518.zip

 

Nope bad URL :cry:


--- Denver Prophit Jr.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×