Jump to content
Sign in to follow this  
IngoPhisto

Update osCommerce 2.2 Milestone 2

Recommended Posts

Gruesst Euch,

es mag eine vollkommen dumme Frage sein, aber ich weiß nicht, wie ich sonst zu einer Antwort komme.

Woran erkenne ich meine Version von Oscommerce???

Ich möchte schon das richtige Update verwenden.

Das Original habe ich 2006 installiert.

Danke für Eure Nachsicht

Oliver

Share this post


Link to post
Share on other sites
Wann kommt den etwa die OsCommerce 3 raus? (Hat ja viele SOE Erweiterungen)

Wenn sie fertig ist ;)

Da gibt es keinen festen Termin.

Share this post


Link to post
Share on other sites

@chilinotes

die Version kann man in der catalog/includes/application_top.php

ca. Zeile 43

// define the project version

define('PROJECT_VERSION', 'osCommerce 2.2-MS2');

Damit kann man aber nicht den Stand der installierten Updates erkennen,

dafür musst Du Dir die geänderten Funktionalitäten ansehen.

-------------------------

Kann mir denn bitte jemand sagen, ob diese Daten

noch aktuell sind ?...:

das aktuellste update gibts hier update-20060817.txt

es beinhaltet auch alle alten updates

## Update 051112 (12th November 2005)

## Update 051113 (13th November 2005)

## Update 060817 (17th August 2006)

Also ist das aktuellste Update 20060817.txt immer noch das aktuellste ?

Gibt es eine offizielle Seite, auf der man das verfolgen kann ?

Dank für jeden Tip !

Share this post


Link to post
Share on other sites

@Alex66

Genau, habe das gleiche Problem wie Alex...

Da muss es doch eine Zwischenversion gegeben haben... Kann das sein ?

Danke !

Share this post


Link to post
Share on other sites
@chilinotes

die Version kann man in der catalog/includes/application_top.php

ca. Zeile 43

// define the project version

define('PROJECT_VERSION', 'osCommerce 2.2-MS2');

Damit kann man aber nicht den Stand der installierten Updates erkennen,

dafür musst Du Dir die geänderten Funktionalitäten ansehen.

-------------------------

Kann mir denn bitte jemand sagen, ob diese Daten

noch aktuell sind ?...:

das aktuellste update gibts hier update-20060817.txt

es beinhaltet auch alle alten updates

## Update 051112 (12th November 2005)

## Update 051113 (13th November 2005)

## Update 060817 (17th August 2006)

Also ist das aktuellste Update 20060817.txt immer noch das aktuellste ?

Danke.

Share this post


Link to post
Share on other sites

Hallo zusammen!

Mittlerweile stellen ja wohl alle Hoster irgendwie auf PHP5 um und ich mache mir nun Gedanken, ob ich unseren Shop updaten muss. Könnt Ihr mir das beantworten? In der application_top.php steht "define('PROJECT_VERSION', 'osCommerce 2.2-MS2');", wir haben den Shop vor etlichen Jahren mal inclusive einiger Einbauten gekauft und nutzen ihn jetzt seit etwa 2 Jahren sehr intensiv, sprich wir haben mittlerweile auch die eine oder andere Contrib eingebaut, die wir nicht mehr missen möchten.

Wenn ein Update nötig ist, um den Shop PHP5 tauglich zu machen, dann möchte ich das natürlich fertig haben, bevor der Tax X kommt und der Shop plötzlich einfach nicht mehr funktioniert.

Aber wenn Ihr sagt, das sollte mit der Version auch so funktionieren, dann würde ich auf ein Update lieber verzichten.

Danke schonmal für Eure Antwort!

Viele Grüße, Nicole

Share this post


Link to post
Share on other sites

Warum willst Du auf das Update verzichten ?

Klar hast Du mit dem Update einen gewissen Aufwand, aber m.E. lohnt der sich durchaus.

Du bekommst damit die PHP5-Fähigkeiten, sowie diverse Verbesserungen und Bugfixes.

Share this post


Link to post
Share on other sites
wir haben den Shop vor etlichen Jahren mal inclusive einiger Einbauten gekauft und nutzen ihn jetzt seit etwa 2 Jahren sehr intensiv, sprich wir haben mittlerweile auch die eine oder andere Contrib eingebaut, die wir nicht mehr missen möchten.

Wenn ein Update nötig ist, um den Shop PHP5 tauglich zu machen, dann möchte ich das natürlich fertig haben, bevor der Tax X kommt und der Shop plötzlich einfach nicht mehr funktioniert.

Hi,

ich empfehle dass Ihr euer Shop local, z.b. mit XAMPP, installiert, dann könnt Ihr dort in Ruhe alle Updates einbauen und testen ob noch alles funktioniert ohne den live shop zu stören, denn das wird einige Zeit beanspruchen... und wenn alles funktioniert könnt ihr, wenn Ihr fertig seit, die Daten hochladen ;)

da Ihr jedoch einen Kauf Shop habt wird es schwierig Unterstützung zu bekommen sollten Probleme auftreten... ;)

Gruß

Paul

Share this post


Link to post
Share on other sites

Hallo!

Ui, das klingt gut. Ich lad mir gerade mal dieses XAMPP runter und schau mal, wie das so fluppt. Danke für den Tip!!! Das hätte ich am Wochenende schon wissen müssen. Da habe ich mir mit Ultimate Seo Urls nämlich den Shop gecrashed und ziemlich Arbeit damit gehabt, das wieder geradezubiegen. *ächz*

Trotzdem nochmal kurz die Frage: Ist der OSC Shop in der o.g. Version bereits PHP5 tauglich? Oder was genau kann da bei der Umstellung passieren? Geht er dann gar nicht mehr? Oder nur eingeschränkt? Das wäre wichtig zu wissen, damit ich abschätzen kann, wie ich mich mit dem Update beeilen muss.

Danke, Nicole

Share this post


Link to post
Share on other sites

Hallo Leute!

Ich weiß, das hier ist kein XAMPP Forum, aber vielleicht kann mir doch nur mal kurz einer auf die sprünge helfen. Ich habe soweit alles installiert und die Datenbanken und Shopdaten alle dort hingeladen, wo sie laut Anleitung hinsollte. Aber irgendwie krieg ich das Ding nicht zum Laufen?!

Wenn ich das Control Panel zum Beispiel aufmache und dann bei MySql auf "Admin" klicke, dann lädt er mir "http://localhost/phpmyadmin/" im Browser, aber es erscheint nur eine weiße Seite. Hab ich da irgendwas falsch gemacht oder vergessen?!

Danke Euch, Nicole

Share this post


Link to post
Share on other sites
Sign in to follow this  

×