Jump to content
Sign in to follow this  
Ian

[Contribution] Pollbooth v2.0

Recommended Posts

Hi,

Need some basic help, please!

Installed Polls and everything shows in admin, but the problems is:

 

when the polls mamager link or config is clicked the link is:

http://hdshirts.com/shop/admin/FILENAME_POLLS

if I replace the 'FILENAME_POLLS' manually with polls.php it works, but then if I click anything in Polls config again I get the same error 404.

 

What did I do wrong? Site https://hdshirts.com/shop/catalog/default.php goes live tomorrow.

Share this post


Link to post
Share on other sites

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/includes/functions/sessions.php on line 67

 

I get these in the polls section of my admin consloe

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/includes/functions/sessions.php on line 67

 

Warning: Cannot modify header information - headers already sent by (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/polls.php on line 83

 

Fatal error: Call to undefined function: tep_exit() in /home/timdawn/public_html/admin/polls.php on line 83

 

i get the above when i try to make a new poll

 

Parse error: parse error in /home/timdawn/public_html/pollbooth.php on line 5

 

this shows up whe you vote

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/includes/functions/sessions.php on line 67

 

Warning: Cannot modify header information - headers already sent by (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/polls.php on line 69

 

this is in the poll manger window

 

 

Please help me this mod could do so much to help my site

 

Thanks form Nubie Tim

Share this post


Link to post
Share on other sites

got all the above fixed but this

 

 

 

Warning: Cannot modify header information - headers already sent by (output started at /home/timdawn/public_html/admin/includes/languages/english.php:312) in /home/timdawn/public_html/admin/polls.php on line 31

 

Fatal error: Call to undefined function: tep_exit() in /home/timdawn/public_html/admin/polls.php on line 31

 

 

can some one shed some light on this

Share this post


Link to post
Share on other sites

hello,

 

I had error messages:

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/timdawn/public_html/admin/polls.php:12) in /home/timdawn/public_html/admin/includes/functions/sessions.php on line 67

...etc

 

I put in comment the line 49 in pollcollect.php

// $forwarder .= "/warn/" . $warn;

 

and now it's ok.

 

hope it helps

Share this post


Link to post
Share on other sites

been a long time since I've been here - - a lot has happened, apparently. Has anyone been successful in getting the poll comments to display?

 

Hard to tell from what I've seen in the posts so far.

 

Thanks!

 

 

-jared

Share this post


Link to post
Share on other sites

hi there!

 

I've got a problem with pollbooth:

 

1062 - Duplicate entry '18dcb76b089a981ebd0d4ce36843246f' for key 1

 

insert into sessions values ('18dcb76b089a981ebd0d4ce36843246f/warn/_ALREADY_VOTED', '1082193452', 'cart|O:12:\"shoppingcart\":4:{s:8:\"contents\";a:0:{}s:5:\"total\";i:0;s:6:\"weight\";i:0;s:12:\"content_type\";b:0;}language|s:6:\"german\";languages_id|s:1:\"2\";currency|s:3:\"CHF\";navigation|O:17:\"navigationhistory\":2:{s:4:\"path\";a:1:{i:0;a:4:{s:4:\"page\";s:13:\"pollbooth.php\";s:4:\"mode\";s:6:\"NONSSL\";s:3:\"get\";a:3:{s:2:\"op\";s:7:\"results\";s:6:\"pollid\";s:1:\"2\";s:6:\"osCsid\";s:52:\"18dcb76b089a981ebd0d4ce36843246f/warn/_ALREADY_VOTED\";}s:4:\"post\";a:0:{}}}s:8:\"snapshot\";a:0:{}}autologon_link|s:170:\"http://localhost/pollbooth.php?op=results&pollid=2&osCsid=18dcb76b089a981ebd0d4ce36843246f/warn/_ALREADY_VOTED&osCsid=18dcb76b089a981ebd0d4ce36843246f/warn/_ALREADY_VOTED\";autologon_executed|s:4:\"true\";')

 

[TEP STOP]

 

1062 - Duplicate entry '18dcb76b089a981ebd0d4ce36843246f' for key 1

 

insert into sessions values ('18dcb76b089a981ebd0d4ce36843246f/warn/_ALREADY_VOTED', '1082193452', 'cart|O:12:\"shoppingcart\":4:{s:8:\"contents\";a:0:{}s:5:\"total\";i:0;s:6:\"weight\";i:0;s:12:\"content_type\";b:0;}language|s:6:\"german\";languages_id|s:1:\"2\";currency|s:3:\"CHF\";navigation|O:17:\"navigationhistory\":2:{s:4:\"path\";a:1:{i:0;a:4:{s:4:\"page\";s:13:\"pollbooth.php\";s:4:\"mode\";s:6:\"NONSSL\";s:3:\"get\";a:3:{s:2:\"op\";s:7:\"results\";s:6:\"pollid\";s:1:\"2\";s:6:\"osCsid\";s:52:\"18dcb76b089a981ebd0d4ce36843246f/warn/_ALREADY_VOTED\";}s:4:\"post\";a:0:{}}}s:8:\"snapshot\";a:0:{}}autologon_link|s:170:\"http://localhost/pollbooth.php?op=results&pollid=2&osCsid=18dcb76b089a981ebd0d4ce36843246f/warn/_ALREADY_VOTED&osCsid=18dcb76b089a981ebd0d4ce36843246f/warn/_ALREADY_VOTED\";autologon_executed|s:4:\"true\";')

 

[TEP STOP]

 

 

Warning: Unknown(): A session is active. You cannot change the session module's ini settings at this time. in Unknown on line 0

 

this occurs when I have "Allow people to vote more than once" set a 0.

 

another problem with pollbooth is:

Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, ?berpr?fen Sie bitte die Schreibweise und versuchen Sie es erneut.

 

Sofern Sie dies f?r eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hier?ber.

 

Error 404

localhost

17.04.2004 10:58:18

Apache/2.0.48 (Win32) mod_perl/1.99_10 Perl/v5.8.0 mod_ssl/2.0.48 OpenSSL/0.9.7c PHP/4.3.4

 

 

the path in the addressline is:

 

 

that occurs when I try to vote from the trend detail page

 

If you have any idea about it, please let me know!

 

Andreas

Share this post


Link to post
Share on other sites
been a long time since I've been here - - a lot has happened, apparently.  Has anyone been successful in getting the poll comments to display?

 

Hard to tell from what I've seen in the posts so far.

 

Thanks!

 

 

-jared

Jared, the comments are working for me. Initially, I read through the thread to make any changes before testing, thinking to save myself some aggravation with known bugs. Somewhere in here it says to change

htmlspecialchars($comments['comment'])

to

htmlspecialchars($comments['COMMENT'])

I did this and then found my comments wouldn't display. After looking through the code I finally found this change was the problem. I changed it back and the comments display now. So, if you made this change, try removing it.

 

Jack

Share this post


Link to post
Share on other sites

I have Display Poll in admin set to random but only the last poll I add is displayed. Is anyone having this problem?

 

Also, how can I have the poll displayed on my homepage? Right now, the poll only shows in one of the categories. I ran across mention of this site in a thread about this contribution. It has the poll displayed on all pages. Does anyone know how to change do this?

 

Jack

Share this post


Link to post
Share on other sites

Thanks Jack! That was my problem as well.

 

-jared

Share this post


Link to post
Share on other sites

What do I need tto do so that a visitor can vote more than once on a poll. I have found the code that print the warning message but each visitor is still only permitted to vote once.


Live free or die

Share this post


Link to post
Share on other sites

I answered my own question.......... it is in admin.


Live free or die

Share this post


Link to post
Share on other sites

I also have the issue where there is no error message displayed if someone doesn't make a selection, has already voted, etc. After working with this mod for many hours, I'm not really up to figuring it out. :(

 

I have managed to fix nearly all the layout issues, added some images, etc. and would be happy to share my modded version if anyone can help me out with the finishing touches (re the error above)

Share this post


Link to post
Share on other sites

I found the problem. heh Just need to see how to go about fixing it. The URL is not being properly formed.

 

Vote w/o making a selection and then change the URL to look like this:

 

/catalog/pollbooth.php?op=results&pollid=1&warn=_NO_VOTE_SELECTED

 

Then resubmit.

Share this post


Link to post
Share on other sites

wow, easier than I thought. :D

 

In /catalog/pollcollect.php

 

FIND:

 

$forwarder .= "/warn/" . $warn;

 

CHANGE TO:

 

$forwarder .= "&warn=" . $warn;

Share this post


Link to post
Share on other sites

G'day Acheron,

 

Would you mind submiting your debugged varsion with layout issues fixed, etc, as an update to the existing Pollbooth contribution?

 

Thanks.

 

Peter

Share this post


Link to post
Share on other sites
G'day Acheron,

 

Would you mind submiting your debugged varsion with layout issues fixed, etc, as an update to the existing Pollbooth contribution?

 

Thanks.

 

Peter

I can, but I've changed more than enough so that it won't work with a pre-existing install. heh I changed all tables names for instance to begin with the word 'poll' as it makes it easier for me when I need to fix something if they're all grouped together and the name starts with something that describes it. Also, I have changed a query name within the PHP ($configuration_query) b/c I didn't like it using the same variables as a pre-existing query in application_top.php Anyway, that's where it stands. lmk :)

Share this post


Link to post
Share on other sites

OK, in case anyone is interested ...

 

I think I have the mod in a good enough state now to release my version publicly but b/c of all the excessive changes, I was thinking I should 'Contribute a New Package' rather than add to the existing one, no??

 

lmk what you all think. Here are the changes I've made:

 

- Mod heavily revamped and put back into BETA status until further testing can be done

- All code references and echos regarding 'Poll Comments' have been commented out. The table has also of course been removed from the SQL.  This means USERS CANNOT LEAVE COMMENTS.

- Major HTML cleanup.  I edited a *lot* of HTML to get the mod looking the way it does now.

- Warning function now working

- HTML/PHP additions to add dynamic hyperlinking to 'All Polls' page.  Various other HTML/PHP additions as well

- /catalog/admin/includes/boxes/polls/ was replaced as it was only partially working and contained unnecessary code. The replacement box fixes at least 2 issues: (a) clicking 'Polls' in the admin menu now brings you to the right page the first time and (B) everything updates on 1st edit.

Share this post


Link to post
Share on other sites

I think you should definently release a new version, but heres a problem ive just ran into. For some odd reason my "comments" are displaying the number '2' in the box when a person checks out after installing this poll contrib. Is this something to have to do with conflicts of variables?


Kenneth S

--------------

Customer "Are you a real programmer?"

Me "No, but I did stay at a Holiday Inn Express last night"

Share this post


Link to post
Share on other sites
I think you should definently release a new version, but heres a problem ive just ran into. For some odd reason my "comments" are displaying the number '2' in the box when a person checks out after installing this poll contrib. Is this something to have to do with conflicts of variables?

I can't really answer that one at this point b/c I have now disabled comments altogether. I see a couple issues with comments.

 

(1) They are not moderated prior to be displayed publicly. Any immature jacka-- who decides to type in 'You suck' or something stupid like that will have his comment displayed publicly. Just one more thing I'd rather not worry about.

 

(2) Comments aren't really necessary IMHO as the contact page provides ample opportunity for a user to leave feedback if they wish to do so.

 

Anyway, back to your problem ... are there any variables concerning the word 'comments' that are located in both checkout and the poll mod?

Share this post


Link to post
Share on other sites

Thanks,

 

Ive already discovered the problem. It was a variable clashing and since there were 2 comments (tests) I made before I removed the code to display or post them it was displaying that number by default in my orders. Just incase anyone else has this problem I suggest completely disabling comments for the simple reason of the error and the obvious reason Acheron posted above.

 

Thanks,

KennethS


Kenneth S

--------------

Customer "Are you a real programmer?"

Me "No, but I did stay at a Holiday Inn Express last night"

Share this post


Link to post
Share on other sites

Hi.... :-)

 

 

My question are for those out there who uses both the Polls and the newsdesk contribs.......

 

In the polls manager you can set in which categories the polls will be shown.....

 

But this goes for the shop/catalog categories and not for the newsdesk.

 

My question then is if there are anyone out there who has any idea how to add the option of choosing polls for newsdesk categories instead?

 

(as a replacement and/or an addition to todays choices)

Share this post


Link to post
Share on other sites

Hey all,

 

Im getting the following error on my site index page over in the top of the right column. It says the following:

 

Fatal error: Cannot redeclare pollnewest() (previously declared in C:\home\markettown\www\irishtimes\catalog\includes\boxes\polls.php:6) in C:\home\markettown\www\irishtimes\catalog\includes\boxes\polls.php on line 5

 

Im also getting all my column left options in the admin section renamed to

 

BOX_HEADING_CONFIGURATION etc. and

BOX_TOOLS_BACKUP etc.

 

This happens on all the options down the left hand side of admin, except where the 'Polls' option is, that displays as just 'Polls'.

 

The poll is actually showing up on the left hand side of the index page, even though the code is in column_right afaik.

 

Here's the site:

 

Irish Times

 

Can anyone help please? I need this fixed asap and the guy that wants it done told the Irish Times it would be finshed last week! Goddamit :(

Edited by sonictrip.net

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×