Jump to content
Sign in to follow this  
Ian

[Contribution] Pollbooth v2.0

Recommended Posts

Having problems adding more than 8 possible answers to the question posed in the poll... in Poll Manager there are only 8 options, i would like to be able to add atleast another 4... has anyone else had this problem - if so how did they get round it ?

Share this post


Link to post
Share on other sites

Hi, having a quick problem with this mod. Everything installed fine, with no problems. The poll booth also works fine, apparently, because I can see the numbers going up. The admin section works fine too, and there are NO ERRORS. BUT:

 

When I vote on one of the options, it goes to a BLANK PAGE. Not to a "can't find" page, but just a white page, and in the address bar, it says:

 

http://localhost/catalog/pollcollect.php?o...47d8276a0601d2f

 

(localhost, because I'm testing it out first), and there's nothing on the page. I can't figure out what is wrong. I know that some other people before had this issue, but I went through every support page and tried all the fixes, and nothing worked. It's not my application_top.php either, since I even tried replacing it with the original from a clean install. I don't know what it could be. Any hints, or anyone who had this issue have any suggestions? Thanks!

Share this post


Link to post
Share on other sites
Hi, having a quick problem with this mod. Everything installed fine, with no problems. The poll booth also works fine, apparently, because I can see the numbers going up. The admin section works fine too, and there are NO ERRORS. BUT:

 

When I vote on one of the options, it goes to a BLANK PAGE. Not to a "can't find" page, but just a white page, and in the address bar, it says:

 

http://localhost/catalog/pollcollect.php?o...47d8276a0601d2f

 

(localhost, because I'm testing it out first), and there's nothing on the page. I can't figure out what is wrong. I know that some other people before had this issue, but I went through every support page and tried all the fixes, and nothing worked. It's not my application_top.php either, since I even tried replacing it with the original from a clean install. I don't know what it could be. Any hints, or anyone who had this issue have any suggestions? Thanks!

 

 

There is probably an error on the page your visiting and the error logging has been shut off. you will have to look in your server for a either and error.log file or in the cpanel for your error logs. then you will know what the error is and you can fix it

Share this post


Link to post
Share on other sites

Has anybody gotten this to work with bts. (basic template system)? I'm working on it but it is sooooo hard to implement cuz I'm not that good with php. Any help on this would be much appreciated.

Share this post


Link to post
Share on other sites

Hey guys,

 

wondering if you can help me out _ i'm wanting to move this pollboth contribute from the left hand column (where i have it now) and move it to display into the index page, like the results. So effectivly when poepl come to nmy site the firast hting they see is pollbooth on the main page where the upcoming products usually is.

 

Look forward to your suggestions,

 

Any Ideas?

 

Cheers,

 

Mitchell

 

Megaphone

Share this post


Link to post
Share on other sites
Hey guys,

 

wondering if you can help me out _ i'm wanting to move this pollboth contribute from the left hand column (where i have it now) and move it to display into the index page, like the results. So effectivly when poepl come to nmy site the firast hting they see is pollbooth on the main page where the upcoming products usually is.

 

Look forward to your suggestions,

 

Any Ideas?

 

Cheers,

 

Mitchell

 

Megaphone

 

Any ideas, anyone ? please?

Share this post


Link to post
Share on other sites
Any ideas, anyone ? please?

 

Here's a quick solution for you.

  1. rename the file catalog/includes/modules/new_products.php -> new_products_orig.php
  2. copy catalog/includes/boxes/polls.php -> catalog/includes/modules/
  3. rename the file catalog/includes/modules/polls.php -> new_products.php
  4. upload changes to server

That should give you a start. Just a note that you cannot have the poll running in the right or left column as well, as this will give you an error. If you want to have it running on other pages, you will have to modufy the code that places it in the column to check if it is on the page where the new_product.php is running and not have it run there.

 

Hope this helps :thumbsup:

 

Ed

Share this post


Link to post
Share on other sites
Here's a quick solution for you.
  1. rename the file catalog/includes/modules/new_products.php -> new_products_orig.php
  2. copy catalog/includes/boxes/polls.php -> catalog/includes/modules/
  3. rename the file catalog/includes/modules/polls.php -> new_products.php
  4. upload changes to server

That should give you a start. Just a note that you cannot have the poll running in the right or left column as well, as this will give you an error. If you want to have it running on other pages, you will have to modufy the code that places it in the column to check if it is on the page where the new_product.php is running and not have it run there.

 

Hope this helps :thumbsup:

 

Ed

 

I Ed - this works great! thank you so much for the advise, i thought that no one would answer!,

 

Cheers for that,

 

Mitchell

Share this post


Link to post
Share on other sites
I Ed - this works great! thank you so much for the advise, i thought that no one would answer!,

 

Cheers for that,

 

Mitchell

 

Hey Mitchell:

 

Here's a better alternative that I used (I liked your idea :thumbsup: and added to my site! )

 

find in catalog/index.php around line 326

 

 <td><?php  include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ); ?></td>

 

and replace with:

 

<td><?php  include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); echo "<br>"; include(DIR_WS_BOXES . 'polls.php'); ?></td>

This will display both the new products and polls on your home page or

 

<td><?php  include(DIR_WS_BOXES . 'polls.php'); ?></td>

This will just display the poll.

 

*** You will have to replace the products_new.php with your original, in either case. ***

 

Reason for change

When I made my suggestion to you originally, I didn't know that when you go to a product category page, it also shows the new products for that month in that category! By changing the file name, your poll would show up there instead. This change however only shows your poll on the home (index) page and the new products everywhere else.

 

Hope this helps!

 

Ed

Share this post


Link to post
Share on other sites
Hey Mitchell:

 

Here's a better alternative that I used (I liked your idea :thumbsup: and added to my site! )

 

find in catalog/index.php around line 326

 

 <td><?php  include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ); ?></td>

 

and replace with:

 

<td><?php  include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); echo "<br>"; include(DIR_WS_BOXES . 'polls.php'); ?></td>

This will display both the new products and polls on your home page or

 

<td><?php  include(DIR_WS_BOXES . 'polls.php'); ?></td>

This will just display the poll.

 

*** You will have to replace the products_new.php with your original, in either case. ***

 

Reason for change

When I made my suggestion to you originally, I didn't know that when you go to a product category page, it also shows the new products for that month in that category! By changing the file name, your poll would show up there instead. This change however only shows your poll on the home (index) page and the new products everywhere else.

 

Hope this helps!

 

Ed

 

Hi Ed,

 

your've outdone yourself again, although, I hve stuck with the first option and I don't sue the new_products module anyway.

 

I appreciate all of your help - your great!

 

Cheers,

 

Mitchell

Share this post


Link to post
Share on other sites
I wish it would rotate between my various polls instead of just my newly made one.....

In /catalog/includes/boxes/poll.php change:

 

		if (DISPLAY_POLL_HOW==3) {
			$extra_query=" and pollID='" . DISPLAY_POLL_ID . "'";
			}
	if (!isset($customer_id)) {
			$extra_query.=" and poll_type='0' ";
			}
	if (DISPLAY_POLL_HOW==2) {
			$order = 'voters DESC';
			 } else {
			$order = 'timestamp DESC';
			}

to

		 if (DISPLAY_POLL_HOW==3) {
			$extra_query=" and pollID='" . DISPLAY_POLL_ID . "'";
			}
	if (!isset($customer_id)) {
			$extra_query.=" and poll_type='0' ";
			}
	if (DISPLAY_POLL_HOW==2) {
			$order = 'voters DESC';
			 } 
	if (DISPLAY_POLL_HOW==0) {
			$order = 'RAND() LIMIT 1';
			 } else {
			$order = 'timestamp DESC';
			}

Share this post


Link to post
Share on other sites

Hi all

 

I have installed the contribution but all i receive om the front page is "there are no polls" message

Also if i change in the admin section not to show a poll if there are no polls then the poll disappears!

Does any one know what I am doing wrong

Sorry to be a complete idiot

Site can be seen here click here

 

Regards and thanks in advance for help

 

Chris

Share this post


Link to post
Share on other sites

Hi

I use osCommerce Online Merchant v2.2 RC 1 with Poll Booth v2.3.

When I add a new poll I get an error msg:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 'asdf', 0, 0, '4')' at line 1

insert into phesis_poll_data (pollid,optiontext,optioncount,voteid, language_id) values (, 'asdf', 0, 0, '4')

 

 

I tried tips from this topic, but my problem still exists.

 

Here is my pollcollect.php file:

 

<?php
require('includes/application_top.php');
require(DIR_WS_LANGUAGES . $language . '/pollbooth.php');
$pollid=$HTTP_POST_VARS['pollid'];
$voteid=$HTTP_POST_VARS['voteid'];
$forwarder=$HTTP_POST_VARS['forwarder'];
$ip = getenv("REMOTE_ADDR");
$past = time()-90800;
$votevalid=1;
// tep_db_query("DELETE FROM phesis_poll_check WHERE time < ".$past."");
if ($voteid) {
       $result=tep_db_query("select poll_type, poll_open from phesis_poll_desc where pollid='".$pollid."'");
       $poll=tep_db_fetch_array($result);
       if ($poll['poll_open']=='1') {
               $votevalid=0;
               $info_message1 = _POLLCLOSED;
               }
       if ($poll['poll_type']=='1' && !isset($customer_id)) {
               $votevalid=0;
               $info_message1 = _POLLPRIVATE;
               }
       /*  If you want to check by IP uncomment this block  */
if ($votevalid==1 && POLL_SPAM==0) {
              $result=tep_db_query("SELECT ip FROM phesis_poll_check WHERE ip='".$ip."' and pollid='".$pollid."'");
              $result1=tep_db_fetch_array($result);
              $ips=$result1['ip'];
              $ctime = time();
              if ($ip == $ips) {
                      $votevalid = 0;
                    $info_message1 = _ALREADY_VOTED;
                          } else {
                    tep_db_query("INSERT INTO phesis_poll_check (ip, time, pollID) VALUES ('".$ip."', '".$ctime."' , '".$pollid."')");
                      $votevalid = 1;

/*This block checks by customer id (1 vote per customer id)
      if ($votevalid==1 && POLL_SPAM==0) {
              $result=tep_db_query("SELECT customer_id FROM phesis_poll_check WHERE customer_id='".$customer_id."' and pollid='".$pollid."'");
              $result1=tep_db_fetch_array($result);
              $customers=$result1['customer_id'];
              $ctime = time();
              if ($customer_id == $customers) {
                      $votevalid = 0;
                    $info_message1 = "YOU ALREADY VOTED ";
                          } else {
                    tep_db_query("INSERT INTO phesis_poll_check (ip, time, pollID, customer_id) VALUES ('".$ip."', '".$ctime."' , '".$pollid."', '".$customer_id."')");
                      $votevalid = 1;   */      
       }
   }
}
if (!$voteid){
        $votevalid=0;
        $info_message1 = _NO_VOTE_SELECTED;
        }
if($votevalid>0) {
      $result1=tep_db_query("UPDATE phesis_poll_data SET optionCount=optionCount+1 WHERE (pollid='".$pollid."') AND (voteid='".$voteid."') and (language_id='".$languages_id."')");
      $result2=tep_db_query("UPDATE phesis_poll_desc SET voters=voters+1 WHERE pollid='".$pollid."'");
     header("Location: pollbooth.php?op=results&pollid=".$pollid."");
   } else {
      // $info_message = $info_message1 . "YOU ARE NOT ALLOWED TO VOTE";
     header("Location: pollbooth.php?op=results&pollid=$pollid&info_message=$info_message1");
      exit;
   }
?>

 

 

My store is hosted on bluehost (maybe this will help?).

Thanks in advance

Regards

szesze

Share this post


Link to post
Share on other sites

Hi,

 

I'm having a problem similar to a lot of others here. I've looked all over and can't find a difinitive answer. Can someone PLEASE tell me how to correct this error? I've been searching for days.! Thanx, George

 

 

Warning: mysql_insert_id(): supplied argument is not a valid MySQL-Link resource in xxxxxxxxxxxxxxxxx/catalog/admin/includes/functions/database.php on line 117

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' '', 0, 0, '1')' at line 1

 

insert into phesis_poll_data (pollid,optiontext,optioncount,voteid, language_id) values (, '', 0, 0, '1')

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Regarding the pollbooth contribution i would like know if it's possible to do this changes...

 

On poll comments

 

Instead

 

Comments made by wgwgfwre on 2007-12-07 00:47:53

 

have

 

Comments made by wgwgfwre on 07-12-2007 00:47:53

 

I'm asking this because some times i have the comments mixed and not sorted by date, and in my oppinion what is causing this is the Formating of the date....

 

 

 

The other situation is...

 

Can be very usefull if it's possible to implement "Visual Verify Code" on pollbooth, in my oppinion this changes can prevent the SPAM comments on pollboth... I try to do this but i'm not an expert on php....

 

 

Can anyone help on this two thinks????

 

 

 

Best Regards

João Carrolo

Share this post


Link to post
Share on other sites
Hi,

 

I'm having a problem similar to a lot of others here. I've looked all over and can't find a difinitive answer. Can someone PLEASE tell me how to correct this error? I've been searching for days.! Thanx, George

Warning: mysql_insert_id(): supplied argument is not a valid MySQL-Link resource in xxxxxxxxxxxxxxxxx/catalog/admin/includes/functions/database.php on line 117

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' '', 0, 0, '1')' at line 1

 

insert into phesis_poll_data (pollid,optiontext,optioncount,voteid, language_id) values (, '', 0, 0, '1')

 

[TEP STOP]

I had the same error.

Open admin/polls.php on line 53 find: $pollid=tep_db_insert_id($poll_query);

change to : $pollid = tep_db_insert_id();

 

Worked for me.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

I've just set up this contribution which is the best way to make easy survey.

However there are a few things that I wish to modify or that are not working properly:

 

- BUG: whether comments are disable or not, I can still comment the poll.

 

- modification: in the poll box, instead of having a full poll, I would like to only have the question. If peopel wants to cast a vote they would click on it and would see the options available.

- modification: possibility to have the result shown to visitors or once visitor cast its vote redirected to a page saying "thanks for your vote" or something.

- modification: prevent non registered people to cast a vote.

 

I hope someone will be able to give me a clue me about these points! :)

Share this post


Link to post
Share on other sites

you are a star

 

thanks 1000 time for help

 

b rgds

 

alfred

 

this works - im happy !!!!!

Edited by stragami

Share this post


Link to post
Share on other sites

Hi Alex,

 

yes, your right this is a bug (but not the only one)

 

but ok

 

- modification: in the poll box, instead of having a full poll, I would like to only have the question. If peopel wants to cast a vote they would click on it and would see the options available.

 

no i think the a customer like to see direct wahat is the questions and can make directly a vote

 

- modification: possibility to have the result shown to visitors or once visitor cast its vote redirected to a page saying "thanks for your vote" or something.

 

this is a good idea maybe the text "Thanks for your vote" (if a vote is done) can be show at the header (like all other informatioon)

 

- modification: prevent non registered people to cast a vote.

 

this you can setup in adnim panel (click on public) if its green so all user can make a vote if its red only registrated user can make a vote

but this information that only registrated user can make a vote will comes up after the user make a voot (it will not be caount) but i thinkl that tjis is to late better it is to show this ionformation earlyer.

 

rgds

 

Alferd

 

greeting from lod germany :rolleyes:

Share this post


Link to post
Share on other sites

Not sure if anyone has a problem from one of the the Admin pages with incorrect text lines but I had it from the most recent v2.3 install package.

 

I've uploaded a text file with the mod to fix here: http://addons.oscommerce.com/info/20 for what it's worth.

 

Nothing major at all but slightly distracting. :blink:

 

Cheers to all and this is a worthwhile mod to add I reckon.

Share this post


Link to post
Share on other sites

Hi,

 

i search the point where i can delete in the result page all links excluding the button

 

wht i have to do?

 

thanks for help

 

rgds

Alfred

Share this post


Link to post
Share on other sites

A few weeks ago I had reported this

- BUG: whether comments are disable or not, I can still comment the poll.

 

I have to say I had no time to dig into this.. did someone solve this little bug?

 

Cheers!

Share this post


Link to post
Share on other sites

Hello,

 

I installed this contribution which will be very useful for my site.

 

It seems to work, but once someone votes it gives the following message at the top of the page :

 

//function to check that there is no HTML in the comment field. function screenForm($field_value){ $stripped = strip_tags($field_value); if($field_value!=$stripped) { // something in the field value was HTML return false; } else return true; }

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/dca/public_html/catalog/pollbooth.php:11) in /home/dca/public_html/catalog/includes/functions/sessions.php on line 67

 

 

although the reesults are there and the rest of the site is O from then on....but thje error lines are at the top for that moment right after voting

 

Any ideas ?

 

dca

Share this post


Link to post
Share on other sites

Hello,

 

i have read a lot of problems around pollbooth.

i have it working, almost 100%

but this BUG, when comments are disable or not, I can still comment the poll isn't still solved or i have haven't seen it :blink:

 

is there a solution? or can someone point me to the right place.

 

thanks

Jan

 

Sorry second question, is it possible that only registrered customers can add a comment?

Edited by jan64

Dreams can come true, if you help them a littlebit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×