Jump to content
Sign in to follow this  
moyashi

OrderCheck v 1.3 Released

Recommended Posts

still busy but this definitely looks like an idea to follow-up on.

 

Thanks :D


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

Hey Moyashi!

 

Any news on the double recurrence of the sub-total, total, VAT etc.

on the checkout page?

 

Hope you've found the solution cos I've staring myself blind on the code but it wont give up it's secrets to me... :cry:

 

cya

 

DicE


_____.:::.________###__________|/______

:(o o): . (o o) (o o)

ooO--(_)--Ooo-ooO--(_)--Ooo-ooO--(_)--Ooo-

Share this post


Link to post
Share on other sites

Here is what I think. The double display is caused by the the repeating of a function that is contained in ORDERCHECK_FUNCTIONS and order_total.php. I am not a programmer so that is as far as I can go!

 

Thomas

 

quote="DicE"]Hey Moyashi!

 

Any news on the double recurrence of the sub-total, total, VAT etc.

on the checkout page?

 

Hope you've found the solution cos I've staring myself blind on the code but it wont give up it's secrets to me... :cry:

 

cya

 

DicE

Share this post


Link to post
Share on other sites

ok, I bailed on this contribution then installed MS1 and now I am trying to install this contribution again:

 

Two things are happening wrong -

1) the paypal option is not showing up in the shipping choices, although clearly it is checked off properly in the admin section.

 

2) when I do choose the other method available to me - MoneyOrder - when I click on "confirm order" it has an error ERROR_NO_CONDITIONS.

 

Any help would be appreciated.


Thanks,

 

Karole

Share this post


Link to post
Share on other sites

Just installed this contribution, looks great but I have the same problem as mentioned above, double trouble.

 

Anyone got the answer?

 

 

Plus my incomplete orders are getting processed to the database but not displaying in the admin, any help would be appreciated.

 

Nev

Share this post


Link to post
Share on other sites

Oh no just come across a huge problem for me.

 

Since installing the mod all my successful orders and unsuccesful have been held in the database, but none have come through to the normal orders page in the admin or the new ordercheck page!!

 

I have just removed the mod, I am now having to decipher the info in the database to match with my payment provider details.

 

Why did this happen?

 

Any ideas?

 

Nev

Share this post


Link to post
Share on other sites

sorry no idea. The only problem I've come across have been listed here with the double totals. Pesty bugger since I can't get it to do it on my machine.

 

(PS ... I just got a new logic board for my iBook today ... the price was pretty hefty too ... which is why I haven't been here at osC.)


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

What osC version are you running? I am using loaded 5!

 

We might be able to figure it out..

 

Thomas

 

sorry no idea. The only problem I've come across have been listed here with the double totals. Pesty bugger since I can't get it to do it on my machine.

 

(PS ... I just got a new logic board for my iBook today ... the price was pretty hefty too ... which is why I haven't been here at osC.)

Share this post


Link to post
Share on other sites

Well I installed and had more bugs than I can imagine. All the errors listed, I had. I uninstalled...to many bugs for me at this moment.

Great Contrib though it we can get the bugs worked out :)

Share this post


Link to post
Share on other sites

I think I found the issue with the double trouble (at least this seems to work for me):

 

comment out the following line in catalog/includes/functions/order_check_functions.php:

 

$order_totals = $order_total_modules->process();

 

this gets called twice (or more) depending on the other contribs installed, especially when you have Ian Wilson's Credit Voucher Contrib installed.

 

Hope this helps - Cheers,

 

- D. Michael Henninger

Share this post


Link to post
Share on other sites

I can not find the line that you mentioned. Does your program contain the following at the end of the file.

 

Thomas

 

 

-------------

osCommerce, Open Source E-Commerce Solutions ---- http://www.oscommerce.com

Copyright © 2002 osCommerce

Released under the GNU General Public License

 

IMPORTANT NOTE:

 

This script is not part of the official osC distribution but an add-on contributed to the osC community.

Please read the NOTE and INSTALL documents that are provided with this file for further information and installation notes.

 

script name: OrderCheck

version: 1.3

date: 2003-05-02

author: Carsten aka moyashi

web site: www..com

paypal: carsten@hakuja.com

-----------------------------

 

I think I found the issue with the double trouble (at least this seems to work for me):

 

comment out the following line in catalog/includes/functions/order_check_functions.php:

 

$order_totals = $order_total_modules->process();

 

this gets called twice (or more) depending on the other contribs installed, especially when you have Ian Wilson's Credit Voucher Contrib installed.

 

Hope this helps - Cheers,

 

- D. Michael Henninger

Share this post


Link to post
Share on other sites

Sorry the file is catalog/includes/functions/ordercheck_functions.php - here are the first lines of the file, basically it's the first statement of the file which I commented out:

 

<?php

 

// ------------------------------------------------------------------------------

// data insert functions below.

 

// the following line was commented out:

//$order_totals = $order_total_modules->process();

 

// ------------------------------------------------------------------------------

...

?>

Share this post


Link to post
Share on other sites

Hi there,

 

I'm having a problem with this contribution.

 

Its working fine-ish for paypal, the order is logged and shows up in the admin>orders page, but it doesnt work for other payment options, (i have one called WorldPay)

 

Also the orders thats are being logged show up in the holding orders tables when i look at the database but dont show up in the admin panel under the Order Check page?

 

Any help would be appreciated.


Reddy to Rumble

 

Thank you osCommerce and all who Contribute to her!

Share this post


Link to post
Share on other sites
Also the orders thats are being logged show up in the holding orders tables when i look at the database but dont show up in the admin panel under the Order Check page?

 

Any help would be appreciated.

 

I am having the exact problem above. I tried a couple tests where I left osC (one to PayPal and one to 2Checkout) and the orders do appear in the tables as I verified that there was data in them, but on the OrderCheck page (Admin --> Customers -> OrderCheck) the page stops rendering right before displaying the held orders. In other words, when I view the HTML source on this page, it stops right before rendering the held orders. In the admin it creates the top menu bar, left nav. bar, the order ID search function (which works) and stops right after this...

 

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<form name="orders" action="https://XXXXXXXXXXXXXX.com/catalog/admin/orders_check.php" method="get">  <td class="smallText" align="right">Order ID: <input type="text" name="ocID" size="12"><input type="hidden" name="action" value="edit"></td>

</form>

</tr>

<tr>

<form name="status" action="https://XXXXXXXXXXXXXX.com/catalog/admin/orders_check.php" method="get">  <td class="smallText" align="right">

 

I am using osC 2.2ms2, MySQL 3.22.26a and php 4.3.0.

 

*ANY* help would be greatly appreciated.

 

Thanks in advance!

 

Justin =)

Share this post


Link to post
Share on other sites

Maybe a (late) solution for MS2 and "no holding orders at admin" and "double tax, etc.":

 

Replace at catalog/checkout_confirmation.php (about Line 300):

<?php

 if (MODULE_ORDER_TOTAL_INSTALLED) {

   $order_total_modules->process();

   echo $order_total_modules->output();

 }

?>

 

with:

<?php

 if (MODULE_ORDER_TOTAL_INSTALLED) {

   echo $order_total_modules->output();

 }

?>

 

So, the $order_total_modules->process(); will be called at ordercheck_functions.php before these lines ...

 

... and everything works fine (for me :lol: )

Share this post


Link to post
Share on other sites
Maybe a (late) solution for MS2 and "no holding orders at admin" and "double tax, etc.":

 

Thanks for chiming in. I hope this helps some people :).

 

Unfortunately, it didn't help with the problem I have :( (see previous post for description).

 

If *anyone* can help with my problem of not being able to view the database (so I can move/delete/etc the held orders) in the ordercheck admin, please let me know.

 

Justin =)

Share this post


Link to post
Share on other sites

If it helps at all I installed the 'Holding Orders' contribution some time ago and it works fine with loaded5 apart from not restoring the attributes when it restores the order. The interface isn't as pretty as this one though.

 

The other simpler approach is to make use of the fact that uncompleted orders stay in the customer's shopping cart. Should something go wrong :

Just log in as the customer using your master password and complete the order yourself using the cheque/money order option

After that you simply change it back to Paypal, WorldPay or whatever using the 'Edit Orders' contribution.

 

hth

Share this post


Link to post
Share on other sites
OK, I redownloaded the tar and unzipped again - I reinstalled and am coming up with the same error.

I must be doing something wrong though if others can install this contribution and it is only me with this error.

I moved the:

// Begin OrderCheck

require(DIR_WS_INCLUDES . 'application_top_contribs.php');

// End OrderCheck

to the top of application_top.php and now the error is at line 13 instead of line 35 (where it had been coinciding with where I had it placed the first time).

Any suggestions would be appreciated.

 

~:~ Karole

 

 

I never made it past this error when I tried to install this contrib. Has anyone run into this and resolved it?

Share this post


Link to post
Share on other sites
If it helps at all I installed the 'Holding Orders' contribution some time ago and it works fine with loaded5 apart from not restoring the attributes when it restores the order. The interface isn't as pretty as this one though.

 

Are you talking about this?

 

http://www.oscommerce.com/community/contributions,1153

 

Does it work with MS2 okay? I might give it a try.

 

I can't seem to get OrderCheck v1.3 to work :(.

 

Justin =)

Share this post


Link to post
Share on other sites

I've gotten farther with the OrderCheck contribution :).

 

1) The reason my admin wasn't rendering was becuase it was choking on this from admin/orders_check.php (around line 455):

 

<?php echo HEADING_TITLE_STATUS . ' ' . tep_draw_pull_down_menu('status', tep_array_merge(array(array('id' => '', 'text' => TEXT_ALL_ORDERS)), $orders_statuses), '', 'onChange="this.form.submit();"'); ?>

 

I had to change "tep_array_merge" to "array_merge" for the admin to work. So now the line looks like:

 

<?php echo HEADING_TITLE_STATUS . ' ' . tep_draw_pull_down_menu('status', array_merge(array(array('id' => '', 'text' => TEXT_ALL_ORDERS)), $orders_statuses), '', 'onChange="this.form.submit();"'); ?>

 

2) After that, like a lot of you, I had duplicate totals so I had to comment out one of these redundant lines:

 

$order_total_modules->process();

 

3) But NOW, I have another problem. Whenever I (actings as a test customer) tried to finish my checkout (when getting to the checkout_process.php page) I would get the following error...

 

1062 - Duplicate entry '1' for key 1

 

Then if I tried again...

 

1062 - Duplicate entry '2' for key 1

 

...where the problem was the checkout process was trying to use the highest (or max) orders_id from the holding table as the value to complete the order by trying to write an order with that order_id in the regular orders table. In the above example "1" and "2" already existed in key 1 (order_id), or in other words, I already had orders stored as Order Number:1 and 2.

 

What is the best solution?

 

Justin =)

Share this post


Link to post
Share on other sites
Hello,

I am trying to install this contribution. I think I installed everything correctly but this is my error when i try to view it in browser.

 

Warning: main(DIR_WS_INCLUDESapplication_top_contribs.php) [function.main]: failed to create stream: No such file or directory in /home/karolep/public_html/catalog/includes/application_top.php on line 35

 

Fatal error: main() [function.main]: Failed opening required 'DIR_WS_INCLUDESapplication_top_contribs.php' (include_path='') in /home/karolep/public_html/catalog/includes/application_top.php on line 35

 

 

I checked on line 35 of the application_top.php file and it is this addition:

 

// Begin OrderCheck

require(DIR_WS_INCLUDES . 'application_top_contribs.php');

// End OrderCheck

 

Seems I am stuck at the first step.

 

Any assistance would be greatly appreciated.

 

Karole

 

did anyone else have an error similar to this one? how did you resolve it?

Share this post


Link to post
Share on other sites

:?:

 

Hello,  

I am trying to install this contribution. I think I installed everything correctly but this is my error when i try to view it in browser.  

 

Warning: main(DIR_WS_INCLUDESapplication_top_contribs.php) [function.main]: failed to create stream: No such file or directory in /home/karolep/public_html/catalog/includes/application_top.php on line 35  

 

Fatal error: main() [function.main]: Failed opening required 'DIR_WS_INCLUDESapplication_top_contribs.php' (include_path='') in /home/karolep/public_html/catalog/includes/application_top.php on line 35  

 

 

I checked on line 35 of the application_top.php file and it is this addition:  

 

// Begin OrderCheck  

require(DIR_WS_INCLUDES . 'application_top_contribs.php');  

// End OrderCheck  

 

Seems I am stuck at the first step.  

 

Any assistance would be greatly appreciated.  

 

Karole

 

 

I am having the exact same problem. Odd to say the least, as I don't see any obvious errors in the code. Has anyone found a solution? Please help....This contibution would help me out greatly. Some orders mysteriously disappear, and I think this contrib. will resolve the issue IF I can get the thing to work.

 

Thanks in advance,

 

Matt

Share this post


Link to post
Share on other sites

is anyone considering updating this for MS2.2?

it would be a great thing to have as i currently have "logging orders before checkout" but would love to have the admin that this contribution offers. any help? please? pretty please?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×