Jump to content
Sign in to follow this  
Ian

[Contribution] Credit Class/Gift voucher/Discount Coupon v5

Recommended Posts

Are there suppose to be 2 boxes or just one to reedeem coupon and voucher they are both in the same box.

Also after installing it images of the products are not appearing in the basket page?

can some one help me

Share this post


Link to post
Share on other sites

When I send a gift thingy the and click the link in the email the page tries but never loads. It has been about 30 min now and I got a white page where it is still tring to load /gv_redeem.php/gv_no,982ec4 I tried changing the permitions on gv_redeem.php to 755, 777 nothing seems to work. I seen a message about this but didn't see a fix for it. Please help me sort this out.

Thanks

 

Great script by the way.

Share this post


Link to post
Share on other sites

Hi,

 

finally I thougth except the queue the gv5.03 is working. But now I figured out, when I send a giftvoucher from admin to somebody, he clicks on the email link, the shop opened and in his shopping cart is the amount i.e 10 Euro. But I was shocked, all costumers in the shop had then the same amount in the table gv_coupon_costumer.

 

I know another one with the same problem.

 

Does anybody know what this could be?

 

Devon

Share this post


Link to post
Share on other sites

Posted: Mon Jun 30, 2003 9:50 am Post subject: Error Table 'dappasco_store.TABLE_GV_CUSTOMER' doesn't exist

 

--------------------------------------------------------------------------------

 

I am running march of 2003 snapshot. i added the gift voucher contribution and it worked fine until I had some other problems which when fixed I now get this error during checkout. There is no left colum only this error there. being new to php I am lost with this one. I am getting this error message:

 

1146 - Table 'dappasco_store.TABLE_GV_CUSTOMER' doesn't exist

 

select amount from TABLE_GV_CUSTOMER where customer_id = '9'

 

[TEP STOP]

 

Does anyony know how to fix this problem?


I want to believe.

Share this post


Link to post
Share on other sites

ok heres the only error I get,

 

insert into gv_tracking (gv_number, date_created, customer_id_sent, sent_firstname, sent_surname, emailed_to, gv_amount) values ('203e273cb55aceb6', NOW(),'0','Sent by','Admin','test@test.com','39.9900')

 

there is no table gv_tracking it's missing from the SQL Dump included in the main package, other than that it was pretty easy to install.

 

Good work guys.

Share this post


Link to post
Share on other sites

Hi everyone, I am trying to install the Credit module for an 8th time, is that is right, an 8th time. I posted a couple of messages before with no replies, hopefully someone will reply to this post.

 

Since I could not get v5.03 to work, I decided to start with v5.0 and work my way up but I'm getting the following error during check out with v5.0.

 

Fatal error: Call to undefined function: update_status() in /home/ibigbaby/public_html/catalog/checkout_confirmation.php on line 51

 

Anyone have any ideas why I am getting this error?

 

I had to copy and paste the Credit Voucher code in to my files because I already have other modules installed.

 

For those who plan to ask me what snapshot I'm using, you'll have to tell me how to find out that information because the OSC I'm using was installed through C-Panel provided by the web hosting company I'm with.

 

Andrew

Share this post


Link to post
Share on other sites

I just installed this contrib, but my info box has disappeared.

 

As soon as I add the line to the information.php file, the info box disappears.

 

The pages are all there, they can be called directly.

 

I have the include file on the english.php (I have even tried placing the contents of this into english.php.

 

Any ideas what I might be missing?

Share this post


Link to post
Share on other sites

You might want to try posting whats in your information.php, if you copied and pasted the code in there is probably a syntax error in it as you have to change the line before to add the ICW line

 

You have to change the end of the last line to , (comma) instead of );

eg)

'<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a><br>',  //<-- this was ); 

'<a href="' . tep_href_link(FILENAME_GV_FAQ, '', 'NONSSL') . '">' . BOX_INFORMATION_GV . '</a>');//ICW ORDER TOTAL CREDIT CLASS/GV

 

I just installed this contrib, but my info box has disappeared.

 

As soon as I add the line to the information.php file, the info box disappears.

 

The pages are all there, they can be called directly.

 

I have the include file on the english.php (I have even tried placing the contents of this into english.php.

 

Any ideas what I might be missing?

Share this post


Link to post
Share on other sites
You might want to try posting whats in your information.php, if you copied and pasted the code in there is probably a syntax error in it as you have to change the line before to add the ICW line

 

You have to change the end of the last line to , (comma) instead of );

eg)

'<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a><br>',  //<-- this was ); 

'<a href="' . tep_href_link(FILENAME_GV_FAQ, '', 'NONSSL') . '">' . BOX_INFORMATION_GV . '</a>');//ICW ORDER TOTAL CREDIT CLASS/GV

 

That fixed it, thanks!

Share this post


Link to post
Share on other sites

hallo,

 

i have an error, redeem giftvoucher in checkout process:

 

ERROR_REDEEMED_AMOUNT 10.00EUR

 

can someone help me?

 

all bugs, updates i have already included.

 

sorry,my english

 

greetings from germany

 

didi

Share this post


Link to post
Share on other sites
Does anyone know why installing CGV 5.03 would cause orders not to be listed in the admin->customers->orders section?

 

If it is simply a code in one of the files we're suppose to edit, could that could just be removed without screwing up the entire CGV mod?

 

Andrew

 

This is the issue I am having too... I posted a thread in this forum yesterday, but it got buried..

 

It's a great mod, this is the only problem I am having :)

 

TIA!

Share this post


Link to post
Share on other sites

First Tanya, don't expect to see a reply to the question of why 5.03 causes the orders not to show up in admin. The question has been asked numerous times and no one has given an answer. Must be a mystery that no one can figure out. :-)

 

I do have two other errors that hopefully someone know the answer to.

 

The first one is with v5.0. I copied the proper items over and would received an error pertaining to the following line:

 

$payment_modules->update_status();

 

That line is in my checkout_confirmation.php file around line 51. The error had something to do with update_status so I put // in front of the line and everything seem to be working fine.

 

What is that line and is it really important?

 

 

After solving that, I started to upgrade from v5.0 to v5.03. When completed I got a parse error in my checkout_payment.php file on a line that didn't even exist. The error would give say line 412 but the file only had 411 lines.

 

Anyone know what would cause this such error?

Share this post


Link to post
Share on other sites

the update_status() function is from whichever payment module you are currently using on that page, so it could be important or may not. For the money order module it just does a check on the zone_id/billing_zone. If you are using a different module you may just want to see what they are doing or put an empty update_status() if you use multiple payment modules.

 

When you get an error on a line number past the last line number it usually means you are missing an ending bracket (}) somewhere, you may want to check through for that (or maybe a missing semi-colon) some editors help with this a lot as they show you which brackets match up. (I personally use jedit http://www.jedit.org which handles this very well.)

 

First Tanya, don't expect to see a reply to the question of why 5.03 causes the orders not to show up in admin. The question has been asked numerous times and no one has given an answer. Must be a mystery that no one can figure out. :-)

 

I do have two other errors that hopefully someone know the answer to.

 

The first one is with v5.0. I copied the proper items over and would received an error pertaining to the following line:

 

$payment_modules->update_status();

 

That line is in my checkout_confirmation.php file around line 51. The error had something to do with update_status so I put // in front of the line and everything seem to be working fine.

 

What is that line and is it really important?

 

 

After solving that, I started to upgrade from v5.0 to v5.03. When completed I got a parse error in my checkout_payment.php file on a line that didn't even exist. The error would give say line 412 but the file only had 411 lines.

 

Anyone know what would cause this such error?

Share this post


Link to post
Share on other sites

Thanks for your reply Sterling and I'll give that jedit program a try. I've been using Winmerge which is nice, just wish the program would allow the user to choose part of a highlighted section to transfer over to the comparing file.

 

Andrew

Share this post


Link to post
Share on other sites

Hello Ian,

This is an nice contribution, but i have one problem....

The calculation of the total price is not corect if i redeem an coupon.

on the checkout confirmation page i see the following:

 

 

Sub-Totaal: 82.76EUR 

shipping: 4.50EUR 

tax: (19%) 13.21EUR 

coupon:47274a: 5.00EUR 

Totaal: 81.50EUR

 

the total here is81.50 but if i calculate it it has to be 82.26

tis is thesort order i have on the modules -> order total page:

 

coupon 5     

gift voucher 4     

small order cost none      

shipping 2     

Sub-Total 1     

tax 3     

Totaal 6

 

and this is what i fillt in on the coupon

coupon 



Display Total

true



Sort Order

5



Include Shipping

true



Include Tax

true



Re-calculate Tax

None



Tax Class

BTW hoog

 

I have done it on evry way i can thinck, but watever i do the calculation of the total price is wrong when i redeem an coupon.

Can you (or some one else) please help me with is it's driving me crasy :(

 

One other quistion:

discount_coupon_NC_v0.95 is that an complete other contribution or do i have to install that one to?

I saw i is replacing a lot of the files of your contribution.

Hope someone can help me

 

Anne

Share this post


Link to post
Share on other sites

Hi,

Can anyone pleaseeeeeeeeeeee help me

i stil have an problem with the calculation of the total price!!

if i put in the configuration to show the products without tax it's al going oke, but when i show the prices with tax it isnt posible to use the coupons becouce the calculation of the total price is not good:

 

Sub-Totaal: 80.00EUR

Per post (berekend aan de hand van order totaal.): 4.50EUR

Kortingsbonnen:ce63c7: 6.50EUR

totaal btw in bestelling: (19%) 11.54EUR

Totaal: 76.77EUR

 

i'm already working for 3 days on this problem and can't get it fixt.

Pleasy help me!!!!!!!!!!!

 

Dani?l

Share this post


Link to post
Share on other sites

Hi,

 

First of all great work, Ian. Very impressive.

 

Now my problem:

 

I have everything working properly except no entries are made to the coupon_redeem_track table. The order shows up properly in Customers/Orders and the discount/voucher is calculated correctly but the voucher report has no entry. :?

 

Which page is actually responsible for entering the voucher/discount coupon information into coupon_redeem_track?

If anyone knows, I'd be very grateful.

 

Thanks.

Share this post


Link to post
Share on other sites
Hi,

 

First of all great work, Ian. Very impressive.

 

Now my problem:

 

I have everything working properly except no entries are made to the coupon_redeem_track table. The order shows up properly in Customers/Orders and the discount/voucher is calculated correctly but the voucher report has no entry.  :?  

 

Which page is actually responsible for entering the voucher/discount coupon information into coupon_redeem_track?  

If anyone knows, I'd be very grateful.

 

Thanks.

 

I did a search through all the files that use it (it appears to be working fine on mine, here's the listing along with line numbers (approximate as I have a few mods)

 

catalog/includes/classes/shopping_cart.php:46

catalog/includes/modules/order_total/ot_coupon.php:337

catalog/includes/modules/order_total/ot_gv.php:168

catalog/gv_redeem.php:42

 

Check those out and make sure all of them have an insert into the coupon_redeem_track

Share this post


Link to post
Share on other sites

Hi Ian,

 

I seem to be having a few problems, hopefully you can address.

 

First, I read earlier, that this mod did not work with Authorize.net. Is this still the case?

 

I am using v.5.03 on OSC2.2MS1, I have two additional mods installed. The Dynamic menu, and the OSAffiliate.

 

The problems I seem to be having are this.

 

I sent myself a $25 voucher. I clicked the link to redeem it. It appears in the cart as a Voucher redeeed.

 

I did a test purchase of 199.95, free shipping, no tax, and my total was 173.95. Why did it discount $26?

 

Second, I have just realized, once I try to add or modify a product in the catalog, when I preview, I get the header and the menu, but nothing else. Looking at the source of the generated page, it ends one line into the <body>.

 

This is the last line: <!-- body_text //-->

<td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="2">

 

It is no doubt a syntax error, but I am not sure where I should be looking.

 

I am also certian that this problem surfaced due to a problem with the install of this module. It was working prior to this.

 

Any suggestions?

 

Thnaks in advance.

Share this post


Link to post
Share on other sites
Hi,

Can anyone pleaseeeeeeeeeeee help me

i stil have an problem with the calculation of the total price!!

if i put in the configuration to show the products without tax it's al going oke, but when i show the prices with tax it isnt posible to use the coupons becouce the calculation of the total price is not good:

 

Sub-Totaal: 80.00EUR

Per post (berekend aan de hand van order totaal.): 4.50EUR

Kortingsbonnen:ce63c7: 6.50EUR

totaal btw in bestelling: (19%) 11.54EUR

Totaal: 76.77EUR

 

i'm already working for 3 days on this problem and can't get it fixt.

Pleasy help me!!!!!!!!!!!

 

Dani?l

 

Check in admin under order total - set it to subtotal first, then coupon deduction, then the rest with tax coming before total or before shipping if you have to charge tax on shipping


"If you rundown your shadow, you will never catch it"

Bob Marley

Share this post


Link to post
Share on other sites

I just completed installing the credit class & Gift Voucher. When I use the admin console, all I get is the menu on the left screen. I am pretty green to php, so any help would be greatly appreciated.admin_problem.jpg

Share this post


Link to post
Share on other sites
I just completed installing the credit class & Gift Voucher. When I use the admin console, all I get is the menu on the left screen. I am pretty green to php, so any help would be greatly appreciated.admin_problem.jpg

 

 

OK I Found it. It was just a typo in column_left.php

Share this post


Link to post
Share on other sites

OK, I have been working on this for quite a while and am not getting very far. I have just installed credit class v5.03 and am having trouble getting the modules to appear under Admin->Modules->Order Total. Nothing shows up when I put ot_coupon.php and ot_gv.php in the catalog/includes/modules/order_total directory. If I remove them the rest of the modules show up. As soon as I put them back in, everything disappears.

Any Help would be greatly appreciated.

Share this post


Link to post
Share on other sites

Hi.

 

I have just installed this contrib on MS2 and it works of sorts. I can send vouchers, coupons, I can fully use the admin functions and have setup order section ok.

 

My problem is that I can see the voucher at the bottom of the shopping cart, but the box that appears during the checkout process just mentions gift voucher but with no amounts at all and doesn't discount anything at checkout. The same is happening with discount coupons.

 

Has anyone managed to run this contrib successfully under MS2?

 

Where would I be best to start looking to try and rectify this fault?

 

Many thanks

 

Brent

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×