Jump to content
Sign in to follow this  
Ian

[Contribution] Credit Class/Gift voucher/Discount Coupon v5

Recommended Posts

BTW the contribution is based on being insatlled on 5/18 code or earlier.

 

Don't even try installing on later code, it just won't work.


Trust me, I'm an Accountant.

Share this post


Link to post
Share on other sites

Ian,

 

Any guess on when a version compatible with the New Account (post 5/18) might be complete? Thanks.


Ryan Thrash

Share this post


Link to post
Share on other sites

Ryan,

 

Hard to say, the 5.04 version is ready and I would like to see how that goes before releasing a post 18/5 version.

 

Most of the problems would be on the admin side, because of the changes to the split_page_results class.

 

I've already made a small start on this in a new cvs branch but you are probably looking to the weekend for a pre-release version.


Trust me, I'm an Accountant.

Share this post


Link to post
Share on other sites

The 5.04 code is now ready, however rather than release now, I was hoping there would be a couple of people who could test the install before a proper contribution release.

 

Let me know if you want to give it a try.


Trust me, I'm an Accountant.

Share this post


Link to post
Share on other sites

Hi -

 

I am having problems getting the discount coupon codes to work. I have installed the Credit Class and Gift Voucher module along with it.

 

Everything works great (as far as I can tell) on the admin side, but on the customer side it never comes up for a code to be entered? Where is the user suppose to enter it?

 

Am I missing something?

 

Thanks ahead of time.

 

SMurphy

Share this post


Link to post
Share on other sites

Now it doesn't recognize gift vouchers either - I'm guessing that they both have the same problem.

 

I sent myself, the customer, a gift voucher via the admin panel. I, the customer, logged in to use my voucher - but it never deducted from my order - instead it just gave me the option to send to a friend. So - I sent it to a friend - myself, again - and again, the voucher deducted nothing from my total - it only gave me the option to send it off again. ??

 

I'd really hate to reinstall all this stuff - because I had a lot of custom coding I had to dance around. So - if anyone can point me in the right direction I would greatly appreciate it.

 

SM

Share this post


Link to post
Share on other sites

Not sure why, but a customer that I sent $40 in Gift Vouchers, ended up with $123 in their account, the same as the amount that I had in my test account? :(

Share this post


Link to post
Share on other sites

I have the discount coupons working - and I disabled the gift vouchers - because I don't need them. I just buckled down and reinstalled. Things appear to be working well.

 

SM

Share this post


Link to post
Share on other sites
Not sure why, but a customer that I sent $40 in Gift Vouchers, ended up with $123 in their account, the same as the amount that I had in my test account?

 

what did the admin->Gift Vouchers sent have to say about this.


Trust me, I'm an Accountant.

Share this post


Link to post
Share on other sites

Initially I had tried to send her a GV & for some reason it came up as $0, even though on the confirmation screen, it indicated that I was sending $40. So then I had to resend.

 

I checked in the GV Sent to make sure it was the correct amount this time. Then she contacted me & told me that when she redeemed it & there was $123 in her account, the same that was in my test account which was above hers in the sql table?????

Share this post


Link to post
Share on other sites

 

Another thing, in shopping_cart.php I had to change "java script:couponpopupWindow" to "java script:popupWindow" and to add a java script function "function popupWindow(url)" in order to get the popup to work. The popup function "function popupWindow(url)" is defined in some pages but not all -> do popup is not working everywhere (checkout_payment.php and checkout_confirmation.php)

 

/Fred

 

Fred, can you give me some more detailed instructions how to solve the popup problem. I have 5.03 installed but popup doesn?t work

 

Thanks a lot !!

 

Marc

Share this post


Link to post
Share on other sites

teebee,

 

Very weird, I do have a possible explanation. First does the sent to friend email have an sid in the redeem link ?

 

If so this could possibly explain what is happening


Trust me, I'm an Accountant.

Share this post


Link to post
Share on other sites

Hello,

 

Still having checkout issues. The amount redeemed from gift voucher on purchase does not get deducted from GV account balance. Orders do not reflect the form of payment when using GV, reports do not show it either.

 

Strange occurances as well. When an existing customer would check out the tick button and billing address info would not appear on the checkout_payment screen. When the same user on the same computer signed up a new account and checked out everything appeared as it should.

 

MJS

Share this post


Link to post
Share on other sites

Hallo

 

I have a Problem with this Script. After i ad a Item to my Basket and go to checkout I receive a mistake message (404)

 

This this probably lies with the file (checkout_shipping.php), however, lies on my server.

 

If an idea has here one what this can be

 

Sorry my english is not good.

 

W?re cool wenn mir einer auf deutsch helfen k?nnte. Per PM oder Email. Besten Dank

Share this post


Link to post
Share on other sites
Fred, can you give me some more detailed instructions how to solve the popup problem. I have 5.03 installed but popup doesn?t work

 

Thanks a lot !!

 

Marc

 

Hi Marc,

make sure that your catalog/include/boxes/shopping_cart.php begin with:

 

<!-- shopping_cart //-->

<!-- ICW GV start //-->

<script language="javascript"><!--

function couponpopupWindow(url) {

 window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=yes,resiza
ble=yes,copyhistory=no,width=450,height=310,screenX=150,screenY=150,top=150,left=
150')

}

//--></script>

<!-- ICW GV stop //-->

 

I missed to add the java script function when I first installed the GV & CC addon.

 

I hope this will help you,

Fred

Share this post


Link to post
Share on other sites

Ian,

 

First of all, thank you very much for your contributions - weighing in at an average 3.93 posts-per-day in the left corner is Ian... !

 

I am running php v.4.3.1 and ms1 and have encountered the same problem that the people at greekretreat.com and that is that when I send out a voucher by email the total comes up to be $0.00 every time despite many efforts to lie, cheat and steal my way in! Foiled!

 

This is the exact text in the email voucher:

 

The Gift Voucher is worth $0.00

 

Simple as that, except I can't get it to work! Your help would be greatly appreciated. I tried to find your response to this question which was previously posted, but found no direct answer... ergo, this plead for help!

 

Thanks again,

 

Joe Wilson


-----

 

Thanks, Ian, for your contributions! :)

Share this post


Link to post
Share on other sites

Hello,

 

I am still wondering why the queue is not working. I set it in admin to true. Has anybody an idea. Would be nice.

 

Devon

 

Back to top

Share this post


Link to post
Share on other sites

Joe,

 

With such a great surname how can I not help (or is that really your surname and not just a ploy to attract my attention :lol: )

 

Is the problem you are having with Gift Vouchers sent by admin or gift vouchers sent by a customer to a friend.


Trust me, I'm an Accountant.

Share this post


Link to post
Share on other sites

Does anyone have a URL where I can see the Gift Voucher in action? I'd like to see how she actually performs and behaves before installing.

Share this post


Link to post
Share on other sites

Need Help. When somebody creates an account he gets 50 Euro gift voucher and an email mentioning a coupon. I dont have coupons active.

 

I blocked my side meanwhile.

 

Please answer me.

 

Thanks, Devon

Share this post


Link to post
Share on other sites

add_ccgcdc_application_top says:

 

// The settings below determine whether a new customer receives an incentive when they first signup

//

// Set the amount of a Gift Voucher that the new signup will receive, set to 0 for none

define('NEW_SIGNUP_GIFT_VOUCHER_AMOUNT', '0');

//

// Set the coupon ID that will be sent by email to a new signup, if no id is set then no email :)

define('NEW_SIGNUP_DISCOUNT_COUPON', '0');

 

I am usinf gv5.03 from 18.05.03

 

Devon

Share this post


Link to post
Share on other sites

Hi Ian -

 

The error occurs when we send out a gift voucher from the Admin section.

 

Who knows, maybe we're distant cousins or something!

 

Thanks!


-----

 

Thanks, Ian, for your contributions! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×