Jump to content
Sign in to follow this  
bobvin

affiliate_branding

Recommended Posts

I must have not explained myself correctly.

 

Regarding the logo field -

 

can i enter

 

logobanner.jpg into the field or do I have to enter:

 

http://www.domain.com/images/logobanner.jpg

 

 

Regarding the logo changing

 

If I click on an affiliate link and go to the store as a customer/visitor, i still see the original logo - not the affiliate's logo - where do I correct that?

 

As a visitor that has clicked on an affiliate's link - I should see the affiliates logo correct?

Share this post


Link to post
Share on other sites
Regarding the logo field - can i enter

logobanner.jpg

into the field or do I have to enter:

http://www.domain.com/images/logobanner.jpg

 

You should be able to enter

/images/logobanner.jpg

but the full URL should work as well.

 

Regarding the logo changing

If I click on an affiliate link and go to the store as a customer/visitor, i still see the original logo - not the affiliate's logo - where do I correct that?

 

As a visitor that has clicked on an affiliate's link - I should see the affiliates logo correct?

 

Hmm... That DID work before; lemme test the current code real quick...

 

Well, it worked when I put in a full URL. See http://shop.pillars.net/default.php?ref=11

 

Now I'm going to change it to a relative one...

 

Yup, that one works, too. See

http://shop.pillars.net/default.php?ref=12

 

So I dunno. Did you check your Apache error log?


The web is like usenet, but the elephants are untrained.

Share this post


Link to post
Share on other sites

can you tell me which file is used for that feature?

 

also, if there isn't a logo - does it default to the default logo image?

Share this post


Link to post
Share on other sites
can you tell me which file is used for that feature?

 

includes/header.php.

 

Here's the relevant part of the .diff file:

diff -ur catalog-base/includes/header.php catalog-branding/includes/header.php

--- catalog-base/includes/header.php    2003-03-13 22:34:26.000000000 -0500

+++ catalog-branding/includes/header.php        2003-04-29 19:17:14.000000000 -0400

@@ -50,7 +50,7 @@

?>

<table border="0" width="100%" cellspacing="0" cellpadding="0">

  <tr class="header">

-    <td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'oscommerce.gif', 'osCommerce') . '</a>'; ?></td>

+    <td valign="middle"><?php echo '<a href="' . AFFILIATE_HOMEPAGE . '">' . tep_image(AFFILIATE_HEADER_IMAGE, AFFILIATE_COMPANY) . '</a>'; ?></td>

 

also, if there isn't a logo - does it default to the default logo image?

 

Yup. From affiliate_application_top.php:

 

if ($affiliate_ref == 0) {

 define('AFFILIATE_ID',0);

 define('AFFILIATE_GENDER',0);

 define('AFFILIATE_FIRSTNAME','');

 define('AFFILIATE_LASTNAME','');

 define('AFFILIATE_DOB','');

 define('AFFILIATE_EMAIL_ADDRESS','');

 define('AFFILIATE_TELEPHONE','');

 define('AFFILIATE_FAX','');

 define('AFFILIATE_PASSWORD','');

 define('AFFILIATE_HOMEPAGE',FILENAME_DEFAULT);

 define('AFFILIATE_HEADER_IMAGE',DIR_WS_IMAGES . 'oscommerce.gif');

 define('AFFILIATE_STREET_ADDRESS','');

 define('AFFILIATE_SUBURB','');

 define('AFFILIATE_CITY','');

 define('AFFILIATE_POSTCODE','');

 define('AFFILIATE_STATE','');

 define('AFFILIATE_COUNTRY_ID','');

 define('AFFILIATE_ZONE_ID','');

 define('AFFILIATE_AGB',0);

 define('AFFILIATE_COMPANY','VDS_NAME');

 define('AFFILIATE_COMPANY_TAXID','');

 define('AFFILIATE_COMMISSION_PERCENT',0);

 define('AFFILIATE_PAYMENT_CHECK','');

 define('AFFILIATE_PAYMENT_PAYPAL','');

 define('AFFILIATE_PAYMENT_BANK_NAME','');

 define('AFFILIATE_PAYMENT_BANK_BRANCH_NUMBER','');

 define('AFFILIATE_PAYMENT_BANK_SWIFT_CODE','');

 define('AFFILIATE_PAYMENT_BANK_ACCOUNT_NAME','');

 define('AFFILIATE_PAYMENT_BANK_ACCOUNT_NUMBER','');

 define('AFFILIATE_DATE_OF_LAST_LOGON','');

 define('AFFILIATE_NUMBER_OF_LOGONS',0);

 define('AFFILIATE_DATE_ACCOUNT_CREATED','');

 define('AFFILIATE_DATE_ACCOUNT_LAST_MODIFIED','');

}


The web is like usenet, but the elephants are untrained.

Share this post


Link to post
Share on other sites

Has anyone been successful installing Loaded 5, oscaffiliate_vs_1.01 and affiliate_branding without any major problems?

 

Thanks,

 

Thomas

Share this post


Link to post
Share on other sites

[*]Did you do a clean (new) install, or did you patch an existing osCommerce installation? (I haven't written patch instructions yet)

 

This seems like it is going to be a very good mod, I am reluctant to install it on my existing store for that reason "I haven't written patch instructions yet"

 

 

Do you have a timeframe of when you think you may be able to complete this?

 

 

I guess no matter what you do everyone wants more. :)

 

Thank you for your great attention to everyone's questions and Keep up the great work!

Share this post


Link to post
Share on other sites
I am reluctant to install it on my existing store for that reason "I haven't written patch instructions yet"

 

 

Do you have a timeframe of when you think you may be able to complete this?

When somebody pays me to do so, I will. If somebody else writes them, I'll gladly accept patches. Otherwise, I'm not so bored that I'm willing to write stuff for free. See, I'm one of the bad guys. I write this stuff for a living. (Though I probably got paid more per month working at 7-11.)

I guess no matter what you do everyone wants more. :)

Question is, do they want it badly

enough to


The web is like usenet, but the elephants are untrained.

Share this post


Link to post
Share on other sites

Hi, I have a question about the BUILD-A-LINK feature. When I enter the product ID (is it same as product model?), no code is generated. Is it something I missed during setup?

 

Currently I am using easyPopulate to import my products.

 

Thanks

Share this post


Link to post
Share on other sites

I have succeeded in installing oscaffiliate_vs_1.01 on Loaded 5. Now the last task is affiliate_branding.

 

Thomas

 

Has anyone been successful installing Loaded 5, oscaffiliate_vs_1.01 and affiliate_branding without any major problems?

 

Thanks,

 

Thomas

Share this post


Link to post
Share on other sites

Hi have installed the mod and everything is fine except one thing.

 

When I log in as an affiliate I can a search will bring up all products belonging to the owner of the strore. I assumed that the mod was to allow you to have your own subset of products so that if a customers clicks on a link from a affiliates website they would be brought to the store and only see products that i have selected to be in the store. But when you do a search you see all the products......am I missing something

 

Thnx

Share this post


Link to post
Share on other sites

Hi

just installed this nice contrib and run into the same thing. Also Categories from which an affiliate has not chosen any products are still shown in the categories box. Since they are empty it will be nice to hide them. Looked at other posts about hiding empty categories but I think they don't apply here. What can be done to prevent this? any nice hack?

thanks

= )

Share this post


Link to post
Share on other sites

This has proven to be a very popular contribution with my customers, but they want more more more .......

Has anyone found a way to make the text in Default.php specific to the affiliate or the emails that are sent out branded with the affiliate company name?

 

TY

Theo


Share your knowlege and you learn even more !

Share this post


Link to post
Share on other sites

Hello everyone,

 

I have been trying to install this mod since last Monday and before I give up on it I wanted to ask you all for advice direction how to install this mod from start to finish I am doing something wrong.

 

I have installed the tep_snapshot-20030615 and OSC-Affiliate 1.01 they both works fine but when I install the affiliate_branding this is what I get.

 

Fatal error:  Call to undefined function:  tep_output_string() in /home/fine/public_html/store/includes/functions/html_output.php on line 81

 

I am sure that I am missing something and I don?t know what. Is there someone can help me to fix this problem or can someone write a how to install from scratch step by step.

 

All the best,

Share this post


Link to post
Share on other sites

I finished installing the modules, and all appear to be working great, just one little thing...

 

On the email that was sent to me when I created a test account, the return email address is: affiliatet@localhost.com and shows for the email name:

 

"Actual Name of Store"< (With the quotes and angle bracket)

 

Also, on the affiliate contact page, the From field shows:<affiliatet@localhost.com>

 

 

Where should I be looking to change this to the correct email address, and show the email name without the quotes and angle bracket?

 

Thanks all!

Share this post


Link to post
Share on other sites

I have installed oscommerce M2.2 and osaffiliate version 1.09. They seem to be stable together now. Is the present version of affiliate_branding stable enough to be included. I would like to include the mod. What are the proper steps for installing additionally to what I have now. I realize that I have to add to tables and put links in my header files. Can the database.php be left allone for my connection.

 

Thanks,

 

Martin

Share this post


Link to post
Share on other sites

Is Affiliate Branding going to be updated for MS2 and Affiliate 1.09

I have 3 customers who are using affiliate branding and they would love to upgrade.

TY

Theo


Share your knowlege and you learn even more !

Share this post


Link to post
Share on other sites

Yes, is anyone working on an update for MS2? Pertaining to affiliate-branding.

 

I apologize for my lack of php scripting ability, but these forums and people like you are my savior, and my source of knowledge.

 

I promise that I am learning more and more each day... anyone know of any good places for me to find some good php learning courses?

 

Thanks, each and every one of you!


.:) shadowmaxss (:.

shadowmaxss dot com/portal

I love loaded osc distros

Share this post


Link to post
Share on other sites

does affiliate_branding-2003-04-29 work with osc 2.2ms2 and oscaffiliate_vs_1.09_MS2?

 

i have many problems with this combination.

Share this post


Link to post
Share on other sites

I think affiliate branding was only ever a beta module, and i doubt it would work with MS2 and anyway you should be using the osCAffiliate 2.02 version with MS2 anyway :)

Share this post


Link to post
Share on other sites

You probably wont find any other language files besides english, as these are contributions from users of oscommerce. The gentleman who wrote this script as an add on to oscommerce, was generous enough to share it with the rest of the world. These "contributions" sometimes do not come with language files and sometimes the contributions are flawed or incomplete. These contributions are not software releases, or guarunteed add ons to oscommerce, and are made by people not associated with the oscommerce team. They are people like you and me. Well, they are better at it than I. :D

 

Max


.:) shadowmaxss (:.

shadowmaxss dot com/portal

I love loaded osc distros

Share this post


Link to post
Share on other sites

Alright, I am begging now.

 

Would someone be so kind and take a look at affiliate branding and update it to MS2? Or possibly lead me in the right direction to do it myself.

 

I am baffled.

 

max


.:) shadowmaxss (:.

shadowmaxss dot com/portal

I love loaded osc distros

Share this post


Link to post
Share on other sites

Sorry, but the affiliate_branding-Conribution dont work with MS2, i think :-(

 

 

Fatal error: Call to undefined function: tep_output_string() in c:\programme\apache group\apache\htdocs\oscommerce\catalog\includes\functions\html_output.php on line 81

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×