Jump to content
Sign in to follow this  
sfatula

Just contributed - Fedex Shipping Quotes

Recommended Posts

Yes, I do. The Fedex production server is having problems. Fedex is aware and are trying to fix it, but, it's been that way since some time Saturday.

 

You will get quotes sometimes, otherwise not. Heck, you can go to the Fedex web site and not get a quote most of the time too!

 

The new 2.0 does have a timeout which can lessen the sting.


Steve

Share this post


Link to post
Share on other sites

Steve,

 

First of all, great work and thanks for the contribution, I can't wait for version 2.

 

Maybe you have addressed this as I just skimmed the latest posts in this thread. But would it be possible to add a radio button to this contrib asking if the shipping address is a residential or commercial address?

 

I ask this because....My business address is in a residential area, therefore considered residential. But if I were to order something for my company and fill in the company field, it will give me ground rates that could slow the shipment, since I really only qualify for home delivery.

 

I placed three online orders tonight from three different websites. All three websites asked me this question using a radio button. I think it could possibly help and save us from future problems and be a valuable part of your contrib.

 

Just an idea.

 

Thanks for your time. :)


Lee

 

"Pleasure in the job puts perfection in the work" -- Aristotle

Share this post


Link to post
Share on other sites

Actually, I agree with you, but it's beyond the scope of this module. That's not data or functionality this module has access to, it would have to be coded at a much higher level in OSC. And it should be so it could be passed to UPS, and other modules that care if it is a business address.

 

You are correct, rating will be wrong if someone types "none" like some of my customers do, or as you say have a home business (as I do also). You just have to eat those. That's why I add a surcharge to the rate, just allows over the long haul to break even.

 

Anyway, if you are still there, send me an email and I will reply with version 2.0 so you can try it out. That way, once a user or 2 has it working (have 1 so far), I will release, hopefully Tuesday. just want a user or 2 to verify before uploading, and then findout out I made the usual stupid mistake.


Steve

Share this post


Link to post
Share on other sites

I am a straight up newbie. I've installed the new version of this module and believe I've followed all direction. The osCommerce version my host has is MS1. And this the error I get: Meter not set. Error 5012: Account number not in database. Is this a Fedex problem or mine? Is there like a waiting period after registering for an account number? I just got the number last night. Thank you. I did tried a search but haven't found an answer.

Share this post


Link to post
Share on other sites

How do you set Higher Rate then the one that is giving, I want to set rate like around 35% higher then the actuall cost.. how would i set that in the fedex 2.0??

Share this post


Link to post
Share on other sites

I have installed the Fedex module on the oscommerce 2.2 ms2.

 

I checked and found out curl enabled;

CURL support enabled

CURL Information libcurl 7.9.5 (OpenSSL 0.9.6b) (ipv6 enabled)

 

Everything seems fine, but I just doesnot get any reply after post.

 

the request is shown as follows:

 

0,"211"10,"XXXX"4003,"xxxx"4007,"xxxx"4008,"xxxx"4011,"xxxx"4012,"xx"4013,"xxxx"4014,"CA"4015,""99,""

 

There is no information missing from the request Tag.

Here is what I got from the _AccessFedex($data);

 

Server Error

This server has encountered an internal error which prevents it from fulfilling your request. The most likely cause is a misconfiguration. Please ask the administrator to look for messages in the server's error log

 

 

I am currently running at Linux RedHat 7.3 and I am connecting to gatewaybeta.fedex.com .

 

I checked all the possible error and run out of idea now? Thank you all .

 

grant

Share this post


Link to post
Share on other sites

ALL - please use the new thread for version 2.0, I have stopped monitoring this thread.


Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×