Jump to content
Latest News: (loading..)
Sign in to follow this  
JcMagpie

Support thread for Product Info page contact us addon.

Recommended Posts

This is the support thread for Product Info page contact us addon. Any issues post here.

A simple product_info addon it gives your customer the ability to contact you directly from the product info page.

You have 2 options by installing one of 2 files.

tpl_cm_jcm_product_info_contact_us_modal.php

tpl_cm_jcm_product_info_contact_us_modal.stock-contact form

image.thumb.png.8aaae22bf7b1433f56c8a1e27b05db14.png

The first is a fully new contact us modal. However it has an issue when product attributes are turned on. It will work but it adds a comment to your error log. This has something to do with the way forms are used on product info page which I have not been able to pin down! It still works but it up to you to decide to use it.

image.thumb.png.667804015352f2cf2a06c26b1fcd191a.png

The second ( you will need to rename the file .php) Is still a modal but used the current stock contact us page by opening a new window. You still have all the other options.

image.thumb.png.8b204b0453b12bfcd047927d5345a2b8.png

Both have a call now button option which uses my call button as default, if you have your own then just edit this line in tpl_cm_jcm_product_info_contact_us_modal.php around line 40.

Just replace “MODULE_NAVBAR_JCPHONE_PUBLIC_TEXT” with your button. Oh and as the instructions say just remove the // to get button to be visible. This is also where you can change the text that appears in modal header.

<!---------------------simply remove the // below if you need phone button, remember to change text------------------>
<h4 class="modal-title">Contact us by eamil. Or you can call us now &nbsp &nbsp<?php //echo MODULE_NAVBAR_JCPHONE_PUBLIC_TEXT; ?></h4></div>

Next open handler.php and edit line 24

$pp->sendEmailTo('info@tbyb.co.uk'); // ← Your email here  ... and put your email in place of the test site.

Next,

A basic GDPR statement is provided as a boiler plate you can edit this to your requirements. Make sure to replace all red stuff **business name** with your own details.

Just edit as required from line 120 in, tpl_cm_jcm_product_info_contact_us_modal.php

<!-- Place your GDPR text below this-->

At *Your business name* we understand that we have a responsibility to
protect and respect your privacy and look after your personal data.<br>
This Privacy Notice, inclusive of our General Terms of Service,
explains what personal data we collect, how we use your personal data,
reasons we may need to disclose your personal data to others and how we
store your personal data securely.<br>
GDPRData Protection law will take effect on 25 May 2018<br>
This Privacy Notice sets out your rights under the new laws.<br>
<br>

 

Again totally standalone with no core code change. Once you have copied all the files over go into admin/Content /Modules and install “JcM Product Info Contact us Modal “ and turn it on.

That’s it your done.

 

 

 


 

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, shiftyrecall said:

I am using: osCommerce Online Merchant v2.3.4.1 CE

That could be anything! is it Gold, Edge, Frozen BS3 or Edge BS4?  Also without a link to look at? It's a old one but looks to be working fine still.

https://tbyb.co.uk/product_info.php/the-matrix-p-6?osCsid=u9154113i5pksfp8ird216rsm7

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites

osCommerce 2.3.4.1 CE
=====================
osCommerce
+ Bootstrap v3  
+ jQuery
+ other external scripts

Status
======
FROZEN.  
From today onwards;

- no Issues will be accepted
- no Pushes will be accepted 

Minimum PHP Version
===================
7.0


Discussion Forum
================
https://forums.oscommerce.com/forum/107-oscommerce-online-merchant-community-bootstrap-edition/

Demo Site

=========
http://template.me.uk/234bs3/index.php

Thank You
=========
- all the Developers who supported the Project.
- all the Shopowners 
who supported the Project.
- all the osCommerce Forum Users who had their say over the years.
 

Share this post


Link to post
Share on other sites

😊 Yep see what your talking about. It's clearly a conflict with somthing your already running on the site.

This type of thing normaly happens when the modal plugin gets loaded more than once!  Looking at your html out put it's clear you have lots of duplication! This will alway cause problems.

<meta charset="utf-8">
    <meta name="robots" content="noindex, nofollow">
    <title>Mega menu for Store</title>
        <meta name="viewport" content="width=device-width, initial-scale=1">
  <!--  <link href="ext/bootstrap/css/bootstrap.min.css" rel="stylesheet" id="bootstrap-css"> -->
    <link href="//netdna.bootstrapcdn.com/bootstrap/3.1.0/css/bootstrap.min.css" rel="stylesheet" id="bootstrap-css">
    <script src="//netdna.bootstrapcdn.com/bootstrap/3.1.0/js/bootstrap.min.js"></script>
    <script src="//code.jquery.com/jquery-1.11.1.min.js"></script>


</style>
    <script src="ext/js/jquery-1.11.3.min.js"></script>
    <script src="ext/bootstrap/js/bootstrap.min.js"></script>
    <script type="text/javascript">

You can see this problem shown on this test demo.

http://next.plnkr.co/edit/WwgzRX?p=preview&amp;utm_source=legacy&amp;utm_medium=worker&amp;utm_campaign=next&amp;preview


 

Share this post


Link to post
Share on other sites

Your site need a lot of cleaning up but,

Removed lines 81 & 82
<!--<script src="./ICOM IC-M35 _ BRIDGER MARINE_files/bootstrap.min.js.download"></script>-->
    <!--<script src="./ICOM IC-M35 _ BRIDGER MARINE_files/jquery-1.11.1.min.js.download"></script>-->

Removed lines 334 & 335
<!--<script src="./ICOM IC-M35 _ BRIDGER MARINE_files/jquery-1.11.3.min.js.download"></script>
    <script src="./ICOM IC-M35 _ BRIDGER MARINE_files/bootstrap.min.js(1).download"></script>-->

and it work fine. 😊 scripts called over and over again will cause issues.

image.png.941bd33c9b8b0252657bfcce99a06463.png


 

Share this post


Link to post
Share on other sites

Hi,

I am trying to get  product variables like name, price,description etc included in the enquiry form email like this:

<div class="form-group">
                                <input type="hidden" class="form-control" id="product_info" name="product_info" value="<?php $_GET['products_id'];?>"/>       -----       THIS WORKS
                                </div>

<div class="form-group">
                                <input type="hidden" class="form-control" id="products_name" name='Product Name' value='<?php echo $_GET["products_name"]; ?>'/>   --------  products_name shows blank in email?
                                 </div>

 Only  the product ID seems to carry over in the email. Anyone have any pointers?

 

Thanks

Share this post


Link to post
Share on other sites

This is an old add-on that i have not updated and have no plans to. It's a simple contact form that lets your customer ask questions about a product. The product id id included in the email. If you need more info then you will need to edit the code. A simple edit would be to add,

<input type="hidden" class="form-control" id="product_info" name="product_info" value="<?php echo 'http://' . $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI']; ?>"/>

This will include the link back to the product in the email. Edit it as you need.

image.png.657e2e0b822bde7e01c7cacf124d7549.png
                                   


 

Share this post


Link to post
Share on other sites

Ok it's a small edit to the class and template. I have no plans to update so pm me and your welcome to the code you can hack it to your needs.

image.png.f8cd40e9aaa040a1d5ce574ee2092afc.png


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×