Jump to content

Recommended Posts

hi,  @jandg425

Thanks for the addon.

had installed Excel Populate for Oscommerce(https://apps.oscommerce.com/9O5mP)  on 234.1 Edge version.
Can generate the excel files and can opened in the excel file, however, when tried to POPULATE. i have long list of error messages, mainly are about 2 lines in same file.
Notice: Uninitialized string offset: 2199023255040 in admin/includes/excel/olerad.inc on line 27

function GetInt4d($data, $pos) {
        return ord($data[$pos]) | (ord($data[$pos+1]) << 8) |  // line 27 (ord($data[$pos+2]) << 16) | (ord($data[$pos+3]) << 24);
}


Notice: Undefined index: in admin/includes/excel/olerad.inc on line 138

          $sbdBlock = $this->bigBlockChain[$sbdBlock];


Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in admin/includes/excel/ /oleread.inc on line 27

Can anyone please help? Thanks! Lyn

 

Edited by ce7

Share this post


Link to post
Share on other sites

This is the wrong forum for add-on questions, but two quick comments: 

 

        return ord($data[$pos]) | (ord($data[$pos+1]) << 8) |  // line 27 (ord($data[$pos+2]) << 16) | (ord($data[$pos+3]) << 24);

This probably doesn't parse properly.  Consider

        return ord($data[$pos]) | (ord($data[$pos+1]) << 8) | (ord($data[$pos+2]) << 16) | (ord($data[$pos+3]) << 24);

For the other line, try a smaller file.  It seems to be complaining that things are too big. 


Always backup before making changes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×