Jump to content
Latest News: (loading..)

Recommended Posts

Posted (edited)

Fresh install of 2.3.4  all seems OK even with import of old Database and conversion.  I've had a successful 2.2 installation for years and have learned a lot.

 

Problem now is when enabling SSL to true on new fresh 2.3.4 install.  I am getting DIR_WS_ADMIN added to all my links and images.

example:

<a href="https://www.xxxxxxxx.comDIR_WS_ADMINindex.php">

When SSL set to false (everything works) I get below

<a href="http://www.xxxxxxxx.com/catalog/admin/index.php">

 

Any ideas?

 

Thanks....

Edited by Gadget

Share this post


Link to post
Share on other sites

Before you go any farther, you need to be sure you are using the Community Edition of oscommerce. Then be sure you are not using an old configure file since it has changed. The error you are getting is due to a definition that Is not used in the latest versions.

Share this post


Link to post
Share on other sites
Posted (edited)

I had just installed the latest version through Network Solutions VPS. Thought it would be the best. Oh well. It said it was the latest.   So would it be best to wipe the whole thing and just start over? Or another approach...

Thanks

 

Edited by Gadget

Share this post


Link to post
Share on other sites

It is the latest version available through the control panel of hosts. That is because the site that provides those can only show the official version. So what you have is, most likely, the latest official version. But it is not currently support so the unofficial version is the one everyone uses. 

So, yes, you should wipe what you have and start over. There are too many differences between the two versions to try and upgrade what you have.

Share this post


Link to post
Share on other sites

Ok cool...  That was painless.  Should the database import be about the same as far as 'sql_upgrades_2-2ms_2-3-4'  worked ok on the other installation it just wasn't the responsive bootstrap version. 

 

Thanks again.  so far so good....

Share this post


Link to post
Share on other sites

No, the databases aren't directly compatible. There are a few threads on it here. If you haven't made changes to the database via addons, then you can do the following:

- Install a new database using the one included in CE package. If you have already done the installation, this is not necessary.

- Empty all of the tables in the new database - Remove the data but leave the structure.

- Make a copy of the original database and then delete the configuration and configuration_group tables from it.

- Dump the copy of the database (data only).

- Import the data backup you just made into the new shop database.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×