Jump to content
ce7

2.3.4.1 is it BS?

Recommended Posts

Hi

I had download few different BS version from oscommerce or github, spend lots of time to put different addons and always got problem and start all over again. Recently I download 2.3.4.1 from oscommerce product website, i thought this is BS version, but somehow I found that the front page will not change the size when i change the browser..... i just like to confirm 2.3.4.1 is BS version or where can i download the newest BS version, thanks!

Share this post


Link to post
Share on other sites

@ce7

No, the 'official' v2.3.4.1 version you can download from the osCommerce website is NOT the latest BS version. For that, go to the link in my signature below.

M

Edited by ArtcoInc

Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites
4 minutes ago, ArtcoInc said:

@ce7

No, the 'official' v2.3.4.1 version you can download from the osCommerce website is NOT the latest BS version. For that, go to the link in my signature below.

M

@ArtcoIncThank you so much for your reply. Have to start all over again.......whole week work is gone...... thank you again.

Share this post


Link to post
Share on other sites

@ce7

The official leader of the osC project has been absent for a while, and no 'official' development has happened. The Community got together to make the BS version. Without the 'blessing' of our absent leader, it can't become an 'official' release.

v2.3.4.1 was just a hot-fix to v2.3.4, which is several years old. And, as you have found out, it is not responsive.

I recognize how frustrating it is to have 'wasted' time on the wrong version. And, without our fearless leader to bless the BS version, it can not be included in the 'official' downloadables.

M

Edited by ArtcoInc

Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites
Just now, ArtcoInc said:

@ce7

The official leader of the osC project has been absent for a while, and no 'official' development has happened. The Community got together to make the BS version. Without the 'blessing' of our absent leader, it can't become an 'official' release.

v2.3.4.1 was just a hot-fix to v2.3.4, which is several years old. And, as you have found out, it is not responsive.

M

@ArtcoInc I had tried download from Github before, but the version has problem and I post on forum but can not get fix..... last month found new release on oscommerce site, thought finally has the 2.3.4.1 BS version, i was wrong.... wasted lots of time to install addons over and over....... not moving to other platform because oscommerce has lots of people in the forum to help out, like you now.... Hopefully a champion leader will show up soon for BS version... and hopefully the drag and drop template system will be consider at the same time. once again, thank you!

Share this post


Link to post
Share on other sites

@ce7

As with any open-source project, anyone can take the code and make their own fork. There are several BS forks of osC on Github. The one I pointed to is the one that @burt did, as he was the leader and driving force for the BS version.

M


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites
On 6/6/2018 at 9:48 AM, ArtcoInc said:

@ce7

As with any open-source project, anyone can take the code and make their own fork. There are several BS forks of osC on Github. The one I pointed to is the one that @burt did, as he was the leader and driving force for the BS version.

M

@ArtcoInc

@burt

hi,

 

spend couple days redo more then 10 addons on 234CE version.

Now trying to modify specials modules to something new....
1. want to be able to enable/disable the module,
2. admin can add/delete/copy the entry
3. after admin add the entries, can show on front page if module enable, have previous and next button, page split...

however now facing problems, trying to fix it, but before that I notice one issue,

with the product price, has the net price and gross price, and the tax rate not change, taxable goods 10%, for example if enter $100 the net price, it show on admin/categories.php page the gross price is $110, however on the front page, it is not showing $110 instead only $100, i am confused about this, can any help?

2nd question, the new forum, why i can mark the post like but can not mark LOVE as others did?

thanks!

Lyn

Share this post


Link to post
Share on other sites
18 hours ago, ce7 said:

@ArtcoInc

@burt

hi,

 

spend couple days redo more then 10 addons on 234CE version.

Now trying to modify specials modules to something new....
1. want to be able to enable/disable the module,
2. admin can add/delete/copy the entry
3. after admin add the entries, can show on front page if module enable, have previous and next button, page split...

however now facing problems, trying to fix it, but before that I notice one issue,

with the product price, has the net price and gross price, and the tax rate not change, taxable goods 10%, for example if enter $100 the net price, it show on admin/categories.php page the gross price is $110, however on the front page, it is not showing $110 instead only $100, i am confused about this, can any help?

2nd question, the new forum, why i can mark the post like but can not mark LOVE as others did?

thanks!

Lyn

admin / configuration / my store / display product with tax price / set as TRUE, it is the same, even set price with Taxable but it is still not showing Gross price (should be Net price + % tax rate price)..... any one please can help?

Share this post


Link to post
Share on other sites

Have you got a tax zone set up in admin and your store zone set?


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites
21 hours ago, BrockleyJohn said:

Have you got a tax zone set up in admin and your store zone set?

@BrockleyJohn

Hi Thank  you for your reply. :thumbsup:Yes I set up...

For other people who may have the similar problem, check the database tax_class and tax_rate.    I think what I did wrong is that I imported the tax class, tax rate, zones, geo_zones from old database, and somehow it mess up. :blush: I end up drop the these two database, and insert a new clean on, then manually enter tax class, and tax rate at admin, the problem fixed....lucky it is not the php code from other addons I had installed....

Tar!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×