Jump to content
Latest News: (loading..)

Recommended Posts

If you have not downloaded the Final/Frozen version, DO SO NOW! As I understand it, the Github project has been archived, and is pending deletion!

Since there will be no more development on it, I propose posting any bugs and/or fixes here. I'll start:

In the Also Purchased module ... There is a tiny mistake in cm_pi_also_purchased.php. Line 62 has "Enable
Reviews Module" instead of "Enable Also Purchased Module".

 


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release here

Share this post


Link to post
Share on other sites

I've been thinking of doing the same. Here are some changes that should be made (not all are mistakes):

1 - In includes/modules/content/product_info\templates/tpl_cm_pi_price.php, the variables in sprintf are in the wrong order. Change

    <h2 class="h3 text-right-not-xs"><?php echo (tep_not_null($specials_price)) ? sprintf(MODULE_CONTENT_PI_PRICE_DISPLAY_SPECIAL, $specials_price, $products_price) : sprintf(MODULE_CONTENT_PI_PRICE_DISPLAY, $products_price); ?></h2>

to

    <h2 class="h3 text-right-not-xs"><?php echo (tep_not_null($specials_price)) ? sprintf(MODULE_CONTENT_PI_PRICE_DISPLAY_SPECIAL, $products_price, $specials_price) : sprintf(MODULE_CONTENT_PI_PRICE_DISPLAY, $products_price); ?></h2>

2 -  In languages/create_account_success.php change priviledges to privileges.
                                                                      
3 - In languages/shopping_cart.php change two instances of "don't" to "don\'t".

4 - In languages/shopping_cart.php change "immediate deliver" to "immediate delivery".  

5 - In includes/application_top, add the deprecated flag to prevent future warnings and disable display errors since it is a security hole by changing

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);

to

  error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT & ~E_USER_DEPRECATED);
  ini_set('display_errors','0'); 

6 - In includes/template_top.php, change the version number to the current one because some icons being used won't work in V 5.0.6.

<script defer src="https://use.fontawesome.com/releases/v5.0.6/js/all.js"></script>

to

<script defer src="https://use.fontawesome.com/releases/v5.0.9/js/all.js"></script>

 

Share this post


Link to post
Share on other sites

This is not a fix for a coding bug, but a good praxis improvement:

  • customer creates account
  • customer fills in a wrong state name which doesn't match any database state name
  • error is thrown "please select a state from the drop down menu"
  • the first alphabetic state is selected by default
  • customer doesn't pay attention and the first default state is submitted
  • solution: add "Please select" as default to the menu

create_account.php, address_book_details.php, checkout_new_address.php:

change:

          if ($entry_state_has_zones == true) {
            $zones_array = array();

to:

          if ($entry_state_has_zones == true) {
            $zones_array = array(array('id' => '', 'text' => PULL_DOWN_DEFAULT));

 

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, wHiTeHaT said:

excellent that saves me the bother!

...but I think it's going to mess up people's github projects with merge issues if it's not another fork of the same ancestor. I'll have a go and we'll see what happens

Edited by BrockleyJohn

For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce here: https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

 

For Github users: Bootstrap addons - one per branch - https://github.com/BrockleyJohn/Responsive-osCommerce/wiki/Overview-of-Branches

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites
Posted (edited)

For "others" , they just need to adapt.
There is already a mess.
default 2.3.4.1 users
previous BS users who NEVER upgraded.

The bottom line needs to be drawn.
For that a roadmap needs to be made towards a osc version that will be accepted by a wider audience committed to oscommerce.
It will NOT going to be easy.
But i have a plan, and it WILL work.
The first plan:
Any post FLAMING and RANTING about oscommerce 
Will be hidden.
Positive critics are accepted and should be read as.
And will be moved to: https://forums.oscommerce.com/forum/13-general-discussions/ 

Edited by wHiTeHaT

Share this post


Link to post
Share on other sites

I guess there's going to be a bit of self-moderating going on then :tongue:


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce here: https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

 

For Github users: Bootstrap addons - one per branch - https://github.com/BrockleyJohn/Responsive-osCommerce/wiki/Overview-of-Branches

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

As a store owner, I don't want to have to visit Github (or wherever) to see if there are any patches I need to apply to my live store(s). For me, I was very happy when Edge/Final/Frozen was 'finished'. That's not to say that there aren't any bugs still in it. That's the reason for this thread ... a place to document bugs, and hopefully fixes.

I am also pleased that development is still happening. Keep it up, guys. Use this thread as a source of information to improve your forks. But please, for this thread, let's keep it just for Edge/Final/Frozen, ok?


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release here

Share this post


Link to post
Share on other sites

With the latest final/frozen anyone else having problems with the site jerking on refresh?

Does for a second but on every refresh the site jumps to the right and back.

Share this post


Link to post
Share on other sites
5 hours ago, CGhoST said:

With the latest final/frozen anyone else having problems with the site jerking on refresh?

Does for a second but on every refresh the site jumps to the right and back.

@CGhoST On all pages? What modules do you have enabled?


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce here: https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

 

For Github users: Bootstrap addons - one per branch - https://github.com/BrockleyJohn/Responsive-osCommerce/wiki/Overview-of-Branches

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites
Posted (edited)

I belive its always done this, you get what looks like a jerk but its just the switch from text to images on refresh. This (link) is fresh install of frozen with no addons ot tinkering. On refresh the logo is replaced with text for a micro second before returning to logo which gives a jerking effect. Unless you are seeing somethig diferent?

 

http://www.justfastfood.com/

Edited by JcMagpie

I'm using the cutting Edge v2.3.4.1 CE:thumbsup::smile:

Get the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

 

Share this post


Link to post
Share on other sites

What Zahid described, every website does. @CGhoST pm me your url


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce here: https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

 

For Github users: Bootstrap addons - one per branch - https://github.com/BrockleyJohn/Responsive-osCommerce/wiki/Overview-of-Branches

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites
Posted (edited)

@BrockleyJohn

On this link provided by JcMagpie http://www.justfastfood.com/ when you click on oscommerce image and the page refreshes you can see the breadcrumb jerking and the navbar jerking. In my older edge site it doesnt do that. There is no jerkiness.

Edit: I dont have a link as its on localhost

Edited by CGhoST

Share this post


Link to post
Share on other sites

I would say thats normal. You see the image's alt text until the images are loaded. It may be more or less noticeable depending if you have the images already in cache or not, if they are bigger or smaller and the speed of your connection and server response.

Share this post


Link to post
Share on other sites

If you're experiencing jerking in the navbar, it's going to be the fontawsome icon causing it.

There is a different version of fontawesome in CE since last September, and they are now vector graphics. Perhaps it's the speed with which your browser handles vector graphics; I don't have a noticeable flicker.

If you fix a width for .fa-home in your user.css, the rest of the navbar won't move.


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce here: https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

 

For Github users: Bootstrap addons - one per branch - https://github.com/BrockleyJohn/Responsive-osCommerce/wiki/Overview-of-Branches

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×