Jump to content

Archived

This topic is now archived and is closed to further replies.

zefeena

'Safer Payments' Registration - World Pay

Recommended Posts

Hi,

I recently installed World pay as a payment option, as an alternative to Paypal.  I am being told that I need to comply with Safer Payments or something, but I'm baffled by this.

I am using World Pay as a'hosted' payment provider .  I will be sending my customers over to Worldpay to process their payment, just in the same way as with Paypal.  I will NOT be seeing their credit card details, these will not be input on my website at all - I simply do not want the responsibility!

Has the customer service adviser on WorldPay got ti wrong? surely I do not need to 'comply', as its them seeking the details, and therefore they need to comply not me!

anyone any idea? ta


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

Hi.

It is a very simple process and will give you the necessary PCI security rating. Basically it is to prove that you are NOT seeing or holding card details and to establish how you connect to the internet e.g. whether your PC is on a network and can others access it.

Just answer the questionnaire and they will issue a 12 month certificate. Because they are handling the card details a lot of the questionnaire is not relevant, however you have to do this to comply. Do not ignore it, they will keep chasing you until it is done.

Martin


Live Phoenix 1.0.5.0 on PHP 7.3

Is your version of osC up to date? You'll find the latest osC community version (CE Phoenix 1.0.7.9) here.

Share this post


Link to post
Share on other sites

thank you Martin,

much appreciated x

 


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

×