Jump to content

Recommended Posts

Hi team,

 

I am trying to install Excel Populate into my OsCommerce 2.4.3.1 installation. However I cannot get it going as the instructions say that I must add the following line into the catalog/admin/includes/boxes/catalog.php

'<a href="' . tep_href_link(FILENAME_EXCEL, '', 'NONSSL') . '" class="menuBoxContentLink">Excel Populate</a><br>' .

 

The issue I am having is that I cannot see the after line which is '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>'

because there is no HTML code in the PHP file. Is this for a php file or should I still add it and will it be translated?

 

Please help!

 

Thanks in advance. 

Share this post


Link to post
Share on other sites

@nickjansen Try this. It's just an anchor. I hope you get the idea of it being in an array form. Don't shoot me, I think I am changing core codes.

 

<?php
/*
  $Id$
  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com
  Copyright (c) 2010 osCommerce
  Released under the GNU General Public License
*/
  $cl_box_groups[] = array(
    'heading' => BOX_HEADING_CATALOG,
    'apps' => array(
      array(
        'code' => FILENAME_CATEGORIES,
        'title' => BOX_CATALOG_CATEGORIES_PRODUCTS,
        'link' => tep_href_link(FILENAME_CATEGORIES)
      ),
      array(
        'code' => FILENAME_PRODUCTS_ATTRIBUTES,
        'title' => BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES,
        'link' => tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES)
      ),
      array(
        'code' => FILENAME_EXCEL,
        'title' => 'Excel Populate',
        'link' => tep_href_link(FILENAME_EXCEL)
      ),
      array(
        'code' => FILENAME_MANUFACTURERS,
        'title' => BOX_CATALOG_MANUFACTURERS,
        'link' => tep_href_link(FILENAME_MANUFACTURERS)
      ),
      array(
        'code' => FILENAME_REVIEWS,
        'title' => BOX_CATALOG_REVIEWS,
        'link' => tep_href_link(FILENAME_REVIEWS)
      ),
      array(
        'code' => FILENAME_SPECIALS,
        'title' => BOX_CATALOG_SPECIALS,
        'link' => tep_href_link(FILENAME_SPECIALS)
      ),
      array(
        'code' => FILENAME_PRODUCTS_EXPECTED,
        'title' => BOX_CATALOG_PRODUCTS_EXPECTED,
        'link' => tep_href_link(FILENAME_PRODUCTS_EXPECTED)
      )
    )
  );
?>

 

Share this post


Link to post
Share on other sites

Hey thanks for your reply!!

 

I made those changes, but now I get the attached error. Not sure if it is something I am still doing wrong. 

 

Thanks so much for your help!

 

 

ExcelPopulate.jpg

Share this post


Link to post
Share on other sites

from your image there is no define for FILENAME_EXCEL in admin/includes/filenames.php


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P


Support The Project
Documentation/Knowledgebase/Discussions
 

Share this post


Link to post
Share on other sites

@nickjansen

1 hour ago, 241 said:

from your image there is no define for FILENAME_EXCEL in admin/includes/filenames.php

 

or, you could hard code it into the menu code itself. For example:

      array(
        'code' => FILENAME_EXCEL,
        'title' => 'Excel Populate',
        'link' => tep_href_link('excel.php')
      ),

(adjust the file name, and directory structure, as needed)

Edited by ArtcoInc

Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Ah, IIS, what!? Just kidding, your definitely missing some steps during your hack. In the old OSC, that should be defined in the filenames.php file.

 

17 hours ago, nickjansen said:

Hey thanks for your reply!!

 

I made those changes, but now I get the attached error. Not sure if it is something I am still doing wrong. 

 

Thanks so much for your help!

 

 

ExcelPopulate.jpg

 

Share this post


Link to post
Share on other sites

I've got the installation finished, but I cannot get the user docs - the link  http://www.advancewebsoft.com/downloads/documentation/excel-populate-manual-p.html   just leads to a blank page

Edited by Schizolocal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×