Jump to content
Latest News: (loading..)
sahilgulati5

Website not working from past 5 days

Recommended Posts

Hi,

Everything was working perfect till last week suddenly the site is not working and now its saying to install Oscommerce Online Merchant 2.3.4. We are using Cpanel. How do we bring the site back live again.

 

Thank you for all your help in advance.

site.jpg

Share this post


Link to post
Share on other sites

Well untill you know why its gone wrong simply rename the directory. Use the file manager in cpanel and rename the directory. But if you have no experiance who installed your website? you should first aske them as they may know what has happend.


 

Share this post


Link to post
Share on other sites

@sahilgulati5

If I may, before you do anything else .... STOP!  Before you go any further ...

1) You said that your store was working up until 5 days ago. What has changed?

2) Do you have a backup of your original site, both the files and the database?

3) What screen is telling you to install osC 2.3.4?

A few things to think about ...

A) osC 2.3.4 is OBSOLETE. I recommend that you DO NOT install it!

B) Installing a new copy of osC will (most likely) overwrite your original site, meaning you will loose all history, customer data, products, store customization, etc. Again, STOP!

C) Who set up your shop in the first place?

Malcolm

 


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

As @ArtcoInc has mentioned. Stop what you are doing. Do not overwrite anything. If you do everything could be lost.

If your site was working faultlessly up until the last few days, you need to find out what had changed. If your hosts have a backup copy, and most good hosts will, ask then to reload a good known working copy of your site. That should at least restore it back to a known working site. They may even have a good database copy which can be uploaded. Your hosts may have also changed something. Generally most hosts will lie and say that they have changed nothing. Keep pestering them.

If you dont have a good backup, you have just learned lesson one.

If you feel that you need to do a full install, use the latest community bootstrap version. The official version available though things like softilicious in the cpanel is rubbish and out dated.


REMEMBER BACKUP, BACKUP AND BACKUP

Before installing the official version of oscommerce first look at a responsive version here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Hi, 

 

Really now idea. As it was working perfectly fine. Now when I try to visit the home page or any other page it shows install oscommerce. 

 

No one other than me has access to cpanel.. Nor anything as been changed by me from past few months.. 

 

So I am really understanding what went wrong. 

Share this post


Link to post
Share on other sites

Websites dont just vanish. Someone did something. Your hosts have access. Speak to them. If they are any good they will be able to help you. If they are no good, move to better ones.


REMEMBER BACKUP, BACKUP AND BACKUP

Before installing the official version of oscommerce first look at a responsive version here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

@sahilgulati5

As @14steve14 mentioned, someone did something. Your host may have changed something (like the version of PHP they are running), or you could have been hacked, or ...

1) I'll ask again, do you have backups of your site, both the store code and the database?

2) Have you contacted your host? (by the way, who is your host?)

3) If you are the person in charge of your shop, I strongly urge you to:

A) Do not use any 1-click install packages available through your host (or cPanel). They are typically out of date. Take the responsibility to research the application yourself. Your host will not be able to offer ANY support for ANY application (be it WordPress, osCommerce, etc) ... it is up to you to find the support you need (like here :wink:)

B) Learn how to make backups of both your store code and the database. TEST that the backups are valid, and that you can indeed restore off of your backups.

C) Learn to use an FTP client (such as Filezilla) to administer your shop, and use cPanel only for those tasks that require it.

If all of this is beyond your skills, or you don't have the time, please hire someone you trust to do this for you.

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

1. Find out from your host if they just upgraded PHP at about the time your store stopped working. osC 2.3.4 (the official version) will run poorly (or not at all) on PHP 7, and may have problems with PHP 5.5 and later. If this is what happened, you want to migrate your data to osC 2.3.4.1BS "Edge", rather than trying to fix an old osC version.

2. Did your host just restore a backup of your site, that might still have the "install" directory? Did your server crash (and was restored) around that time? That must have been a very old backup! No good host would use a months-old backup, and not tell you about it.

3. Go into your control panel file manager and look at the "last updated" timestamps on all your files. Is there anything suspiciously recent, that might indicate you were hacked?


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Hi, 

 

I am relatively new. So I really don't have a back up of anything. I am using namecheap host. 

 

I got a mail from Google search console on 15th May. 

"

New Index coverage issue detected for sitehttps://www.kartoffr.com/

To owner of https://www.kartoffr.com/,

Search Console has identified that your site is affected by 1 new Index coverage related issue. This means that Index coverage may be negatively affected in Google Search results. We encourage you to review and consider fixing this issue.

Can this be a reason?? 

Share this post


Link to post
Share on other sites

@MrPhil

The Install screen on the site shows PHP at version 5.6.35

@sahilgulati5

You say that's dated 15 May? As in, eleven months ago (or more)???

And no, I don't think that has anything to do with what's happening now.

As has been suggested, contact your host, and ask them to restore your site (both files and database) to what it was a week ago (before this problem arose). Once that's done, you can learn how to back up everything yourself.

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

@sahilgulati5

I *think* the message from Google says that they scanned your store on the 15th, that they saw that something was wrong, and suggested that you look into it. In other words, they didn't cause the problem, but they did notice the problem.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites
14 hours ago, sahilgulati5 said:

Sorry it's not 15th May.. It's 15th April.. Just 4 days back. 

Recover from the most recent backup these files

admin/includes/configure.php

includes/configure.php

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×