Hello Looking for some wisdom if anybody is able to help I am running OSC V2.3.4 I received email from paypal saying TLS 1.2 is not setup / working properly and action is needed. Webhosting company assures me that their servers support TLS 1.2 Report is here https://www.ssllabs.com/ssltest/analyze.html?d=kauto.co.uk  ( I do not understand it all by any means but it looks to me as if it is supported ) using the test connection button in the latest paypal add on I get cURL Version: 7.53.0
cURL SSL Version: OpenSSL/1.0.2k Default Setting: Failed
TLS v1.2: Failed A connection to PayPal could not be made using TLS v1.2. Please consult with your hosting provider to upgrade the cURL version that is installed with your PHP web server to support TLS v1.2 connections. Hosting company assures me they support and their other customers do not have problems with this. Paypal just seem to ignore any messages from me asking for pointers of what to do next   Anybody got any clues or wisdom to pass on what else I can do to make this work or why it may be failing. I am not a programmer but can generally find my way around the OSC files and make edits etc if somebody can tell me what to do   Any help will be greatly appreciated