Jump to content
Latest News: (loading..)

Recommended Posts

I have the standard USPS module that comes with the base install. I have applied for and received a user ID and password from USPS. when I test I get the following error.

Quote
United States Postal Service United States Postal Service
An error occured with the USPS shipping calculations.
If you prefer to use USPS as your shipping method, please contact the store owner.
Installed Version: osCommerce Online Merchant v2.3.4
pixel_trans.gif

these are the only settings available in the module to edit:

Tax Class
--none--

Shipping Zone
--none--

Sort Order
01

Share this post


Link to post
Share on other sites

I haven't tested it in some time but I don't think the one that comes with the package works. I suggest you install this instead.

Also, the error you mentioned can be because the ship to or from address is not valid. So be sure you have a zip code entered in configuration->Shipping/Packaging and that the address being used are valid.

Share this post


Link to post
Share on other sites

What USPS permissions will I need associated with using OSC?

Share this post


Link to post
Share on other sites
12 hours ago, Jack_mcs said:

I haven't tested it in some time but I don't think the one that comes with the package works. I suggest you install this instead.

Also, the error you mentioned can be because the ship to or from address is not valid. So be sure you have a zip code entered in configuration->Shipping/Packaging and that the address being used are valid.

installed and it seems to be working. under the settings for it there are three letters N S H under extra services, what do they mean?

Share this post


Link to post
Share on other sites

I don't ship Internationally so I never had reason to look those up. But when you have a question about an addon, you should always ask it in the support thread for that addon.

Share this post


Link to post
Share on other sites
2 minutes ago, Jack_mcs said:

I don't ship Internationally so I never had reason to look those up. But when you have a question about an addon, you should always ask it in the support thread for that addon.

they appear in both national and international settings. I just posted the question there as well. I thought maybe you had some information since you had recommended it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×