Jump to content
Latest News: (loading..)

Recommended Posts

Posted (edited)

This Addon replaces the New Product page in your store's admin with a tabbed interface that is better organized and easier to use. The rest of the Categories/Products admin is the same; only the Product page has been changed.

I backported this from the osCommerce 2.3.5 Beta, then added the additional fields that the 2.3.4.1 Bootstrap version uses. I did this because the old Products page has always felt poorly organized and confusing to me. If you feel the same way, give this one a try.

Code is here.

Screenshot:

 

product_admin_page.png

Edited by kymation
Added link to the Addon.

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

 

Great idea.
I have tried to install the addon, but I can not get the tabs (frames, borders). Now I have the categories.php as a single page (as before) , but order changed as you coded. Can you tell me what file is responsible for the tabs? Thanks in advance. Greetings, Martin

Share this post


Link to post
Share on other sites

What version of osCommerce? If it's Edge, when did you download it?

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Oscommerce Edge. I have downloaded it after november 2016 and added a few addons. The categories.php is hardcoded ($_POST and $_GET) . Usually I look for general updates at tehe site of Gburton. at github.com. My shop is www.art-ty.nl.

Share this post


Link to post
Share on other sites

Hi Jim. I fixed it (I think). The (admin) template_top.php referred to jquery-2.2.3. I changed it to jquery-3.1.1 and everything worked perfectly. Perhaps because i have added ckeditor??  Thanks, beautifull adonn.

Share this post


Link to post
Share on other sites

Jim, in the main file, what are the pre-placed Hooks for ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

@dreumel  Yes, jQuery 3 is required, so that would do it. I may need to add a warning about CKEditor. Thanks for letting me know.

@burt  The hooks were in the 2.3.5 version that I backported. I assumed that Harald put them there so I left them in. Is this going to cause problems?

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
18 hours ago, kymation said:

The hooks were in the 2.3.5 version that I backported. I assumed that Harald put them there so I left them in. Is this going to cause problems?

It wont hurt anything.  My eyes lit up at the prospect of another dev getting heavily into Hooks, that's all.

I didn't even know there is a 2.3.5 !  When was that released?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

I have big plans for using both Hooks and Actions. They're going to make things a lot easier. I just need to find the time to code some up.

2.3.5 was released in Beta near the end of November last year. I was testing it, along with several other people, so I have a copy of the code. It only needed a few minor bugfixes and it could have been a solid release. Unfortunately that never happened.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@kymation

Wasn't 2.3.5 supposed to be the next step up from 2.3.4(.1) (non bootstrap), while 2.3.6 was supposed to based on the community build (responsive)?


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release here

Share this post


Link to post
Share on other sites

Yes, that was the plan as I understand it. Shame that it never happened.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi, Thank you for this excellent add-on. I believe I've installed it correctly(?),  it seems to work as expected. Assuming that to be the case, there appears to be one very minor trivial  PHP error - 

      Undefined index: admin
      includes/classes/hooks.php
      line 56

Many Thanks

Share this post


Link to post
Share on other sites

Hi, Sorry, ignore my previous message, I've addressed the wrong add-on, I think I meant the tabbed product add-on. 

Share this post


Link to post
Share on other sites

Whichever Addon you were referring to, the bug is in the core osCommerce code. I believe the latest Edge version has a fix for this. The file you need is includes/classes/hooks.php.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×