Jump to content
Latest News: (loading..)
newbie1000

1146 - Table 'merchand_shop.configuration' doesn't exist select configuration_key as cfgKey, configuration_value as cfgValue from configuration [TEP STOP]

Recommended Posts

Hey total newbie and migrating a client site to different server and pulled all files and database and after a few hiccups in missing files I get to this point 

1146 - Table 'merchand_shop.configuration' doesn't exist

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

[TEP STOP]

There is no - Table 'merchand_shop.configuration'  in the existing site, database, 

any ideas? 

Share this post


Link to post
Share on other sites

@newbie1000

What version of osCommerce? What version of PHP (on both the old server and the new server)? What add-ons have been installed?


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release here

Share this post


Link to post
Share on other sites

 


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release here

Share this post


Link to post
Share on other sites

Hi have just checked 

existing server ea-php56 , new server 5.6.34

and 

// Define the project version --- obsolete, now retrieved with tep_get_version()
  define('PROJECT_VERSION', 'osCommerce Online Merchant v2.3');

I have created the new database on the new server and imported all the data into that database, and transferred the files over as required.  DO I need to have run an installation wizard first then drop the tables in?

thanks

 

Share this post


Link to post
Share on other sites
Posted (edited)

Your configuration files need to be updated to the new server settings: absolute paths, database server, database name, database user and passw.

if you are not sure how to do this, yes, you could do a new installation of a downloaded complete oscommerce package. Try to use the same version of your real store. Use the  installation script and install into a subdirectory and linked to a separate database. Then open and compare both configuration files to see which definitions to update and how to update them.

the files are:

includes/configure.php

admin(or whatever your admin directory is called)/includes/configure.php

Edited by raiwa

Share this post


Link to post
Share on other sites

I think "configuration" is one of the first tables hit when running. The first thing to check is whether you did something silly at some point, and misspelled "merchant_shop" (the DB table prefix) as "merchand_shop" (or vice-versa) in either setting up the database, or in osC's configuration. They can be spelled either way, but need to be consistent!

While you're going through the effort of migration, consider upgrading to the latest and greatest: osC 2.3.4.1BS "Edge". Note that this is not the official release, but has to be obtained from GitHub (see my signature below).


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

thanks everyone for your help, woke up this morning and fresh eyes missed 2 tables out of database, should not work night shift but now working on the other server 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×