Jump to content
C1ta

This transaction can't be processed. Please pay with another card.

Recommended Posts

Hi, today I tried to configure paypal pro hosted solution with my paypal business pro account, but at the time of payment I am moved to a page containing "This transaction can not be processed.
do you know how to solve?

Share this post


Link to post
Share on other sites

@C1ta You might want to provide a little more information....see this post on how to get the help you need.

Dan

Share this post


Link to post
Share on other sites
3 hours ago, Dan Cole said:

@C1ta You might want to provide a little more information....see this post on how to get the help you need.

Dan

Okay i have opened new topic. Thanks

Share this post


Link to post
Share on other sites

@Dan ColeI send the information here too, 

OSCommerce Merchant v2.3.4.1

PHP 5.6.3

 
 
When the payment method is selected, you are redirected to the page (see photo)
 
Thanks

Screenshot_1.jpg

Share this post


Link to post
Share on other sites

@C1ta Is it the Responsive version and are you using the PayPal APP?   See this thread regarding the hosted solution.  It might help...there is reference to the Host Solution on page 8.  John or Jack will likely chime in if post there.

Dan

 

Share this post


Link to post
Share on other sites

@C1ta I have reproduced your problem. The app seems to be posting a bad request (return code 400) to pp hosted. Whether this lies in a setting or the code I have yet to determine...


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (2.3.4.1 CE).

here: https://github.com/gburton/Responsive-osCommerce/releases

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites
2 minutes ago, C1ta said:

@BrockleyJohn Is there anything I can send you to try to solve?

Not for now as, having reproduced the error, I have my own to debug! I'll keep you posted.


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (2.3.4.1 CE).

here: https://github.com/gburton/Responsive-osCommerce/releases

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites
23 minutes ago, BrockleyJohn said:

Not for now as, having reproduced the error, I have my own to debug! I'll keep you posted.

I send you the link of my website where I'm trying, so if you want to try them directly. Anyway I'm using the PayPal app site

Edited by C1ta

Share this post


Link to post
Share on other sites

I don't think it's an osc thing. The call to paypal hosted returns the same info in a number of ways, one of them is called EMAILLINK and if you just paste it into the browser, you get the error we've experienced.

Needs more research on the paypal end... will let you know


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (2.3.4.1 CE).

here: https://github.com/gburton/Responsive-osCommerce/releases

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

@C1ta Probably the issue is that your sandbox merchant account is not a pro account.

  • Log into developer.paypal.com
  • Click on Accounts under Sandbox
  • click the little arrow next to the merchant email and click profile underneath it
  • in the popup, scroll down the profile tab till you get to Account Type: and click Upgrade to Pro

For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (2.3.4.1 CE).

here: https://github.com/gburton/Responsive-osCommerce/releases

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

@C1ta ok but it's likely something in Paypal...

Does the account country match the store country and currency?

Paypal returns this 400 result when there's anything wrong with the request, but in this case it doesn't look like an osc problem, it's just a case of finding which settings aren't right.


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (2.3.4.1 CE).

here: https://github.com/gburton/Responsive-osCommerce/releases

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×