Jump to content
Latest News: (loading..)
aaanativearts

Is v2.3.4.1 compatible with php 7.0

Recommended Posts

It depends on which version you mean. If it is the official version, then no. If it is the community version, then yes.

Share this post


Link to post
Share on other sites
Posted (edited)

Didn't HPDL specifically state that 2.3.4.1 was PHP 7.0-ready? I've been telling people it is. Fast-CGI, I don't know.

Edited by MrPhil

If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

I don't recall him saying that but he might have. But I just downloaded the official version and checked a few files and they are not compatible with php 7.

Share this post


Link to post
Share on other sites

Hmm. I seem to recall his saying that the whole reason for the .1 release was to install and run on PHP 7. If you have found incompatibilities with PHP 7, he should be alerted.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites
Posted (edited)

Deprecated php7 errors reporting has been supressed in 2.3.4.1 standard update.

See includes application_top.php:

// set the level of error reporting
  error_reporting(E_ALL & ~E_NOTICE);
  
  if (defined('E_DEPRECATED')) {
    error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);
  }

And also a compatibility update in the database function has been included in that update.

So it works without showing errors.

But 2.3.4.1 BS Responsive code is updated and optimized up to php 7.2.

Edited by raiwa

Share this post


Link to post
Share on other sites

What?! Are you telling me that Harald merely suppressed reporting of "deprecated" errors, rather than truly updating to PHP 7? That's not very good news. I will have to go back to telling people that only "Edge" is PHP 7 ready.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

All I did was check if construct was being used in some of the classes, which they are not. Those are not required by php but would cause warnings and possibly make the shop unusable. But assuming raiwa is correct, which he usually is, then that would make the official version 7.0 compatible. I apologize for any confusion I caused.

To the op, if you are using the official version you should replace it regardless of the php question since it is not Responsive.

 

Share this post


Link to post
Share on other sites

I'm not going to call 2.3.4.1 "PHP 7 compatible" if all that's been done is to sweep "deprecated" errors under the rug. These are going to break at some later PHP release (when old features are finally removed), and customers will be complaining that osC is a POS. It may well work (more-or-less) with 7.0, but I'll bet it will break in some manner further down the line, as deprecated features are removed or subtly changed. In my book, an application is "compatible" when the code has been fixed to not use deprecated features at all, as "Edge" presumably has been. I was under the impression that's what HPDL had spent all that time doing, but evidently not.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×