Jump to content
Latest News: (loading..)
hyungjay

search filed error

Recommended Posts

Hi,

I am new in here and trying to find out why the Seach shows up error,

I am getting

"1054 - Unknown column 'p.products_id' in 'on clause'

select count(distinct p.products_id) as total from products p left join manufacturers m using(manufacturers_id), products_description pd left join specials s on p.products_id = s.products_id, categories c, products_to_categories p2c where p.products_status = '1' and p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and ((pd.products_name like '%bb026%' or p.products_model like '%bb026%' or m.manufacturers_name like '%bb026%') )"

Could you please any one help out why it shows that error when try to search?

http://www.fashionpointinc.com/advanced_search_result.php?keywords=bb026&x=3&y=12

Please advise,

Share this post


Link to post
Share on other sites

Exactly what version of osCommerce? Older versions broke when an incompatible change was made to how the MySQL database implemented operation precedence, but this was fixed long ago, unless you're using an ancient (2.2) version. You might want to search this forum for the 1054 error and see what kind of code changes were made to fix it. Even better, if you are running something old (anything not 2.3.4.1 or even better, 2.3.4BS Edge), it's time to upgrade to something current.

It's also possible, if this is add-on code, that for some reason products_id was not added to the products table, or was somehow removed. Has anyone been working in the code or database lately? Was an add-on just installed?


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

I have "osCommerce 2.2-MS2"

could you please send me how to upgrade the osCommerce and what version should I go?

Also how can I back up the site before upgrade?

 

Please advise

Share this post


Link to post
Share on other sites
17 minutes ago, hyungjay said:

could you please send me how to upgrade the osCommerce and what version should I go?

See this thread for information on upgrading and have a look at MrPhi's signature file, or mine for that matter, on where to download the latest version.

Dan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×