Jump to content

Recommended Posts

Hi All,  I may end up soliciting professional help here but for now just generally looking for best way to attack this or a strategy to upgrade.  My shop http://www.houseofaberrant.com is running on 2.3.4   I know i'm very late to the party with responsive site and mobile friendly which i'm positive has effected my shop's sales and customer growth. I see so much that this bootstrap and upcoming OSC changes that will help - all super exciting!    

Challenges I've had over the last years applying add-ons or performing regular OSC updates is that my site uses a AZ template (happy to stop using).   

I understand there are two parts the database conversion and the shop itself.  Should I attempt conversion (if possible)  2.3.4 to 2.3.4 responsive / bootstrap Gold/Edge  Or would it be best to start from scratch? 
My site is on PHP 5.4 and host supports ( PHP 5.6.32, MySQL  5.6.32-78.1)  I have about 350 active product listings. 

Thanks in advance!

Tiffany

Share this post


Link to post
Share on other sites

You definitely should end up on 2.3.4.1BS Edge (responsive), and not Gold, which is several years out of date. I'm not sure what you mean by "conversion" versus starting from scratch. There is no "upgrade" path from non-BS versions (including 2.3.4) -- you have to install from scratch, but you certainly can then bring over all your existing data. In that sense, you're not "starting from scratch" (lose all customers, order data, product entries, etc.), but the code is brand new. You will need to look into what add-ons you have that you want on the new (Edge) store, and see if they exist for Edge, and install them. I'm not familiar with commercial templates for Edge, if any, but there might be some (just make sure they don't overwrite your system back to something pre-Edge!).

Share this post


Link to post
Share on other sites
On 2/25/2018 at 5:47 PM, MrPhil said:

You definitely should end up on 2.3.4.1BS Edge (responsive), and not Gold, which is several years out of date. I'm not sure what you mean by "conversion" versus starting from scratch. There is no "upgrade" path from non-BS versions (including 2.3.4) -- you have to install from scratch, but you certainly can then bring over all your existing data. In that sense, you're not "starting from scratch" (lose all customers, order data, product entries, etc.), but the code is brand new. You will need to look into what add-ons you have that you want on the new (Edge) store, and see if they exist for Edge, and install them. I'm not familiar with commercial templates for Edge, if any, but there might be some (just make sure they don't overwrite your system back to something pre-Edge!).

Yes when I said conversion i was meaning an upgrade path - so thank you that helps very much!   

Thank you Phil ! 

Share this post


Link to post
Share on other sites

@MrPhil

On 2/25/2018 at 5:47 PM, MrPhil said:

I'm not familiar with commercial templates for Edge, if any, but there might be some (just make sure they don't overwrite your system back to something pre-Edge!).

Are you forgetting the templates that @burt offers commercially?

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×