Jump to content
Latest News: (loading..)
TheStingPilot

Not formatted shop and admin login screen on osCommerce 2.3.4.1

Recommended Posts

Hello,

I have installed osCommerce many times on a local Ubuntu 16.04 LTS server. After a default installation - admin folder not renamed - I cannot login to the admin portal. Also, the layout of the catalog is not right.

I have attached a print screen of the catalog.

I have checked the settings in both configure.php files. There are no references to unknows folders and the DB settings are correct.

Any suggestions are appreciated.

With kind regards,

Willem-Jan

2018-02-04 15_06_04-OSCommerce.png

Share this post


Link to post
Share on other sites

If you haven't done so already, browse the HTML page source in your browser, and see if the paths to CSS files, etc., are what you expect (match configure.php entries). Were you careful to use / instead of \ as a directory separator? This is on a Linux box, and your paths are correct? How about directory and file permissions? Is this a standalone PC installation for testing purposes only, or is it on a commercial hosting service?

By the way, before you get too far along, you need to be aware that osC 2.3.4.1 is quite old (although recently updated for PHP 7). You should be using osC 2.3.4BS Edge, the responsive (mobile friendly) version. Since the latest version returns 2.3.4.1as its version, it can be confusing which you have installed.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Hello @MrPhil,

Many thanks for your answer. 

I downloaded osCommerce 2.3.4.1 from https://www.oscommerce.com/Products&Download=oscom2341. I am sorry, but I cannot find osC 2.3.4BS Edge.

osCommerce 2.3.4.1 is running on my private Ubuntu 16.04 server. The website running on that server can only be reached from my laptop as it is on a Hyper-V box.

Hope this helps and with kind regards,

Willem-Jan

 

 

Share this post


Link to post
Share on other sites

By the way: on IE I got the warning that only secure content is shown. When clicking on 'Show all content' the page is shown correctly. But it does not show correctly on Firefox and Chrome.

2018-02-04 19_49_28-Gold Brew Coffee Web Shop - Internet Explorer.png

Share this post


Link to post
Share on other sites

@Dan Cole @MrPhil

Hello all,

I am sorry but I have bad news. I have installed the new osCommerce. The same result: the layout is not correct. In IE mixed content is not shown. And I also think that the .js files are a part of the problem on Chrome and Firefox Quantum.

Also, the userid that I use for administration is not accepted. 

I use a self signed OpenSSL certificate. The installation was done as per instructions on https://www.digitalocean.com/community/tutorials/how-to-create-a-self-signed-ssl-certificate-for-apache-in-ubuntu-16-04.

Hope this helps and with kind regards,

Willem-Jan

Share this post


Link to post
Share on other sites

I wouldn't worry about the mixed content issue right now....it might sort itself out as you fix the other issue(s).   Have to tried viewing the source as @MrPhil suggested in an effort to see what the problem is?  

3 hours ago, MrPhil said:

If you haven't done so already, browse the HTML page source in your browser, and see if the paths to CSS files, etc., are what you expect (match configure.php entries). Were you careful to use / instead of \ as a directory separator? This is on a Linux box, and your paths are correct? How about directory and file permissions?

Dan

Share this post


Link to post
Share on other sites

Is this self-hosted, i.e., *AMP on a PC or Mac? If so, why? If you are just playing around to dip your toes in the water, or you want to play with a PHP level that your host doesn't yet offer, that's one thing, but if you already have your commercial hosting, use that. It will save you a LOT of grief when it comes time to transfer your "test/development" installation over to your commercial server. Meanwhile, just run without SSL on the PC, if you can't get it configured right. And never, never, never try to host a live site on your own PC -- the hackers know far more about security issues than you ever will, and they will eat you alive.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Hello @MrPhil and @Dan Cole,

 

Many thanks for your answers. In the meantime I had https disabled for this site. And now it is working fine. And do not worry, I will never host a live site on my own PC. That is asking for troubles. But this test box cannot be reached from the internet, so no worries.

With kind regards,

Willem-Jan

Share this post


Link to post
Share on other sites

Unfortunately, I've seen people spend a lot of time trying to get SSL running on their PC *AMP stacks, usually to no avail. There's just something about SSL that doesn't seem to work well with these stacks. Since you're not going to run a live site (exposed to the Web), just leave off the SSL if you can't quickly get it working.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×