Jump to content
Latest News: (loading..)
TomB01

UPS APIs Changed - UPS XML 1.6.1 Not Allowed?

Recommended Posts

I've been getting the infamous "This module supports only xpci version 1.0001 of the UPS Rates Interface." error message lately.  I'm running 2.3.4 and had UPSXML 1.4.0 installed, so updated to 1.6.1.  That didn't fix it.  After some searching on the Internet, all I found were some very dated references stating that the UPS servers had gone offline.  Their problems seemed to get fixed on their own, apparently when the UPS servers went back up.

Mine seemed to be lasting longer than any sort of server issue, so I created the logging file as specified in UPSXML.  This is what I get as a response from UPS in the log file:

Quote

UPS RESPONSE: <HTML><HEAD>
<TITLE>Access Denied</TITLE>
</HEAD><BODY>
<H1>Access Denied</H1>
 
You don't have permission to access "http&#58;&#47;&#47;www&#46;ups&#46;com&#47;ups&#46;app&#47;xml&#47;Rate" on this server.<P>
Reference&#32;&#35;18&#46;b47f3517&#46;1516636115&#46;64d40f4
</BODY>
</HTML>

So, I filed a trouble request at UPS.  This is their response:

 

Quote

 

Response By Email ( Corey N. ) ( 01/22/2018 11:25 AM ) U.S. Eastern Standard Time (US EST)

Dear Thomas

API URLs starting with www.ups.com/ups.app/xml/ or https://www.ups.com/webservices/ are not currently supported. We are unable to guarantee how long these legacy URLs will remain valid and active.

Please update your URLs as shown in the Developer Guides posted on ups.com. The new URLs begin with https://www.onlinetools.com.

In order to be in compliance with requirements set forth by the global Payment Card Industry, UPS has upgraded the communication security protocols for all web-based applications, including UPS Developer Kit, UPS.com and CampusShip as of January 16, 2018.

Please contact your company's IT department or development team to ensure that any security protocols currently used meet the TLS 1.2 requirement.
If Java is enabled, it must be version 1.8 or higher to use TLS 1.2 automatically by default.
If using .NET, it must be version 4.6 or higher to use TLS 1.2 automatically by default.

Please note that our integration environment (wwwcie.ups.com) will only accept TLS 1.2 requests.

If you are using a shopping cart developed by a UPS Ready or third-party provider, please contact them directly for assistance updating your implementation to TLS 1.1 and TLS 1.2 compatible.

If you are a UPS Ready Provider or independent developer with the ability to directly modify their Online Tools implementation, you will need to ensure that their implementation is TLS 1.1 and/or TLS 1.2 compatible.

How this is done will vary greatly from one implementation to the next. In some cases, it may require a change within the operating system of the server from which their implementation is hosted. In others, you may need to update the implementing coding.

Corey N.
UPS Technical Support

 

Is UPSXML dead?  Is there another module I can use?  Luckily, I have USPS and FedEx working just fine, but I had the option for UPS if a customer chose to use it - but not anymore.

Help?

Edited by TomB01

Share this post


Link to post
Share on other sites

onlinetools.ups.com

https://onlinetools.ups.com/ups.app/xml/Rate

Share this post


Link to post
Share on other sites
2 hours ago, ruden said:

OK, so does that mean if I go in and change all references for "www.ups.com" to "onlinetools.ups.com" it will work?

The e-mail from UPS stated, "www.onlinetools.com"

Edited by TomB01

Share this post


Link to post
Share on other sites
5 hours ago, TomB01 said:

OK, so does that mean if I go in and change all references for "www.ups.com" to "onlinetools.ups.com" it will work?

Try it

5 hours ago, TomB01 said:

The e-mail from UPS stated, "www.onlinetools.com"

Probably typo.

Share this post


Link to post
Share on other sites

Still doesn't work.  I even tried removing and re-installing the module.  I also tried both "onlinetools.ups.com" and "www.onlinetools.com."

However, the logging file error message has changed with "onlinetools.ups.com" - it now says,

Quote

Error from cURL: Error [35]: Unknown SSL protocol error in connection to onlinetools.ups.com:443

The e-mail from UPS had a reference to TLS V1.2.  I found a reference here from Harald Ponce de Leon that said cURL implemented TLS V1.2 with cURL V7.34.  My server info from the OSCommerce Admin says the cURL is V7.24.  I've contacted my hosting service.

Share this post


Link to post
Share on other sites

HostGator says there's nothing wrong with their web services (cURL version) or my site and that the issue is with UPS.  I've sent another e-mail to UPS.

Share this post


Link to post
Share on other sites

There is something else going on.  HostGator has proven to me that TLS 1.2 is working on my server.  Yet, UPS still gives that as the reason for the cURL error 35.

Ideas, anyone?

Share this post


Link to post
Share on other sites

Function "exec" is enabled ?

Add file index.php code

if(function_exists('exec')) {
    echo "exec is enabled";
}

 

Share this post


Link to post
Share on other sites
15 hours ago, ruden said:

Function "exec" is enabled ?

Add file index.php code


if(function_exists('exec')) {
    echo "exec is enabled";
}
Quote

exec is enabled

 

 

Share this post


Link to post
Share on other sites

CURLE_SSL_CONNECT_ERROR (35)

A problem occurred somewhere in the SSL/TLS handshake. You really want the error buffer and read the message there as it pinpoints the problem slightly more. Could be certificates (file formats, paths, permissions), passwords, and others.

try it, but I'm not sure

$this->use_exec = '1';

 

Share this post


Link to post
Share on other sites
4 hours ago, ruden said:

CURLE_SSL_CONNECT_ERROR (35)

A problem occurred somewhere in the SSL/TLS handshake. You really want the error buffer and read the message there as it pinpoints the problem slightly more. Could be certificates (file formats, paths, permissions), passwords, and others.

try it, but I'm not sure


$this->use_exec = '1';

 

I'll be danged - that worked!  Many thanks, Valeriy!

It's unbelievable how much difference it made changing a '0' to '1' on that line.

Edited by TomB01

Share this post


Link to post
Share on other sites

@TomB01 , what did you changed according to the innitial error: This module supports only xpci version 1.0001 of the UPS Rates Interface.


CONTACT ME as i am for HIRE

Get the latest osC code (the community-supported responsive version - EDGE) here:

https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

 

Share this post


Link to post
Share on other sites
1 hour ago, wHiTeHaT said:

@TomB01 , what did you changed according to the innitial error: This module supports only xpci version 1.0001 of the UPS Rates Interface.

That error happened spontaneously.  I only discovered it recently when using a test account to my store.  (My store has operated for many years.)  I had just experienced a recent change with USPS that broke my  1st Class Shipping (1st Class Parcel to 1st Class Package - Retail).  In fixing that, I noticed that the UPS Shipping was broken, too - with that error message.

My first reaction was to upgrade to the latest UPS XML as mentioned in the first post up there.  That didn't fix it and resulted in the numerous posts above, until Valeriy's post up there fixed it - changing the "0" to "1" in the code of upsxml.php.  That line that Valeriy references is somewhere in the middle of that file, but fairly easy to locate: $this->use_exec = '0';  The latest UPSXML contrib has the "0" as default.  Anyway, changing that "0" to "1" fixed it for me.  Numerous trouble chats with both UPS and my HostGator services accomplished nothing.

Edited by TomB01

Share this post


Link to post
Share on other sites

Yeah, I forgot the new URL was imbedded in the middle of that description up there.  That's what probably broke it in the first place, but I had installed the new version of UPSXML in the interim and then developed the security issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×