I've been getting the infamous "This module supports only xpci version 1.0001 of the UPS Rates Interface." error message lately.  I'm running 2.3.4 and had UPSXML 1.4.0 installed, so updated to 1.6.1.  That didn't fix it.  After some searching on the Internet, all I found were some very dated references stating that the UPS servers had gone offline.  Their problems seemed to get fixed on their own, apparently when the UPS servers went back up. Mine seemed to be lasting longer than any sort of server issue, so I created the logging file as specified in UPSXML.  This is what I get as a response from UPS in the log file: So, I filed a trouble request at UPS.  This is their response:   Is UPSXML dead?  Is there another module I can use?  Luckily, I have USPS and FedEx working just fine, but I had the option for UPS if a customer chose to use it - but not anymore.

Help?