Jump to content
Latest News: (loading..)
grandpaj

PHP Ver 5.4.45 ???

Recommended Posts

Hi

Just reading thru various security posts on the forum.

I note that currently our site is using Ver 5.4.45, There is a server available with a later version, but I am wondering if our current site (Edge version from around mid July 2016) with modifications, would handle this version OK, or whether it would/could "break" our site.

Appreciate any thoughts.

Many thanks

Grandp

(Currently we're not experiencing any problems that Im aware of)

Share this post


Link to post
Share on other sites

you can test your site in local with Winamp server or example or easy php server. But you must have the same php version than you have in your future production.

With that, you will see if your website works fine or not else it's better to go in commercial request topic and ask a financial proposition for the developer.

the second way is to create a subdomain with your new php (htaccess or admin panel configuration) version and copy your files to this subdomain test.



Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

Tuto for 2.4 :
- How to Display a new page with app
- How to make Header Tags under app APP
- How to make a
boostrap modal with external element
 

 

Share this post


Link to post
Share on other sites

John - The version you are using should run under 5.6. But that refers to the core code. If you have installed old addons that have not been converted properly, there could be problems with those, though probably not. But since you have to change servers to test it, I suggest making a copy of your site on the test server and use the IP to test it first. This assumes your host will allow this.

Share this post


Link to post
Share on other sites
11 hours ago, grandpaj said:

I note that currently our site is using Ver 5.4.45, There is a server available with a later version, but I am wondering if our current site (Edge version from around mid July 2016)  with modifications, would handle this version OK, or whether it would/could "break" our site.

If I understand what you wrote, you're currently running an 18 month old Edge on a PHP 5.4.45 server, and want to know if moving to a later PHP version (another server) will have any problems? If the later version is PHP 5.6, that should be fine (except possibly for any old add-ons, as discussed before). If it's 7.0 or 7.1, I'm not sure an Edge of that vintage has been upgraded to work on that level. You would probably have to start with a new Edge installation, and modify it to your needs. Of course, you have kept careful track of all add-ons and custom modifications as you went, so a new installation should be a breeze, right? :)


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×