Jump to content
Latest News: (loading..)
fin_anorak

Can't install shipping module

Recommended Posts

In the admin area, when I click the shipping module, it shows 7 Modules to install. (see pics)

When I click the buttonto install a module, only the already installed modules are displayed.

I'm missing the "Install modules area" which should shows me the module which i can istall.

The file directory /admin/includes/modules/shipping is "loaded" (see pics)

I have no idea what’s wrong here?

Any help is highly appreciated.

shipping_module.pdf

Share this post


Link to post
Share on other sites

That usually means that you have a broken module in /catalog/includes/modules/shipping/, or you have uploaded a file to that directory that is not a valid module. Check your files, and delete any that do not belong, one at a time.

If you can't figure out which is the problem file, delete everything that is not a part of the stock osCommerce install, then re-add you new modules one at a time, checking after each one.

Regards

Jim

 


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@tmcca  Perhaps you could state exactly what needs to be fixed/changed in the MZMT module, and why that would need a complete rewrite. I'm very interested in your thoughts.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

To start, the latest version of MZMT is an incomplete upload that can't possibly work. You need to start with Version 2.1a which is complete and known to work. You can then add the changes from the later version(s) if you need them.

Like most shipping modules, this one should work in Bootstrap without any changes.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@kymation function mzmt should be function __construct correct? Hmm; yes I added Version 2.1a let me reinstall and see. Thanks.

Share this post


Link to post
Share on other sites

You need to change the construct if you are using PHP 7.x, otherwise not. Be aware that PHP 7.x is not yet supported by most of the osCommerce addons, so you will have to do a bit of coding with just about everything you add.

The modules.php still needs to be modified, and any other changes from the instructions as well. Those changes have to do with functionality in the core code, not whether the theme is supplied by JqueryUI or Bootstrap.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

You probably have a broken module or a non-module file in the includes/modules/shipping directory. It's the next one in the file list after item.php. For more complete information on the error, check your PHP error log. You may need to ask your host where this file is located.

PHP 5.4 is obsolete and no longer supported. You should be using 5.6 at the least.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I have no idea what the filename is in Centos, but the default for generic PHP is php_errors.log.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×