Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

zpupster

oscommerce 2341 BS EDGE filenames??

Recommended Posts

hello support,

installing oscommerce 2341 BS EDGE.  in my navigation i get an   error when trying to link to contactus.php  i.e.

The requested URL /FILENAME_CONTACTUS was not found on this server.

so i noticed there is no filenames.php, in this version

what is the recommended way to handle defining the filenames in this version??

 

thanks 

 

craig

Share this post


Link to post
Share on other sites

There is no 2.3.4.1BS. Did you mean 2.3.4BS Edge? Is this stock (vanilla) code trying to use a defined name, or did you install an add-on? The add-on might have to be modified to hard code the name contactus.php, or to include a filenames.php from an older release. If this is a vanilla installation, please report it to @burt via the 2.3.4BS Community area.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites
31 minutes ago, MrPhil said:

There is no 2.3.4.1BS. Did you mean 2.3.4BS Edge?

Hello Phil @MrPhil,

The actual EDGE BS responsive community version (2017/08/30) is up to date with the 2.3.4.1 standard codebase and therefore can be considered 2.3.4.1. BS

Although in the readme file still states 2.3.4, the 2.3.4.1 code changes are applied:

ignore e_deprecated messages; set empty mysql sql_mode

Share this post


Link to post
Share on other sites

thank you,

i can go ahead and hardcode the links.

no,  it is not an addon. i copied code from previous version, before i found out that there is no filenames.php and database table name file.

the version is 2341.

i will try working with it but,  i may revert to 234 bsedge .

thanks everyone.

craig

Share this post


Link to post
Share on other sites

@zpupster There is also a compatibility addon that enables you to continue to use filenames.php if you want.  At least I think that is what it does. Goggle for it if you want.

Dan

Share this post


Link to post
Share on other sites

×