Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

frankl

Your secure certificate might not be trusted soon

Recommended Posts

Do you have a Symantec (or one of it's sub-brands) secure certificate on your site? Includes:

  • Thawte
  • VeriSign
  • Equifax
  • GeoTrust
  • RapidSSL

Many do. 

It has been announced that the Chrome browser will no longer trust these secure certificates from Symantec's infrastructure if issued before December 2017, due to flaws in their certificate issuance structure.

From Chrome 62, to be released in late October 2017, there will be a warning in the development tools console if your certificate is affected. From Chrome 66, Chrome will completely distrust Symantec certificates issued before June 1, 2016. 

From December 1 2017 Symantec will be using Digicert's infrastructure to issue certificates and from Chrome 70 (October 2018) all trust will be removed for certificates issued prior to that.

All this goes back years when Symantec issued dodgy certificates.

If you have a Symantec issued certificate, make sure you have it reissued and reinstalled as soon as possible after December 1 2017.

Full details here


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

×