Jump to content
Latest News: (loading..)
Sign in to follow this  
tmcca

Added CCGV for bootstrap

Recommended Posts

I am installing important add-ons that I feel should be part of the core. Any suggestions or fixes welcome

 

Edited by burt
Remove Forked URL

Share this post


Link to post
Share on other sites

The idea is not to add these ancient old addons...

but instead to create a clean core suitable for drop in modules.
 


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

I have also moved your topic into the correct Channel.  And removed your Fork URL as it is unhelpful to further fragment the community.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites
On 9/3/2017 at 4:53 PM, tmcca said:

I am installing important add-ons that I feel should be part of the core. Any suggestions or fixes welcome

 

The whole trouble with adding code that you want to the core, means that it may be something that I dont want. I may need something different and it wont all get added.

The whole idea is to keep the core code clean and simple and let people add easy to install one click addons for the functionality required by each store. When you think about it it makes more sense this way. Forget the old way of doing things, its in the past.


REMEMBER BACKUP, BACKUP AND BACKUP

Before installing the official version of oscommerce first look at a responsive version here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

true to that; Yeah I was looking into creating CCGV as a Module instead of editing core not sure how would do that; I am guessing to add a require to pages that need it.

Share this post


Link to post
Share on other sites

@omar_one do you have what you did for bootstrap? I am confused on checkout_payment as there is a javascript function do you keep that or remove it?

Share this post


Link to post
Share on other sites

@burt I think it had been rewritten for BS version but it have not pushed as addon.. but it still not a drop in modules..
and its true that the coders have to focus on creating  a clean core suitable modules for drop in modules.

Omar

Share this post


Link to post
Share on other sites

@Omar_one Yes I am looking into that like how Paypal is as an app. Some changes to core would be to require the actual app thats it. Also looking to add Store Credit option to use with RMA add on. As of now only Gift Vouchers or Store Credit can be used not both.

 

Edited by tmcca

Share this post


Link to post
Share on other sites
23 hours ago, Omar_one said:

@burt I think it had been rewritten for BS version but it have not pushed as addon.. but it still not a drop in modules..
and its true that the coders have to focus on creating  a clean core suitable modules for drop in modules.

Omar

Any module that requires a core change...is OK to use, so long as the shopowner makes a note of what was changed and why it was changed.  No problem.

A potential problem comes when modules like these are inserted into a fork (where the fork is made by someone who cannot code)...and the fork is then advertised here in this forum.  


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

I did see it, thank you for the push.

The Community Edition is at a "sleeping" phase until we see what is happening with
the official release of 2.3.5 [last in the line of outdated 960] & 2.3.6 [first in the line of bootstrap]


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Actually I dropped it have to fix some things on it. Curious what would be better to download? 2.3.4.1? or bootstrap? I see the oscommerce2 github has OSC folder your don't. I am guessing this is the one in development. 

Share this post


Link to post
Share on other sites
15 hours ago, tmcca said:

Actually I dropped it have to fix some things on it. Curious what would be better to download? 2.3.4.1? or bootstrap? I see the oscommerce2 github has OSC folder your don't. I am guessing this is the one in development. 

You are looking at 2.4.  2.3 will never have an "OSC" folder (or put technically:  namespaces).


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×