Jump to content
Latest News: (loading..)

Recommended Posts

I really don't want to go bootstrap at this time since I have a lot of addons in my store and if I go bootstrap most likely breakup. How can I update to 2.3.4.1? or is that bootstrap? Thanks

Share this post


Link to post
Share on other sites

No, that version just has some bug fixes, as I recall.  Harold said he would release a new version soon and that the existing 2.3.4 and BS shops would be upgradable to it.  That will probably break your shop since addons in it were installed by editing core files. The problems can be fixed, of course, but you may find it not worth it and just to start over anyway. The big unknown is when the new version will be released. if it is tomorrow then you can afford to wait. If it won't be for another year, you will be hurting your shop since it is not mobile-ready, unless you have done something to it to make it so.

Share this post


Link to post
Share on other sites

If you're already running on v2.3.4 without any issues, there is no need to update to v2.3.4.1. It would be better to update to v2.3.5 to apply the latest security fixes, compatibility fixes, and bug fixes. You will also have the option to update to v2.3.6 when you're ready to move to the bootstrap series.

v2.3.5 will not break compatibility with existing addons - it's a maintenance release that will finalize the v2.3.4 release series and is planned to be the last release of this series.

v2.3.6 may break compatibility with existing v2.3.4 addons due to moving to bootstrap. The 2.3.6 version label will be added to the Apps Marketplace once it's released so updated addons and Apps can be clearly labelled.


:heart:, osCommerce

Share this post


Link to post
Share on other sites
2 hours ago, Harald Ponce de Leon said:

The 2.3.6 version label will be added to the Apps Marketplace once it's released so updated addons and Apps can be clearly labelled.

Smart move Harald.


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

The way I'm reading Harold's reply is that 2.3.5 will not be mobile-ready. Regarding the bootstrap and addons, any of the old addons can be made to work with the BS version, though it can be difficult with some of them.

Share this post


Link to post
Share on other sites

@tmcca

2.3.5 is an update to 2.3.4. It will bring it up to date for more modern PHP and mySQL versions plus fix a few bugs.


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

Does 2.3.4.1 support PHP 7 or not? I thought "no", but Harald PM'd me asking what the problem was with PHP 7 and why I was cautioning against using 2.3.4.1. Is it at least up to PHP 5.6? Is PHP compatibility the only "bug fix" in this release, and is it complete and working well? The lack of information leaves me no choice but to keep recommending 2.3.4BS Edge, which I will continue to do until this issue is resolved.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

v2.3.4.1 is a hotfix release that addresses compatibility with PHP 7 and MySQL 5.7. This is the changelog for the release:

* Improve detection of MySQLi during setup.

* Update session handler functions to return correct return value types.

* Ignore E_DEPRECATED PHP notices.

* Set empty MySQL sql_mode for compatibility across MySQL versions.

 


:heart:, osCommerce

Share this post


Link to post
Share on other sites
Quote

If you're already running on v2.3.4 without any issues, there is no need to update to v2.3.4.1.

My web host is demanding I upgrade to 2.3.4.1, pretty sure just because it is listed as an updated version. Can anyone tell me exactly what files would need to be updated to go from 2.3.4 to 2.3.4.1?  I have a lot of customization, including mobile version, and do not want to start over at the moment.

thank you!

Share this post


Link to post
Share on other sites

The version your host is suggesting is also out of date.  You should update to the latest version...EDGE.  You'll find the link in my signature file and it is already mobile friendly. 

Dan

Share this post


Link to post
Share on other sites

@GetSirius

I can't imagine that a reputable host would demand that you "upgrade" your site. That said ...

They *might* be planning to upgrade their version of PHP to 7.x, and anticipate that your store will have problems. Do note that 2.3.4.1 is also old (see @Dan Cole's post above), and does not guarantee to run under PHP 7.x

If you truly wish to "upgrade" your site to v 2.3.4.1, you're going to have to use a file compare program, such as WinMerge, to compare all of the files in the 2.3.4.1 package with all of the files from your shop. Do note that all of your customization will show as a file difference, so you will have to know what's a 2.3.4.1 change, and what's a customization change.

Now, if all you are trying to do is get your host off your back, you can edit the /catalog/includes/version.php file to say 2.3.4.1 (not that I'd suggest such a thing <wink>). This won't make it run under PHP 7.x, though.

Although you don't want to hear it, the best option is to invest the time to move your store to Edge.

HTH


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release here

Share this post


Link to post
Share on other sites

Just to clarify matters (I hope), if you are currently on osC 2.3.4, it will break if and when your host upgrades to PHP 5.6 or higher. Note that PHP 7.1 is considered "current". The "official" osC 2.3.4.1 is better than 2.3.4, but it's not really PHP 7 compatible. I strongly disagree with HPDL, in that simply turning off "deprecated" warnings is asking for trouble. It's like your ship had a torpedo tear a huge hole under the waterline, and you're simply going to drape a large plastic sheet over it, crank up the bilge pump, and continue sailing around the world!

The unofficial (community-supported) osC 2.3.4.1BS Edge is really PHP 7.0 (7.1?) compatible, and has mobile built-in (in addition to many other fixes and enhancements). In the long run, you'll spend less time and effort installing this one and migrating your data over, than trying to fix up an old 2.3.4 (or even 2.3.4.1).


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Thank you to everyone for their help. I see that my path should be to go with Edge and will do so soon..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×