Latest News: (loading..)
Lcdo. José Fernando Frugon

Problems connecting to mysql based on xampp in oscommerce installation

4 posts in this topic

Dear Misters). Oscommerce Community; Good afternoon!; The reason for participation in this forum; Is to indicate the following: At the time of the installation of the oscommerce tool, on a local server with xampp; I get an error in the installation that says "Mysql extension is required but is not installed. Please enable it to continue"; For this install PHP, and local server with xampp; On which attached screen: How can I fix this?

 

I also attached the PHP link or link

Http://php.net/

Web Site Of PHP

And from where to download the xampp to configure local server, 

 
 
 
 
 
 
 
41/5000
 
If you can help me urgently with this.
 
 
 
41/5000
 
If you can help me urgently with this.

Https://www.apachefriends.org/en/index.html

 

 
 
 
 
 
41/5000
 
If you can help me urgently with this.

 

 

Problemas al instalar Oscommerce(no conecta a base de datos).jpg

Share this post


Link to post
Share on other sites

You might have MySQLi installed (the more advanced version) rather than MySQL, or maybe neither is installed. I vaguely recall seeing reports that old versions of osC (such as 2.3.4) not being able to handle MySQLi-only PHP installations. If you're on XAMPP, you probably have a very recent level of PHP that may not even have MySQL.

First things first. Do not install and use osC 2.3.4. It is thoroughly obsolete and won't even run on any up-to-date server. You need to install and use 2.3.4BS "Edge", which is the most up-to-date production-ready package. Do not install a public-facing store on your own PC server, using *AMPP. It's OK for testing the waters and playing around, and even testing PHP levels your real server doesn't offer, but don't do production work on such a server -- hackers will eat you for breakfast. Get a professionally managed commercial server account if you intend to set up a real store.

Share this post


Link to post
Share on other sites

Dear Mr. Phill, reviewing the oscommerce page; In the part where the oscommerce package is downloaded (https://www.oscommerce.com/Products); In the option of downloads; This list of these 2 products appears: 

<a href="https://www.oscommerce.com/Products" /a>


V2.3.4 Complete package
V.2.3.3.4 to v2.3.4 package update.

Now you tell me the following: "You may have MySQL installed (the most advanced version) instead of MySQL, or maybe it is not installed. I vaguely remember seeing reports that older versions of osC (such as 2.3.4 ) Were not able to handle MySQL-only PHP installations.If you're in XAMPP, you probably have a very recent level of PHP that can not even have MySQL.

The first is the first. Do not install or use osC 2.3.4. It is completely obsolete and does not even run on any upgraded server. It is necessary to install and use 2.3.4BS "Edge", which is the most ready package for production. Do not install a public facing store on your own PC server, using * AMPP. It's okay to test the waters and play, and even test the PHP levels your actual server does not offer, but do not do production work on a server of this type - hackers will eat you for breakfast. Obtain a professionally managed commercial server account if you intend to create a real store.

Attached screen of the same
But I want to do an install on a local server with xampp; For now as I do not have a hosting service hired for now, maybe later; But if I previously did the installation what I did is that this program xampp disinfect since I had problems and I reinstalled everything again; And the configuration of my PHP MyAdmin is properly configured and running what attached screen; Then what is the problem that does not continue with the installation ?; Whether to make any changes within the oscommerce package; Inside a folder or has to do with the installation of xampps.


Your help.
 

 

Packages of oscommerce (option installation).jpg

PHPMyAdmin.jpg

Share this post


Link to post
Share on other sites

Hi Jose..

We are aiming to push out v2.3.5 and v2.3.6 this month. v2.3.5 includes PHP 7 and MySQL 5.7 compatibility fixes to the v2.3 codebase, and v2.3.6 migrates the community bootstrap edge version into an official release.

To get that specific issue fixed which you are experiencing, please make the following change to the following file:

catalog/install/templates/pages/index.php

https://github.com/osCommerce/oscommerce2/commit/d7f47032afbda82c6342c6fc83777de30a36b5b8

crimble crumble and frankl like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now