Latest News: (loading..)
zwayne

OSC 2.2 / 5.5 Php Incompatibility but works OK on localhost!

10 posts in this topic

Highly customized osCommerce 2.2-MS2 shop that has been online & stable for many years.

I had no clue about the incompatibility of OSC 2.2 and php 5.3 until our hosting company updated php to 5.5 without notifying us in advance. It broke the website (deprecated functions and all that) but they downgraded us back to php 5.2 and all was well again. But recently got a notice that they are completely removing 5.2 in a week. V5.3 will still be available but OSC 2.2 doesn't work with that version either.

I've since read all of threads about incompatibility with OSC 2.2 and php 5.5 and the difficulties in updating OSC and the most frequent recommendation to start from scratch with the newest OSC release. That simply is not possible in a week's time.

Here is the problem which is stumping me:

I use a local copy of OSC for testing. Except for a few changes in configure.php due to local file references it uses the exact same files as production. BUT the localhost install uses php 5.5.3 with no problems! Any ideas how this is possible?

Thanks.

 

Share this post


Link to post
Share on other sites

Posted (edited)

If it won't run PHP 5.5 on a real host, it won't run it on a "localhost" *AMPP PHP 5.5 install, either. I suspect that you think you've got PHP 5.5.3 running, but you're actually running on PHP 5.2 or so. What does phpinfo() say on your localhost? If it really is 5.5.3, are you sure you are running a copy of your osC 2.2 on the localhost, or could a later version (2.3.4 or so) have snuck in during testing?

Even though your beloved 2.2 store is "highly customized", you really ought to be taking a serious look at osC 2.3.4BS Edge. It has many new features, security improvements, responsiveness (is mobile-friendly), and runs up to PHP 7.0. At some point, the pain of constantly patching osC 2.2 to keep it running on newer server levels will exceed the one-time pain of installing the current osC and migrating your data over to it. Do take a serious look at the process, and what add-ons and custom programming you might need.

Edited by MrPhil
add suggestion to upgrade to 2.3.4BS

Share this post


Link to post
Share on other sites

Thanks for the response.

Phpinfo says 5.5.3 and the files on test and production are exactly the same (just to make sure that I wasn't hallucinating, I downloaded the production files and ran kdiff to make sure).

Which is why this has me puzzled.

The big kicker is that this site was slated for eventual replacement (a web developer with a lot of woocommerce experience was going to be using that product.) But it's going to take a while.  I'll play with 2.3.4 to get an idea if a quick implementation is possible.  However, I'm stretched pretty thin with IT responsibilities and am doubtful if I can do it in time.

 

Share this post


Link to post
Share on other sites

Arg. This installation bug was reported in Oct 2015 and the base package was never fixed? Seriously? 

https://github.com/osCommerce/oscommerce2/issues/368

https://github.com/osCommerce/oscommerce2/commit/d7f47032afbda82c6342c6fc83777de30a36b5b8

Then I got bit with php 7.0 incompatibility errors ( Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP ) even though the installation check said everything was fine. So I reinstalled under php 5.6

Unbelievably unprofessional.

Share this post


Link to post
Share on other sites

@zwayne

if your Osc2.2 work with php 5.6, you can read this : http://php.net/manual/en/migration70.php

In this page https://www.oscommerce.com/Products in the "release history", you can see all the different versions of OsCommerce. Osc2.2 is really a very old version ...
The 2.4 version is a beta version, but there is a community version 2.3.4 BS witch is a responsive version with php7 : https://github.com/gburton/Responsive-osCommerce/archive/master.zip Thanks to all the contributors for this responsive version.

 

Share this post


Link to post
Share on other sites

Do NOT use the official 2.3.4 release. It has not been updated since its release, and never will be updated. It's out of support. It doesn't even run on any current PHP. Use the community-supported 2.3.4BS "Edge" version instead (you have to get it from GitHub). If it has any installation problems, @burt will quickly fix it.

Share this post


Link to post
Share on other sites

Now I am totally dumbfounded.

I'm sorry, but I went to the official site

https://www.oscommerce.com/Products

and selected

Download the latest version to install on your own web server.

I installed that version, updated my 2.2 database, and am now struggling with trying to get things looking like the old site (among other things, I used STS). 

And now I'm told that I'm supposed to go to Github to get the most current version because the official site references an out of date version? Seriously?

(Please don't take this as any personal anger as I do appreciate the help.)

 

 

 

Share this post


Link to post
Share on other sites
7 hours ago, zwayne said:

Unbelievably unprofessional.

You should ask for your money back.

But seriously, it's one line of code that you can change yourself. Or use the community version. How hard is it?

Share this post


Link to post
Share on other sites
4 hours ago, zwayne said:

Now I am totally dumbfounded.

I'm sorry, but I went to the official site

https://www.oscommerce.com/Products

and selected

Download the latest version to install on your own web server.

I installed that version, updated my 2.2 database, and am now struggling with trying to get things looking like the old site (among other things, I used STS). 

And now I'm told that I'm supposed to go to Github to get the most current version because the official site references an out of date version? Seriously?

(Please don't take this as any personal anger as I do appreciate the help.)

Literally, yes. The official osC 2.3.4 release is a piece of shit. The guy who runs this site and controls what's listed as "current" doesn't care in the least. If he did, he would have put 2.3.4BS Edge out as the current release (as 2.3.5) at least a year ago (and it would be up to 2.3.6 or 2.3.7 by now). There's no excuse for keeping such an obsolete version, which doesn't even run on current PHP versions, listed as "current". It's no wonder that the general ecommerce community warns away potential osC users that it's totally unsupported and dead. And all Harald cares to do is tinker with 2.4 and 3.0, which he promised would be out many years ago. If you don't want to be declared dead, you have to refresh at least every 12 months. What a shame.

Share this post


Link to post
Share on other sites

Posted (edited)

frankl - "how hard is it?" Seriously? The first problem I mentioned is only couple lines of code but first one has to encounter the failure, then research to figure out why, and only then make the code mods. And the second problem (php 7 incompatibility) certainly NOT a "single line of code".

So your snarky unhelpful reply "how hard is it?" should really be "how hard is it to REMOVE the WRONG version touted as the most current and put up the CORRECT one and thereby avoid the problem in the first place?"

Edited by zwayne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now