Jump to content

Archived

This topic is now archived and is closed to further replies.

tinglei

Urgent! osCommerce is unable to run on new GoDaddy Hosting

Recommended Posts

I have a online shop osCommerce 2.2rc2a running under GoDaddy Linux hosting for many years. But a few days ago, the GoDaddy forced to upgrade my hosting without any notification and said the reason is my hosting is too old. After that, my site crash.

After a few days debugging, I couldn't figure out anything wrong with the hosting configure and oscommerce configure.

Then I ordered a fresh Hosing and have a fresh install of osCommerce on it. It get error like this:

http://www.voguesrus.com/oscommerce.com/index.php

 

"Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/voguesrus/public_html/oscommerce.com/includes/functions/database.php on line 19

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/voguesrus/public_html/oscommerce.com/includes/functions/database.php:19) in /home/voguesrus/public_html/oscommerce.com/includes/functions/sessions.php on line 102

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/voguesrus/public_html/oscommerce.com/includes/functions/database.php:19) in /home/voguesrus/public_html/oscommerce.com/includes/functions/sessions.php on line 102

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Deprecated: Function eregi() is deprecated in /home/voguesrus/public_html/oscommerce.com/includes/classes/language.php on line 87

Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/voguesrus/public_html/oscommerce.com/includes/languages/english.php on line 317"

 

It makes me crazy! So, what should I do now? HELP!

Share this post


Link to post
Share on other sites

The codebase that you are running needs php 5.2 to run without warnings (eregi was deprecated in 5.3).

The version of php you are currently running is 5.5 (mysql is also deprecated).

You may not have 5.2 available but probably can use a lower version than 5.5 - check with your hosting.

You can suppress the deprecated warnings (and the headers already sent error will go away). To do this you should change your includes/application_top.php file in both catalog and admin:

  error_reporting(E_ALL & ~E_DEPRECATED & ~E_NOTICE);

It's likely E_ALL & ~E_NOTICE

Probably that's all you need to do to fix the problem. The functions that it's whingeing about are still included in php until version 7.

However, you should think about moving (over time) to a more modern, mobile-friendly version of oscommerce.


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

This is the sort of thing that happens when you fail to keep your stores software updated. You are not on your own, loads of people just seem to forget about what makes the store work, and then blame their hosts for breaking their store.

Once you get the old unreliable and insecure store running as best you can, you should seriously consider updating to the latest version. It will take time, and it will take work, but it will be so better for your customers and you. Addons are so easy to install, mainly just upload andf click. Your store will be mobile friendly, and with numbers of customers rising that are using a small device, are you ready to be loosing sales because your store is old. You are probably already loosing search ranking because of your site.

As John has already mentioned you can suppress the errors, but that is only like papering over the cracks. You can search  for theerrors as you wont be the first to have them, and find  a cure for each og them, but there will be lots more and lots of code to change.

Good luck.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

×