Jump to content
Latest News: (loading..)

Recommended Posts

Hi all.

 

I have a problem with the address format.

 

I am testing bs edge, and have converted the store to UK format using UK_quick_localisation, and installed ship rates for UK Postcodes_6165.

From my shop, in Create Account the customer fields are as follows :

-First Name

-Last Name

-E-mail

-Street Address

-Suburb (with the text “suburb” removed leaving just a blank field, for addresses that need it).

-Town

-Post Code

-County

-Country.

 

However, after the above information is typed in, and the customer clicks through checkout, the address format has changed to :

-First Name

-Last Name

-Street

-Suburb

Then a gap of three lines, with

-Post Code, at the bottom.

The Town, County and Country are not present! although there is space where they should be, and the postcode has been moved to the end.

 

The above is the same for the Admin/Orders/Invoice and Admin/Orders/Packing Slip, but the address is in the correct format in the Admin/Customers/Edit.

Any pointers will be much appreciated.

Share this post


Link to post
Share on other sites

Are both of those addons compatible with the latest BS version. They may need a lot of converting to get to work, but if you did that then why not upload the file changes as a latest version so others could benefit from it. Shame to do all that work, and then not make use of it.

There used to be an old thread on these forums somewhere that explained how to convert a store to UK address layouts and also date format. It is a bit old now so could do with being updated, but the same code blocks need to be changed although the code is different. It was only a case of changing the positions of blocks of code in some files, and then change the date format in the language file.

So your first move is to put everything back as it was but removing all the code changes and sql alterations and start again by reading

 


REMEMBER BACKUP, BACKUP AND BACKUP

Before installing the official version of oscommerce first look at a responsive version here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Hi Steve

These add-ons were used after reading discussions in previous posts on the forum, so all of the changes I have made are well documented.

I have just been comparing the sql file to my original backup, they do seem to be very different, I think I will take a closer look to see what I can find.

I will post back if I find any problems.

 

Share this post


Link to post
Share on other sites

OK

I have now discovered that there were two extra address formats added, (6 & 7) I used 6 which shows the address correctly.

My original question was posted as I had an error message when trying to create a test customer, this I believed at the time was due to the address format :

 "Shipping is currently not available for the selected shipping address. Please select or create a new shipping address to use with your purchase".

Under phpMyAdmin/address_book the entry_country_id for my UK store is 222, but for the created test UK account the entry_country_id is 242, obviously this is the problem.

How can I change these codes? Which one is correct? I have seen both in different places.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×