Latest News: (loading..)
inra311

Multiple Images suddenly looking weird and nothing happens at mouse over

21 posts in this topic

Can anyone help and give me an idea what has happened, and how to fix:

 

I set up a fresh 2.3.4 BS recently, coming from a 2.2 -> 2.3.1 OSC that meanwhile died because of a PHP upgrade to 5.6.A bit later I imported most data from the old shop, like customers, orders, products, product descriptions and so on.

 

Right after installing the shop, I discovered the example products that were installed with it and the 'new' feature to have multiple pictures without a dedicated contribution. I am sure those little pictures changed at mouse over to the big one.

 

Meanwhile this does not work anymore: One picture is still bigger, the others are small below but mouse over does not do anything at all. I am not sure if their placement is different, they are all touching each other now (maybe this was before as well but looked different as the example pictures had all white background?) When I click on one of them, they open in a new window and I can step through them as normal. Tested with different computers to check if it is a browser problem.

 

I did not remember to modify any files at all (besides configure.php, and adding language files)!

 

What I did:

- I changed the size of images in admin -> configuration -> images (making them all a bit bigger, like  e.g. 150x120 instead of 100x80.

- I deleted most of the example products

- After importing all product description tables from the old store, I simply copied all images from the old image folder into the one of 2.3.4BS, as they were (different sizes, possibly some with solghtly different dimensions)

(- I later imported all picture file names for additional from the old shop where these were done with a multiple image contribution. I exported these additional columns in products-description from the database, rearranged them in a CSV file to make all match the database table sche,e for products_images. )

 

*The problem already came up before the last step, with some newly added test products and uploaded pictures via the built in add large pictures feature.

 

No idea what causes this at all :(

Thanks for help-

Share this post


Link to post
Share on other sites

@@inra311  Ingo...a couple of screen shots showing us what you are seeing might help someone offer some suggestions.  Having a large image with smaller ones below is the usual behavior, at least in my shop.

 

Dan

Share this post


Link to post
Share on other sites

@@inra311

 

That mouseover feature is not available anymore in the latest versions of osC.

The old shops used fancybox to show the images. Since fancybox updated to version 2 their license is not free anymore so the osC Team was forced to go with a different image module which doesn't have that nice mouseover feature.

Edited by Tsimi

Share this post


Link to post
Share on other sites

I see. However, I am sure it worked with the example products after installing (?!)

 

Here is a screenshot as it looks now with eg. four pictures uploaded. When I click on one of them, this one is opened in a window where I can scroll from the first to the last.

 

So possibly everything is working normally... too bad, I really liked the mouse over feature :(

post-334884-0-72806400-1487316351_thumb.jpg

Share this post


Link to post
Share on other sites

@@inra311

 

Yes that is correct.

When you click on any picture, small or larger, they pop up.

Yeah, I personally liked that feature too but as an opensource project you cannot use a license such as fancybox 2 uses.

You can of course purchase that license and install it in your shop though. It ain't an easy task but possible. I think I have seen someone in this forum that had that feature back inside a osC BS shop.

Not sure what the difference is between the new fancybox 2 and the older fancybox version but if there are no security concerns you could even install the older fancybox from an older osC shop into a BS shop.

If you cannot do it yourself you could ask in the Commercial Support Enquiries area for a quote.

Edited by Tsimi

Share this post


Link to post
Share on other sites

The issue has nothing to do with fancybox

 

It is true that in version 2.3.4, fancy box for replaced by ciolorbox, but this affect only the pop up, not the way the gallery behaves

 

The gallery changed in version 2.3.4 from "bxgallery" to "photoset grid" and that is what affects the muse over behaviour

 

You can still use fancybox for the pop up (the "old" free version), but this won't give you the mouseover back

Share this post


Link to post
Share on other sites

I stand corrected.

Then why has that nice feature been removed I wonder?

Edited by Tsimi

Share this post


Link to post
Share on other sites

U talk about fancybox? I did change to the jQuery fancyBox v2.1.5 it's free and work well

Edited by burt
remove external link

Share this post


Link to post
Share on other sites

With weird looking I mean that the pictures are very close together, see the two screenshots from my and your shop. Why are the spaces and little frames gone (I do not remember to have changed anything, see above).

 

And with mouse over I do not mean the magnifying glass like in your shop but that the little picture becomes the one displayed as the main picture. Wasn't it like this right after the fresh installation with the example products? I might be wrong...

 

Also, the position of the 'add to cart' button looks a little odd...

 

 

post-334884-0-76826600-1487363515_thumb.jpg

post-334884-0-48564300-1487363525_thumb.jpg

Share this post


Link to post
Share on other sites

For the borders and positioning stuff that should be controlled through your user.css file...did you make changes to it?....you can use one of the browser inspectors to see the differences between the two shops and adjust to suit.   Not sure about the roll over issue...maybe some one else will chime in.

 

Dan

Share this post


Link to post
Share on other sites

that should be controlled through your user.css file...did you make changes to it?...

 

No, nothing changed, this is why I am wondering ... it was fine with my fresh install, then I imported picture file names into the database and copied all images into the image folder..

Share this post


Link to post
Share on other sites

I don't know if you had a look at the css elements to see what is different but something must be....got a url we can look at?

 

Dan

Share this post


Link to post
Share on other sites

With weird looking I mean that the pictures are very close together, see the two screenshots from my and your shop. Why are the spaces and little frames gone (I do not remember to have changed anything, see above).

 

And with mouse over I do not mean the magnifying glass like in your shop but that the little picture becomes the one displayed as the main picture. Wasn't it like this right after the fresh installation with the example products? I might be wrong...

 

Also, the position of the 'add to cart' button looks a little odd...

 

i change the margin-right of my thumbnails. This is not the original images stuff of osCommerce. The images i use are more bigger than the original. I change to 600x600px. The zoom for the images is elevateZoom i implemented too.

 

a url for to look at would be good.

 

regards Manfred

Share this post


Link to post
Share on other sites

I had to setup the shop in a hurry and am still fighting many minor issues...

Edited by burt
removed url per request

Share this post


Link to post
Share on other sites

The first thing I'm seeing is your images are 100 X 80 although you said that you...

 

I changed the size of images in admin -> configuration -> images (making them all a bit bigger, like  e.g. 150x120 instead of 100x80.

 

 

Some on here would argue about this but I would square the images up....make the originals 500X500 or something like that and then set them to 100X100 or 200X 200 or whatever. That will sort out some of the irregular display issues.  I'm off to have another look.

 

Dan

Share this post


Link to post
Share on other sites

I was going to compare your css elements for the pages you have with the other shop that you wanted to have it look more like.  The one in this post....

 

http://forums.oscommerce.com/topic/410766-multiple-images-suddenly-looking-weird-and-nothing-happens-at-mouse-over/?p=1753435

 

But I'm not exactly sure what shop you're comparing your shop too....another link would help.

 

Dan

Share this post


Link to post
Share on other sites

I am not necessarily comparing my site with a particular other one. I remember it to look different after the fresh install with the example images than it does now, after importing my products and pictures so I had the feeling something is screwed up. If you say it looks like a properly installed ('normal') 2.3.4 BS OSC it should be alright amd my memory plays a trick on me. I even think the imgage on top changed to ono of the small ones at mouse over (??).

 

he first thing I'm seeing is your images are 100 X 80 although you said that you..

 

It was 125 x 100 when I wrote it and made the screenshots, I changed it back for a while to see if this changes anything (beside picture size)

 

Thanks for your effort to help :)

Share this post


Link to post
Share on other sites

Watch my screenshoot please. I know how to change. If you like i do, than send PM to me thx!

post-341966-0-44243500-1487441285_thumb.jpg

Share this post


Link to post
Share on other sites

I presume you've checked that you didn't accidentally turn off Javascript in your browser? That could account for mouseover functions no longer working.

Share this post


Link to post
Share on other sites

Javascript is on..

 

Is with the 2.3.4 BS Edge, fresh installation, mouseover with the product thumbnal pictures on product_info supposed to do anything or not?
The previous answers indicated that mouseover is disabled meanwhile.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now