Jump to content

Archived

This topic is now archived and is closed to further replies.

Leak-Proof

Admin area - "The page isn’t redirecting properly"

Recommended Posts

So I have been running a couple of oscommerce sites for several years. v2.x

The sites have been working very well for us. This weekend the host changed the server to run php 5.6 which broke the site but they also implemented a tool so users can choose their preferred version of php, so I switched it back to 5.3. ( I first went back to 5.5 then 5.4 till they told me to go back to 5.3 which was what I was successfully running a couple of days back. The site now has some problems. For one, I can't get to the admin login page. It says it is not redirecting properly. Also my front end has an error and is not loading the right column.

The error for that is

 

PHP Warning:  strip_tags() expects parameter 1 to be string, array given in /home/xxxxxxx/public_html/xxxxx/includes/boxes/whats_new.php on line 71

 

The other site is an almost identical oscommerce site on the same server which was directly switched back to php5.3 using the tool and it is functioning flawlessly.

 

The host suggested my htaccess file may have been affected some how but they are not the best a offering help.

 

Can anyone assist or recommend a coder to help me out.

Thanks,

R


I like these mods, there fun! ...65 70 72 75 80 85 125+ contributions installed and counting...

 

Tools I'm using: OSC2.2 milestone2, Filezilla for FTP, PHP Designer 2007PE (nice), Araxis Merge 6.5 to compare files, XP(my box), Remote Server is shared Apache 1.3 Cpanel, CURL, and PHPmyAdmin through my hosts Cpanel to mess up the database.

Share this post


Link to post
Share on other sites

@@Leak-Proof

 

To help you better, it would be easier if we could see the code to the whats_new.php file. There's different whats_new.php files out there.

 

Errors can popup out of nowhere when you change PHP version. Since you reverted back after the upgrade, the newer version could still be in the cache. You can try clearing the cache through your browse and, refreshing the page the error is on.

 

PHP 5.3 is really old and obsolete. It's also very insecure. I'd advise you to go to a higher PHP version. Although, going to a higher version can cause more errors in the beginning, it's way faster, more efficient and secure. PHP 7 works great for me. Once you work the bugs out it's beautiful. Although it all depends on how old your site. You might only be able to use 5.6.

 

Post your code and I'll try to help.

 

Take care

Bill

Share this post


Link to post
Share on other sites

If you are running anything older than the current osC, which is 2.3.4BS, it will fail on PHP 5.5 and 5.6 without extensive modifications. Exactly what osC version are you running? Since running unsupported backlevels of PHP is not a good idea, you should use the time bought by your switch to PHP 5.3 to upgrade to current osC. Then come back to PHP 5.6. Note that even though (plain) 2.3.4 is officially the current osC version, it is unsupported and does not run on current PHP levels. At some point in the future there might be a 2.3.5 release which runs at PHP 5.6, I wouldn't wait for it. Even further off is osC 2.4 (currently in beta).

Share this post


Link to post
Share on other sites

×