Jump to content
Latest News: (loading..)
UncleSteve

Wanted Sales by customer by time (year/month)

Recommended Posts

I've tried several addons, but none deliver what I'm looking for.

 

Can anyone point me to a suitable addon that will give me a report of sales by customer between set dates please

 

Thanks in advance.


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

The monthly sales and tax report addon will do that, as I recall.

Share this post


Link to post
Share on other sites

@@UncleSteve

 

This might help. It can do set dates. http://addons.oscommerce.com/info/8307

 

Sample output below.

 

Orders_id    Date    Time    First_Name    Last_Name    Name_On_Card    Company    email    Billing_Address_1    Billing_Address_2    Billing_City    Billing_State    Billing_Zip    Billing_Country    Billing_Phone    ShipTo_First_Name    ShipTo_Last_Name    ShipTo_Name    ShipTo_Company    ShipTo_Address_1    ShipTo_Address_2    ShipTo_City    ShipTo_State    ShipTo_Zip    ShipTo_Country    ShipTo_Phone    Transaction_ID    Order_Special_Notes    Comments    Order_Subtotal    Order_Tax    Order_Insurance    Tax_Exempt_Message    Order_Shipping_Total    Order_Grand_Total    Number_of_Items    Shipping_Method    Shipping_Weight
 

Edited by ecommunlimited

Share this post


Link to post
Share on other sites

@@UncleSteve If you decide to use the addon @@ecommunlimited mentioned, if you would like, please email me and I will send you an updated version of it that has a lot of improvements. It is going to be an addon but is not quite complete.

Share this post


Link to post
Share on other sites

Hi guys,

 

Thanks for the leads, very helpful.

 

As usual with my very old set up, the install instructions never quite match my system. The instructions says...

 

 

catalog/admin/includes/boxes/customers.php

find :
        array(
            'code' => FILENAME_ORDERS,
            'title' => BOX_CUSTOMERS_ORDERS,
            'link' => tep_href_link(FILENAME_ORDERS)
        )
add directly after:

// BOF Export Orders to CSV
        ,
        array(
            'code' => FILENAME_EXPORTORDERS,
            'title' => BOX_CUSTOMERS_EXPORTORDERS,
            'link' => tep_href_link(FILENAME_EXPORTORDERS)
        )    
// EOF Export Orders to CSV

Here is what I've got...

<?php
/*
  $Id: customers.php,v 1.16 2003/07/09 01:18:53 hpdl Exp $

  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com

  Copyright © 2002 osCommerce

  Released under the GNU General Public License
*/
?>
<!-- customers //-->
          <tr>
            <td>
<?php
  $heading = array();
  $contents = array();

  $heading[] = array('text'  => BOX_HEADING_CUSTOMERS,
                     'link'  => tep_href_link(FILENAME_CUSTOMERS, 'selected_box=customers'));

  if ($selected_box == 'customers') {
    $contents[] = array('text'  => '<a href="' . tep_href_link(FILENAME_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_CUSTOMERS . '</a><br>' .
    

  '<a href="' . tep_href_link(FILENAME_ORDERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_ORDERS . '</a><br>' .
  '<a href="' . tep_href_link('customers_groups.php', '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_GROUPS . '</a><br>' .
'<a href="' . tep_href_link('client_search.php', '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_CLIENTSEARCH . '</a><br>' .
  '<a href="' . tep_href_link('quickship.php', '', 'NONSSL') . '" class="menuBoxContentLink">Quickship</a><br>');
/* sam end of order logging*/

  }

  $box = new box;
  echo $box->menuBox($heading, $contents);
?>
            </td>
          </tr>
<!-- customers_eof //-->


Can anyone advise please?

Jack_msc Perhaps this is the time to add your upgrade, so long as its not over complicated (sorry for being such a wimp, but I'm not a coder).

Thanks in advance.

____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

If your osCommerce is v2.3.3.3 or greater, then you should never have to amend admin side box files.  

It is always worth stating what version osCommerce you are using whenever you ask for help.

 

In v2.3.3.3 onwards, with no changes to any files;

New links can be added to exising boxes.

and

New boxes can be added.

 

So... what version of osCommerce are you using?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

So... what version of osCommerce are you using?

Ha ha, good question. Its heavily modified and first install 2006, so what ever version was around at the time. 2.2 I think.


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

@@UncleSteve

 

To find your version you may be able to find it in your admin. In your admin you can go to Tools - Server Info and click on it. When it opens, look near the top for something similar to this: osCommerce Online Merchant v2.3.4. The number at the end is your version.

 

If your system is to old to have the Server Info feature, then you can go to public_html/includes/application_top and look for something to this effect.

 

// define the project version --- obsolete, now retrieved with tep_get_version()
  define('PROJECT_VERSION', 'osCommerce Online Merchant v2.3');

 

I'm not familiar with systems so old but that might help you to find your version.

 

Take care

Bill

Share this post


Link to post
Share on other sites

osCommerce 2.2-MS2

 

So how can I fix my issue please?


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

@@UncleSteve

 

You can also create a file in you root (public_html) directory and name it phpinfo.php.
Place this: <? phpinfo(); ?> in the file and save and close. Then you can pull it up through your browser like this: http://www.your-site.com/phpinfo.php to find what version your working with.

 

Take care

Bill

Share this post


Link to post
Share on other sites

@@UncleSteve

 

You can also create a file in you root (public_html) directory and name it phpinfo.php.

Place this: <? phpinfo(); ?> in the file and save and close. Then you can pull it up through your browser like this: http://www.your-site.com/phpinfo.php to find what version your working with.

 

Take care

Bill

Okay, but its not really fixing my issue. How do I progress to make good?

 

Thanks


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

@@UncleSteve

 

My last post was a way to find your version and not to fix your issue.

 

Since I'm not familiar with your version, can can try replacing this:

 

'<a href="' . tep_href_link('quickship.php', '', 'NONSSL') . '" class="menuBoxContentLink">Quickship</a><br>');

 

With this:

 

'<a href="' . tep_href_link('quickship.php', '', 'NONSSL') . '" class="menuBoxContentLink">Quickship</a><br>'),

'<a href="' . tep_href_link('exportorders.php', '', 'NONSSL') . '" class="menuBoxContentLink">Export Orders</a><br>');

 

Not positive if it will work but that's what I would try.

 

Take care

Bill

Share this post


Link to post
Share on other sites

@@UncleSteve

 

Or this:

 

'<a href="' . tep_href_link('quickship.php', '', 'NONSSL') . '" class="menuBoxContentLink">Quickship</a><br>' .

'<a href="' . tep_href_link('exportorders.php', '', 'NONSSL') . '" class="menuBoxContentLink">Export Orders</a><br>');

Edited by ecommunlimited

Share this post


Link to post
Share on other sites

Sorry William, clearly missed your post with the concerns of the version.
 

@@UncleSteve

 

My last post was a way to find your version and not to fix your issue.

 

Since I'm not familiar with your version, can can try replacing this:

 

'<a href="' . tep_href_link('quickship.php', '', 'NONSSL') . '" class="menuBoxContentLink">Quickship</a><br>');

 

With this:

 

'<a href="' . tep_href_link('quickship.php', '', 'NONSSL') . '" class="menuBoxContentLink">Quickship</a><br>'),

'<a href="' . tep_href_link('exportorders.php', '', 'NONSSL') . '" class="menuBoxContentLink">Export Orders</a><br>');

 

Not positive if it will work but that's what I would try.

 

Take care

Bill

With the above, I get..
Parse error: syntax error, unexpected ',' in /home/site/public_html/store/admin/includes/boxes/customers.php on line 30

 

With the second suggestion, I get..

Warning: require(includes/template_top.php) [function.require]: failed to open stream: No such file or directory in /home/site/public_html/store/admin/exportorders.php on line 34

Fatal error: require() [function.require]: Failed opening required 'includes/template_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/site/public_html/store/admin/exportorders.php on line 34

 

This line says

 

<?php require(DIR_WS_INCLUDES . 'template_top.php'); ?>

It would appear I don't have the template_top.php file.

Going to have a look at Jacks first suggestion to see if I can get any further with that.

Thanks for your input.

____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

 

Jack_msc Perhaps this is the time to add your upgrade, so long as its not over complicated (sorry for being such a wimp, but I'm not a coder).

It's not an upgrade. It is, will be, a whole new addon. I use the one you are trying and it has problems and wasn't flexible enough for what I needed so I decided to change it.

Share this post


Link to post
Share on other sites

Success. I found template_top.php on the web, uploaded and its now working. Its exactly  what I was looking for.

 

Thanks for everyone's input.


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×