Jump to content
Latest News: (loading..)
Harald Ponce de Leon

osCommerce Online Merchant v2.4.0 Joli Beta

Recommended Posts

@@bruyndoncx weekly releases haven't been weekly and commits appear to have stopped at 3000, however the hard work is still continuing.

 

Here is a screenshot preview of the database schema tool being introduced in v2.4.3 that will start the initiative of supporting upgrades/migrations:

 

post-2-0-28149700-1482316129_thumb.png

 

 


:heart:, osCommerce

Share this post


Link to post
Share on other sites

@@harald
 

I suppose it's a limit of github, in this case it's impossible to follow the development. Is not possible to create in this case another project and include only 2.4 ?

 

Is possible to download the dev ?

Edited by Gyakutsuki


Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

Tuto for 2.4 :
- How to Display a new page with app
- How to make Header Tags under app APP
- How to make a
boostrap modal with external element
 

 

Share this post


Link to post
Share on other sites

@@Gyakutsuki and @@bruyndoncx

 

osCommerce isn't even close to hitting the Github commit limit. torvalds/linux has over 640,000 commits!


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

glad to know so it is pure coïncidence - looking forward to a 2.4 test drive after newyears


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

hi @Ninolan

My personal opinion is that this proyect  will never be available as step with V3.0

The leader of the team is missing in action. Core members are with their other new project.

I think @Gyakutsuki    is the only one who is doing something with this, but it is also in a parallel project to oscommerce.

My recommendation is that you do not wait and use the glorious Frozen version of Burt.

Best regards

Valqui


I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

Hi @valquiria23

Thanks for your answer. Sorry, but I am not sure which version do you mean by "glorious Frozen version of Burt."... Perhaps 2.3.4?

My purpose to upgrade from my old version were to have bootstrap on board, but I think it is not included in 2.3.4? Doesn't it?

Best regards Valqui

Nino

Share this post


Link to post
Share on other sites
32 minutes ago, Ninolan said:

Sorry, but I am not sure which version do you mean by "glorious Frozen version of Burt."... Perhaps 2.3.4?

Use the community version, It's your best option if wanting to move forwared with an osC version. Just be aware its NOT the official version and your host may not offer support  for it. Support is available on this forum.

https://github.com/gburton/Responsive-osCommerce


 

Share this post


Link to post
Share on other sites

@Ninolan

The osCommerce project was lead by one person that had been absent for quite some time. In his absence, the "community" has continued with the development of osC. Unfortunately, that one missing person is the only one that can make this continued development an 'official' release.

The 'Community Edition' (also called osC-CE (for Community Edition), osC-BS (for Bootstrap, the platform it is based on), osC-Edge, osC-Final, and/or osC-Frozen. These are all different names for the same thing) is a big improvement over the last 'official' v2.3.4 release in a number of ways:

1) It is responsive. This means that it will adjust the screen layout depending on the size of the screen of your customer's device. This is very important in this day of mobile devices. The 'official' version is not responsive.

2) It will work with the newer version of PHP, the scripting language used in osC. As more and more hosts upgrade their servers to PHP 7.x, older versions of osC will crash.

3) It is much more modular. This means that you can turn features on or off, or even add new features, all without touching the core code.

You can find a link to the latest version of the Community Edition in my signature below.

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

Dear @Ninolan

You can find a link to Frozen (the latest version of the CE) in my signature below.

The person responsible for the great version is @burt, one of the best Oscommerce coders. But there are several in the community that support this version.

Best regards.

 

Valqui

 


I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

Hi all

Thanks for your helpful explanations. I was worried about the status of this project, but sounds there are lot of people interested to maintain this alive.

Again, thanks...

Nino

Share this post


Link to post
Share on other sites

@Ninolan

Lately most people abandoned this project and are continuing it with another name.

On the one hand, it hurts me that this project is abandoned, on the other hand, hopefully they will be able to do what is not achieved here because of lack of leadership.

Best regards.

Valqui


I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×