Jump to content
themuir

Option Types - Site running really slow

Recommended Posts

Hello all, I wondered if anyone had come across this. I have been using option types for a number of years and I have noticed the more products I have added to the site the slower option types is loading. It's getting the point that adding new items is taking forever.

 

Has anyone come across this please? If you did what did you do to fix it?

 

It's driving me mad :-)

Share this post


Link to post
Share on other sites

If you mean on the shop side is slow, I can't imagine Option Types being a problem. It is most likely that you have just added more products, though that would have to be significant to cause a slowdown, I think. If you have a url rewriter installed, turn that off to see if it makes a difference.

 

If you mean the admin side is slow, then it would most likely just be the catalog section. That too is a known issue with large numbers of products.

 

If you mean both sides, it could be something totally unrelated to Option Types. All sites get hit by data skimmers so if you have dramatically increased the number of products, the longer the data skimmers will spend slamming your site and that can cause a big slowdown, though it is usually not constant. Meaning that it might be slow in the morning but not in the evening, for example.

Share this post


Link to post
Share on other sites

Thanks for the reply. I have about 1600 items on the site. It's on the admin side. Loading option types into products slows the website down. I have also noticed the site does run slow. Is there any fix to speed things up?

Share this post


Link to post
Share on other sites

What you are calling Option Types are attributes. If the admin is slow in admin->Catalog->Categories/Products, then the problem is probably due to the number of products. If it is in admin->Catalog->Product Attributes, then it is due to attributes.

 

For the latter, installing the Ajax Attributes Manager will sidestep that issue since you don't need to use that section with it.

 

For both, you can add this to the top of the admin/includes/application_top.php file after the first */, like this

*/
ob_start("ob_gzhandler");

For the shop side, turn off the "Show Category Counts" option in My Store. You may need to replace the category box with just a link to a page with categories or products. There are a bunch of addons for improving the speed but it depends on the actual cause, your version of oscommerce and so on.

Share this post


Link to post
Share on other sites

Thank you for taking the time to reply to me. The products are ok. It's when I add a product and load the options. They take forever to load before I can add a new product. In fact when I do this and test the site at the same time... it can take 12 seconds to load. It's pretty weird as this sort of this hasn't happened before but I guess I haven;t had this many items.

Share this post


Link to post
Share on other sites

I'm confused by "when I add a product and load the options. They take forever to load before I can add a new product.". Those are two different things, it seems to me. What does "load the options" mean? Are you saying that if you went into admin->Catalog->categories/Products it takes a long time to open the new product page? Did you add the code I mentioned?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×