Jump to content
Sign in to follow this  
adcompau

Australia post shipping module need

Recommended Posts

We have installed the Current aus post shipping module but its not stable and we are wondering if some know the best stable one out there for our shop which will work as far as we know australian have been left out with teh shipping modules here and we need to see more made for Australia

Share this post


Link to post
Share on other sites

I am getting incredibly frustrated by the Australian Shipping mod. I can not get an answer from the author, despite heaps of mails and forum posts at his forum.

 

What on earth are other Australian sites using for their Shipping???

 

Please can someone help me out here.

 

All I have at the moment is Express Post showing up as an option for both Australia (there is no Parcel Post) and rest of the world (it shows up as zero dollar value for o/s).

 

Any help MOST appreciated!!! :)

 

 

Jen

www.redinstead.com.au


I haven't lost my mind - I have it backed up on disk somewhere.

Share this post


Link to post
Share on other sites

The problem is with lines 28 & 30 of the current version where they are still referencing the original FLAT_RATE code.

 

Replace your lines 28 => 30 with the following:

      if ( ($this->enabled == true) && ((int)MODULE_SHIPPING_AUSPOST_EXPRESS_ZONE > 0) ) {

       $check_flag = false;

       $check_query = tep_db_query("select zone_id from " . TABLE_ZONES_TO_GEO_ZONES . " where geo_zone_id = '" . MODULE_SHIPPING_AUSPOST_EXPRESS_ZONE . "' and zone_country_id = '" . $order->delivery['country']['id'] . "' order by zone_id");

 

Steve is aware of the problem and will be updating it in the next version.

 

HTH,

Tony


"The price of success is perseverance. The price of failure comes much cheaper."

Share this post


Link to post
Share on other sites

Thanks for trying to help Tony.

 

I really wish I could say that my problems with this mod are over but it seems to have made absolutely no difference! There must be other errors in the code.

 

Any other ideas?

 

Jen

www.redinstead.com.au


I haven't lost my mind - I have it backed up on disk somewhere.

Share this post


Link to post
Share on other sites

What are your lines 28 => 30 of the Express Post module?

 

I came across the same problem as yourself and corrected it with the fix mentioned above.


"The price of success is perseverance. The price of failure comes much cheaper."

Share this post


Link to post
Share on other sites

Tony

 

I can see that those lines did need replacing as they called on the FLAT_RATE module. But which problem did you have that it fixed exactly?

 

All I have at the moment is Express Post showing up as an option for both Australia (there is no Parcel Post) and rest of the world (it shows up as zero dollar value for o/s).

 

Did you have this problem? Cos I have changed that bit of code and still have the same problem! grrrr....

 

Do you have Parcel Post showing up also and the right ones showing up for Overseas customers?

 

Jen


I haven't lost my mind - I have it backed up on disk somewhere.

Share this post


Link to post
Share on other sites

The error I had was with Express Post showing for the same zones as the Flat Rate.

 

I had Flat Rate set for the world and Parcel Post / Express Post set for Australia though Express Post would show in the world.

After I made the changes above, all was fine for me.

 

Cheers,

Tony


"The price of success is perseverance. The price of failure comes much cheaper."

Share this post


Link to post
Share on other sites

Thanks Tony. For now, I have thrown the Aust Shipping mod out the window and gone with State Based and International Zones.

 

It seems to be working fine. :)

 

Jen


I haven't lost my mind - I have it backed up on disk somewhere.

Share this post


Link to post
Share on other sites

when we test the site we try to get the shipping module to work and its comes up with a error of the following

 

Warning: Cannot add header information - headers already sent by (output started at /home2/adcomau3/advancedcomputersau-www/shop/catalog/includes/languages/english/modules/shipping/auspost.php:21) in /home2/adcomau3/advancedcomputersau-www/shop/catalog/includes/functions/general.php on line 23

 

 

if you can help me fix this it would be very greatful

Share this post


Link to post
Share on other sites

Sorry for not getting back to everyone, ive been sick again so ive not been able to spend any time coding.

 

Im packaging up a new release...which hopefully this time will solve the stupid typo's and bugs i have in the code.

 

Should be ready in a couple of hours.

Share this post


Link to post
Share on other sites
when we test the site we try to get the shipping module to work and its comes up with a error of the following

 

Warning: Cannot add header information - headers already sent by (output started at /home2/adcomau3/advancedcomputersau-www/shop/catalog/includes/languages/english/modules/shipping/auspost.php:21) in /home2/adcomau3/advancedcomputersau-www/shop/catalog/includes/functions/general.php on line 23

 

 

if you can help me fix this it would be very greatful

 

chris remove any whitespace that is visible in the code after the closing ?> of each file.

 

For some reason when i compress the code it seems to add whitespace.

Share this post


Link to post
Share on other sites
Sorry for not getting back to everyone, ive been sick again so ive not been able to spend any time coding.

 

Hope you are feeling better now Steve. I wondered what was up.

 

Jen


I haven't lost my mind - I have it backed up on disk somewhere.

Share this post


Link to post
Share on other sites

For some reason my express post shows up in shipping preference. But when selected it processes as the normal post.

 

Have a look www.satcom.com.au

Share this post


Link to post
Share on other sites

Thanks Snowman thats fixed it I think.

 

Now here is another problem, and I was wondering what you guys have done.

 

When customers place and order and they are going to pay COD. They still have to pass throught the shipping module . How do they go throught to the checkout without having to pay the shipping cost on top . Since its a COD they are going to have to pay the shipping at there end.

 

Maybe I have missed something ???

 

 

 

cheers

Tristan

Share this post


Link to post
Share on other sites

I think there is a COD shipping mod. Check the Contributions section.

 

Jen


I haven't lost my mind - I have it backed up on disk somewhere.

Share this post


Link to post
Share on other sites

Has anyone come across a problem in the current version where the shipping rate defaults to the same price as your handling fee when the weight of the products go over 20kg?

 

Cheers,

Tony


"The price of success is perseverance. The price of failure comes much cheaper."

Share this post


Link to post
Share on other sites

havent seen that one before Tony.

 

Im doing up a re-release at the moment, which will bring it up to spec for MS2 and i'll release it once i see the final release code for ms2.

 

Can you give me a bit more info on the bug you have and i'll try and narrow it down

Share this post


Link to post
Share on other sites

Not much more info I can give about it except that the module appears to work fine until the weight exceeds 20kg, then the shipping rate is shown as the handling fee only (no additional for postage).

 

Sorry if my description isn't clear enough, though I couldn't explain it any other way.

 

Also, is it normal for the shipping rate to stay the same price from 1kg all the way to 20kg? This is what I've got happening also.

 

Cheers,

Tony


"The price of success is perseverance. The price of failure comes much cheaper."

Share this post


Link to post
Share on other sites
Not much more info I can give about it except that the module appears to work fine until the weight exceeds 20kg, then the shipping rate is shown as the handling fee only (no additional for postage).

 

Sorry if my description isn't clear enough, though I couldn't explain it any other way.

 

Are you referring to weights over 20Kgs or packages over 20Kg?

 

 

Also, is it normal for the shipping rate to stay the same price from 1kg all the way to 20kg? This is what I've got happening also.

 

No the shipping rate should give different pricing for each weight range...ie up to 1kg 1.01kg to 2kg etc etc

Share this post


Link to post
Share on other sites

So far I've only tested it with weights over 20kg.

ie. 5 x tkg item, not 1 x 25kg item

 

As for pricing, I'm still having the same problem where the one price remains for all weights.

 

Snapshot in use: Current Day 2.2CVS


"The price of success is perseverance. The price of failure comes much cheaper."

Share this post


Link to post
Share on other sites

Im on a coding roll today :)

 

Im currently debugging the nex release and hopefully will have it contributed in the next few hours or so...

Share this post


Link to post
Share on other sites

Is there a way to add a simple if statement that would basically disable the austpost mod when the product weight is greater than 20kg. I am having the problem that whenever the cart weight is greater than 20kg the shipping shows as $0.00. This happens on both 1 x 20kg item and 4 x 5kg items. I have downloaded and installed the latest version of this contribution.

 

Any help would be greatly appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

Does anyone have a problem with the module timing the server out? I can get the results perfectly from my test server (56k dial-up in AU), though my server in the US doesn't like it at all... takes forever to load... and times out after showing no information.

 

Is there a server setting I need to change? I have tried the time-out in PHP though it had no effect.

 

Thanks,

Tony


"The price of success is perseverance. The price of failure comes much cheaper."

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×