Jump to content

Recommended Posts

This addon is meant as a replacement for the Product Attributes section in admin, for any version of oscommerce.  The main advantages of it are:

 

  • Ability to add/edit/delete attributes quickly (very quickly).
  • A multi-select list that allows adding attributes to many products at once.
  • Ability to search attributes.

For those of you with a large number of attributes, you will probably be amazed at how quickly this responds when compared to the existing attributes code.

 

Please note that all of the sections are not completed. The basic attributes and search code is complete, I think, and the Options code is close to complete, if not complete. But the Values and Settings sections still need to be worked on. The old attributes section, or any addon for attributes that is installed, will still function so these unfinished parts won't cause any problems. I wanted to get it uploaded as it is now to start getting feedback on it to better know what to work on.

 

So if anyone tries it, please let me know of any problems, suggestions or questions.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Someone pointed out to me that the uploaded package was missing some files. A new package has been uploaded with those included.

Share this post


Link to post
Share on other sites

Is it possible to have a file selector in this attribute editor?

I have downloadable content for each product, and typing the names takes a REALLY long time for each product.

Share this post


Link to post
Share on other sites

I'm sorry but I don't understand what you mean. There isn't anywhere for you to type the product name. You select them via the dropdown.

Share this post


Link to post
Share on other sites

Not the product name...

 

So after you select a product, you select the attribute.

My attributes are downloads, and a filename must be typed for that downloadable attribute.

Typing the filename usually results in user error every 1000 or so products.

 

Is there a way to have some kind of file selector. So the filename is 100% correct each time?

Share this post


Link to post
Share on other sites

OK, I understand. As mentioned in my first post, only the basic functions are working. There hasn't been any code added to handle downloads. That is planned, as long as there seems to be interest in this addon, but that seems to be lacking, surprisingly.  So, for now, all you can do is use this addon to create the basic attributes and assign them, since it is quicker than the default system. And then switch to the default system to change them to downloads.

Share this post


Link to post
Share on other sites

Not the product name...

 

So after you select a product, you select the attribute.

My attributes are downloads, and a filename must be typed for that downloadable attribute.

Typing the filename usually results in user error every 1000 or so products.

 

Is there a way to have some kind of file selector. So the filename is 100% correct each time?

 

There was a long time ago an addon that changed the filename box into a dropdown box and listed all the files in the downloads folder. The trouble being that it did not search any sub folders. Download can be found at http://addons.oscommerce.com/info/6410.

 

Now, whether it still works without any modification I have no idea. Its not too hard to install, so could be worth a try.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Hello 

 

Looks like an excellent addon BUT....

 

I have followed the directions and everything went well but it is loading the "main" page within the admin section for Easier Attributes.  

 

Got and idea what is going on.

 

Check out the attached image file.

 

thanks

Leon

 

post-13938-0-30986500-1472762235_thumb.jpg


I'm having a great Day - hope you are too!

 

Leon

Share this post


Link to post
Share on other sites

That is due to the version of jquery used in your shop. To stop it, find this line in admin/includes/template_top.php

<base href="<?php echo ($request_type == 'SSL') ? HTTPS_SERVER . DIR_WS_HTTPS_ADMIN : HTTP_SERVER . DIR_WS_ADMIN; ?>" />

and change it to

<?php 
/*** Begin Easier Attributes ***/
if (basename($_SERVER['SCRIPT_FILENAME']) !== 'easier_attributes.php') { ?>
<base href="<?php echo ($request_type == 'SSL') ? HTTPS_SERVER . DIR_WS_HTTPS_ADMIN : HTTP_SERVER . DIR_WS_ADMIN; ?>" />
<?php 
} 
/*** End Easier Attributes ***/
?>

Share this post


Link to post
Share on other sites

Thanks!

 

That made it WORK GREAT!

 

Good job.

 

A short question. In using your contribution I noticed that in adding an attribute, we are make the following selections (example):

 

1) Add Accessory A? - Yes Add Accessory A

2) Add Accessory A? - No Thank You

 

Well...  We have over a dozen "No Thank You"  's in our oscommerce database.

 

Apparently in using the built in attributes for oscommerce... it forced us to do a NEW "No Thank You" for each attribute every time we created one. (Or else we were just doing it ignorantly)

 

Is there a way to get rid of all of these "No Thank You" 's  in oscommerce... so we would only have 1 - - - without messing up all of our product attributes?

 

Don't know if I have explained it right or not....

 

thanks

Leon


I'm having a great Day - hope you are too!

 

Leon

Share this post


Link to post
Share on other sites

Hey Jack

 

Another issue, It may be that you just have not compeleted this portion of the addon yet, but here it is.

 

In the "Options tab" when you click on it... it list 19 options.

 

But in the regular oscommerce attributes we actually have 24 options.

 

The scroll bar is showing.... but it does not allow you to go up or down.

 

Is there a setting in the database or something else that will fix this?

 

thanks

Leon


I'm having a great Day - hope you are too!

 

Leon

Share this post


Link to post
Share on other sites

Hey Jack,

 

Little correction needed on a link.

 

When you click on the "visit the support thread" onthe top left.

 

 
           <tr>
              <td class="smallText" valign="top"><?php echo HEADING_TITLE_SUPPORT_THREAD; ?></td>
           </tr>
 
Saw in the language/english/ file 
 
define('HEADING_TITLE_SUPPORT_THREAD', '<a href="http://forums.oscommerce.com/topic/ -easier_attributes/" target="_blank"><span style="color: sienna;">(visit the support thread)</span></a>');
 
A VERY good contribution! I really like it. saves a lot of time.
 
Thanks,
Leon

I'm having a great Day - hope you are too!

 

Leon

Share this post


Link to post
Share on other sites

@@bibleman I'm sorry but I don't understand what you are saying about the  "No Thank You". There isn't a requirement for that in the basic attributes, that I can think of. Since I don't understand it, I can't really help with it with this addon. Although, it may help to know, if you have not noticed it, that the attribute selector is a multi-select list. So you can select all products in a category and add an attribute to all of them in one go. If you can provide more details on this, I will try again.

 

Regarding the options list, my test shop here has 40 options. They all show in the list and the list scrolls so I can see them all. So all I can think is it is a php issue. What version of php are you using (you can see it in admin->Tools->Server Info)?

 

Thanks for mentioning the broken link. It is a long-standing problem with addons. You have to create the support thread before the addon is uploaded or you won't have a link to the support thread. I did that for the instructions but forgot that language change. it will be in the next version but if you want it fixed now, change topic/ -easier_attributes to topic/410091-easier_attributes.

Share this post


Link to post
Share on other sites

@@bibleman I'm sorry but I don't understand what you are saying about the  "No Thank You". There isn't a requirement for that in the basic attributes, that I can think of. Since I don't understand it, I can't really help with it with this addon. Although, it may help to know, if you have not noticed it, that the attribute selector is a multi-select list. So you can select all products in a category and add an attribute to all of them in one go. If you can provide more details on this, I will try again.

 

Regarding the options list, my test shop here has 40 options. They all show in the list and the list scrolls so I can see them all. So all I can think is it is a php issue. What version of php are you using (you can see it in admin->Tools->Server Info)?

 

Thanks for mentioning the broken link. It is a long-standing problem with addons. You have to create the support thread before the addon is uploaded or you won't have a link to the support thread. I did that for the instructions but forgot that language change. it will be in the next version but if you want it fixed now, change topic/ -easier_attributes to topic/410091-easier_attributes.

 

On the options list...   My server reports:

 

HTTP Server: Apache

 

PHP Version: 5.3.3 (Zend: 2.3.0)

 

 

On the "No Thank you"   You can see it work here: 

 

http://www.ministryhelps.com/dake-bible-large-print-bonded-black-finis-dake-p-78.html

 

If you will notice you will see the "No Thank You" listed there 4 times.

 

AND in the admin section for the same product I have a "No Thank You" selection under each set of attributes.  See Attached image.

 

So this being the case in your EXCELLENT contribution Easier Attributes I have a number of the SAME choices for adding the "No Thank You." See second image.

 

No big deal I guess - just trying to explain what is going on.

 

thanks

Leon

 

 

 

post-13938-0-72369400-1472912539_thumb.jpg

post-13938-0-95171000-1472912804_thumb.jpg


I'm having a great Day - hope you are too!

 

Leon

Share this post


Link to post
Share on other sites

@@bibleman  Regarding the options list, I have a test shop here with 5.3 and it is working fine. I have also installed this into a handful of shops and they are not having the problem either so I'm at a loss as to what might be causing that.

 

The "Thank You" entries are attribute values. The way you have it setup is not technically wrong but it needlessly complicates things. While the procedure for adding attributes has always been stated as

  • Create an Option
  • Create an Option Value
  • Create an Attribute by selecting the Option and Option Value you want it  to have

there isn't any checking done to ensure the Option and the Option Value are for the ones entered so you can't be sure which is being used unless you remember which you used or you very diligently applied them. The way this should be done is to have one Value of "Thank You" and use that for all of the attributes that need it. That Value can be assigned to any Option or a new Option can be created for it. So let's say you have these Options and Values:

 

Option      Value

Color         Red

General    Thank You

 

When you add an attribute, you would use

 

Product Name    Option   Value

Some Product     Color    Red

Some Product     Color    Thank You

 

When that product is displayed, there will be one attribute with both options showing. Doing it that way allows you to use one Value for all attributes, instead of the same Value for all attributes as you are doing now. Unfortunately, there's not an easy way, that I am aware of, to change what you have into what I describe so, if you wanted to do it, it would have to be done by editing each attribute. Although, if you are comfortable with making MySQL changes directly to the database, you could create the new Value in admin, get its ID and then edit the attributes in the database to change the ID for that Value.

Share this post


Link to post
Share on other sites

Although, if you are comfortable with making MySQL changes directly to the database, you could create the new Value in admin, get its ID and then edit the attributes in the database to change the ID for that Value.

 

 

 

 

 

 

@@Jack_mcs

 

OK that explains a lot.

 

So I guess what I need to do is get to work on creating the NEW ID as you have said and change all of the "No Thank You" to that and then AFTER that come back and delete them.

 

Thanks for your help - you rally know your stuff!

 

Leon 

 

Although, if you are comfortable with making MySQL changes directly to the database, you could create the new Value in admin, get its ID and then edit the attributes in the database to change the ID for that Value.

 

 

I'm having a great Day - hope you are too!

 

Leon

Share this post


Link to post
Share on other sites

@@Big Bear It's not possible without code changes and that wouldn't be a quick change. I will add it to the list for a future version.

Share this post


Link to post
Share on other sites

I downloaded the add-on package, iInstalled it, and got the attributes working. Excellent work!

 

1) The attributes do not accept zero price. Is there a way to make it accept?

 

2) In catalog/includes/modules folder, I got these 3 files but they seem to be unfinished work. How is it so?

     easier_attributes_options

     easier_attributes_values

     easier_attributes_settings

 

KG Tee

Share this post


Link to post
Share on other sites

It should accept an entry without a price but be sure to select the blank prefix.

Share this post


Link to post
Share on other sites

Question:

 

In my shop 2.3 Options and Values with no options to select??

What is wrong?

Product listing by Show in use it is ok but I can't edit anything.

Share this post


Link to post
Share on other sites

I can't think of a reason why that would not work. When you go to the admin->Catalog->Easier Attributes section is the display correct? I mean the overall appearance like the columns. The code may not be detecting a 2.3 shop and that would be the symptom. Though I would think the options would still show. Do you see the options when you click on the Show in use button?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×