Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

upaulc

Installed Version: osCommerce Online Merchant v2.3.3.3

7 posts in this topic

Currently I Have Installed Version: osCommerce Online Merchant v2.3.3.3 (That's (2) Versions Out Dated....

 

Would you advise to Upgrade using This Method (osCommerce Online Merchant v2.3.3.3 To v2.3.4) or  skip this version Upgrade and go Directly to (osCommerce Online Merchant v2.3.4)....I'm Just trying to Avoid any unforeseen Problems with or during the Upgrade..

 

Thanx, In Advance...

upaulc

Share this post


Link to post
Share on other sites

Hi @@upaulc If you have not done a lot of modifications on your site it would be best to install a fresh file set of the 2.3.4 BS version and upgrade old database with your info to use. Of course do a full backup of all current site files and database and keep in safe place just in case:) 

 

here is link to latest fileset if interested: https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

Share this post


Link to post
Share on other sites

Note that 2.3.4BS is a fully "responsive" version based on 2.3.4. As so many people use mobile devices (phones, tablets) today, it is vital to be mobile-friendly. Also note that this is a community-supported (informal) branch of the product, but is better than the unmaintained official 2.3.4 version, which hasn't been updated in years.

 

Unfortunately, there is no upgrade path from 2.3.4 to 2.3.4BS. You install 2.3.4BS and migrate the database from 2.3.3.3 to 2.3.3.4 to 2.3.4 to 2.3.4BS, either step by step, or manually by comparing DB layouts between 2.3.3.3 and 2.3.4BS.

Share this post


Link to post
Share on other sites

Hi @@upaulc If you have not done a lot of modifications on your site it would be best to install a fresh file set of the 2.3.4 BS version and upgrade old database with your info to use. Of course do a full backup of all current site files and database and keep in safe place just in case:) 

 

here is link to latest fileset if interested: https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

Thank You For The Fast Input..I Will check out the link and go from there, will be in touch with the progress..

upaulc (Paul)

Share this post


Link to post
Share on other sites

Note that 2.3.4BS is a fully "responsive" version based on 2.3.4. As so many people use mobile devices (phones, tablets) today, it is vital to be mobile-friendly. Also note that this is a community-supported (informal) branch of the product, but is better than the unmaintained official 2.3.4 version, which hasn't been updated in years.

 

Unfortunately, there is no upgrade path from 2.3.4 to 2.3.4BS. You install 2.3.4BS and migrate the database from 2.3.3.3 to 2.3.3.4 to 2.3.4 to 2.3.4BS, either step by step, or manually by comparing DB layouts between 2.3.3.3 and 2.3.4BS.

Thanx Phil, Now That's a Lotta work...Just Thinking of the process of all the versions of database migration gives me Brain Freeze..."In Short" Nothin' Fails But A Try...

Thanx, upaulc (Paul)

Share this post


Link to post
Share on other sites

Thanx Phil, Now That's a Lotta work...Just Thinking of the process of all the versions of database migration gives me Brain Freeze..."In Short" Nothin' Fails But A Try...

 

Actually, I don't think it's as bad as you fear. Each new version of osC includes an SQL update script to be imported (run), which should modify the database schema from the previous version to the new one. Be sure to back up your database (and know how to check that it appears to be a good backup) before starting. The alternative, if you're comfortable with such things, is to obtain the schemas for your current version and the new one (2.3.4BS), and use the differences for a guide to manually updating the DB to the new schema all in one step.

Share this post


Link to post
Share on other sites