Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

rmanbike

osc2.3 /.htpasswd_osCommerce unable to login to admin

Recommended Posts

Long story short, I have been unable to login to admin after a fresh install of site. Hosting on a vps Apache and plesk. I don't remember seeing this file in admin before: /.htpasswd_osCommerce and the file was actually empty so I deleted it. But that still didn't help with logging into admin. Tried resetting password by

 

Login to cPanel, and go to Databases -> phpMyAdmin

 
Click on your OSCommerce database on the right
 
On the next screen, click on the Administrators table
 
Edit the record for the username in this table
 
Replace the contents of the password field with this, then click Go: 6cdd7c57450225fac77427f5962bb726:40
 
But still getting the same error as before and also I not see htaccess file? LOST
 
Error: The maximum number of login attempts has been reached. Please try again in 5 minutes.
 
 
 

Share this post


Link to post
Share on other sites

Now that I looked in the right directory, this is contents of .htaccess 

 

# $Id: .htaccess 1775 2008-01-09 19:26:55Z hpdl $

#
# This is used with Apache WebServers
# The following blocks direct HTTP requests in this directory recursively
#
# For this to work, you must include the parameter 'Limit' to the AllowOverride configuration
#
# Example:
#
#<Directory "/usr/local/apache/htdocs">
#  AllowOverride Limit
#
# 'All' with also work. (This configuration is in your apache/conf/httpd.conf file)
#
# This does not affect PHP include/require functions
#
 

Share this post


Link to post
Share on other sites

Hello Roger @@rmanbike,

 

1. Delete the existing administrator in the database (leave table empty)

2. Leave the file admin/.htpasswd_osCommerce blank (erase all content, but leave the file in place)

3. In the file admin/.htaccess delete the following lines:

##### OSCOMMERCE ADMIN PROTECTION - BEGIN #####
AuthType Basic
AuthName "osCommerce Online Merchant Administration Tool"
AuthUserFile /web/htdocs/YOUR PATH TO ADMIN DIRECTORY/.htpasswd_oscommerce
Require valid-user
##### OSCOMMERCE ADMIN PROTECTION - END #####

then try to enter your admin. You'll be prompted that no admin exists and that you should enter a username and password to create one.

Do this, remember or copy user and pass and try again to enter. Now you will prompted to login, use the user and pass you just entered. Once you have logged in, go to admin => Configuration => Administrators and activate additional .htaccess protection.

 

regards

Rainer

Share this post


Link to post
Share on other sites

×