Jump to content
valquiria23

Español pack para OsC Responsive BS EDGE o Gold

Recommended Posts

Hi Raiwa

I don't want to seem like a know it all; but recently I was having some issue with my store. The result was going through my error log to find the issue, which lead to a few problems which were unseen.

I noticed in the espanol modules that line 73 and 74 have been deprecated in OSC CE Phoenix and now cause a PHP declaration error. I have removed them from my shop as I believe they are now unnecessary.

I hope this is good information and will help some. Please follow up and let me know.

Ron

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, raiwa said:

Never used these platforms and not sure if it would be more work to set it up than to update the translations.

Each language is maintained by only one developer., so I'm not sure if there would be any benefit.

the idea is for all languages and hosted solution, but is possible self hosted type https://pootle.translatehouse.org/ very much open source use similar solutions how joomla & virtuemart for example,
electron use https://crowdin.com/page/open-source-project-setup-request

The benefit is clear, the first does not depend on one developer, the admin/developer remain rights and can manager all,
and translate is open to all people specially to translators like contribute and people help to advance or can translate more languages.
There is no single point of view, so the result is translation was more accurate with sintaxis contextual.

From my point of view and although I don't speak English,
the actual translations they lose part of the meaning or are very long being literal translations, have typos, define missing/over and others...
I not say your translation is bad, secure I can't do better, I say together we can make it better.

It is clear that each one can fix it for oneself, that is also will done equal, but the origin should be agreed and labeled as official.
When I start to adapt your translation to my considerations I think to collaborate, even more when in the first 20 files I found 6 typos and check not all is translated.

If in each version I have to check what files have changed and that they changes it becomes unfeasible,
however with a solution like the one mentioned, you can see who modifies what and when and it is reversible.

Maybe git can be used, but I don't know how and it is a brake for non-developers, others have developed their own i18n solution facturascripts.com,
many others use others such as weblate.org , this is a good self-hosted option,
others are paid and the free plans do not always cover the needs of oscomerce but much of they are free plan for Open Source.
Here 16 -best-translation-management-systems that can be reviewed and a clearer summary in this great webpage https://free-for.dev/#/?id=translation-management
And this page is a curious more advanced solution https://translated.com/developers

Sorry for this brick 

Edited by domiosc

Share this post


Link to post
Share on other sites
Posted (edited)

Dear Vicent @domiosc,

I believe there is a misunderstanding.

I was and I am always open for teamwork. The origin of the actual version was a teamwork between 4 members of the forum @piernas, @PiLLaO, @TITO4 and me, like you can see in the instruction file.

When I say it is maintained by one developer I wanted to say that this is a fact since a couple of years, not a desire.

The original team was working together in the update of a previous 2.3.4.1 standard version to an EDGE version and then to FROZEN.

SInce then I'm maintaining and updating alone, except for some error reports from @valquiria23.

I'm not a native spanish speaker, but living in Spain since almost 30 years. So it might be understandable that there are some literal translations of the newer definitions.

I would be very happy to get again a team built up which for sure will see more than only 2 eyes.

How this can be realized is the question. Until now we have the GITHUB repository:

https://github.com/raiwa/OSCOM-CE-Phoenix-Spanish-language-idioma-espanol

The preferred way would be to push any fixes or suggestions there.

As I pointed out, I have no experience with the platforms you mention and just no time to try them out and decide which would best fit what we need. I have already a lot of work to keep the existing 3 places up to date: GitHub repository, App on the marketplace and on my WEB.

If it is easy and fast to use one of your suggested platforms and link it to the already existing, lets do it. But please, if you have any experience, decide which platform and do the setup there. Maybe the maintainers of the other languages would be also interested and jump in: @cupidare (german), @Fredi (russian) and @Denkster (Dutch).

For the errors, suggestions please take in consideration the following details we agreed in the original translation team:

- upper/lower case follows the pattern of the english original. It doesn't follow the strict ortographic rules.

- We didn't consider it necessary to translate absolutely everything on the admin side. Because all the configuration entries and module descriptions are also in english and translation is not supported by the system (monolingual database entries)

- my Spanish package is oriented to the Spanish localization in Spain. Latin America and other regions will need to produce their own localized version.

Please let me know your thoughts and how we can proceed.

15 hours ago, RonCain said:

I noticed in the espanol modules that line 73 and 74 have been deprecated in OSC CE Phoenix and now cause a PHP declaration error. I have removed them from my shop as I believe they are now unnecessary.

Hello Ron,

Please post the full path and filename where to find the mistake. I'll then be pleased to fix it. Or better push an request to the GitHub repository.

Thanks to both of you and kindest regards
Rainer

Edited by raiwa

Share this post


Link to post
Share on other sites

Hi Raiwa

\catalog\includes\languages\espanol.php

I noticed that line 73 and 74 have been deprecated in OSC CE Phoenix and now cause a PHP declaration error. I have removed them from my shop as I believe they are now unnecessary.

I hope this is good information and will helpful as I am not any master coder. Please follow up and let me know.

Ron

Share this post


Link to post
Share on other sites
3 minutes ago, RonCain said:

Hi Raiwa

\catalog\includes\languages\espanol.php

I noticed that line 73 and 74 have been deprecated in OSC CE Phoenix and now cause a PHP declaration error. I have removed them from my shop as I believe they are now unnecessary.

I hope this is good information and will helpful as I am not any master coder. Please follow up and let me know.

Ron

Thanks Ron, I'll await more corrections from Vicent and update it. But this should not produce any error if the definitions are not used any more. It can produce errors if the same definitions have been moved to another file and are now duplicated. But this is not the case.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, raiwa said:

If it is easy and fast to use one of your suggested platforms and link it to the already existing, lets do it. But please, if you have any experience, decide which platform and do the setup there. Maybe the maintainers of the other languages would be also interested and jump in: @cupidare (german), @Fredi (russian) and @Denkster (Dutch).

Yes, that's a good idea. Multilingual support needs to be organized jointly and to concentrate all available languages on one platform.
I am ready to participate in this for my language.

Additionally, you need to make it possible to output configuration definitions in the multilingual format in Admin.
Today, OSC and Phoenix are bad supported in this regard. This creates a problem for people and peoples who do not know English well. This holds back application in different countries.
This needs to be fixed.

Edited by Fredi

Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites
8 minutes ago, Fredi said:

Additionally, you need to make it possible to output configuration definitions in the multilingual format in Admin.
Today, OSC and Phoenix are bad supported in this regard. This creates a problem for people and peoples who do not know English well. This holds back application in different countries.
This needs to be fixed.

That is true !!! It is a very good opportunity for improvement.
Hopefully the Core team @burtwill take it into consideration for upcoming versions or explain why it won't.
When that is done @raiwa  count on me for the new translations.

Best regards

Valqui


Please do not falsify my words. Are you interested in knowing who does it? Send me a PM.

The Phoenix Club won't allow me to join - why not?

Setting up a new Frozen site with so many nice addons available on the market. 

:heart: Community Oscommerce fan :heart:

 

Share this post


Link to post
Share on other sites
5 hours ago, raiwa said:

As I pointed out, I have no experience with the platforms you mention and just no time to try them out and decide which would best fit what we need. I have already a lot of work to keep the existing 3 places up to date: GitHub repository, App on the marketplace and on my WEB.

5 hours ago, raiwa said:

Please let me know your thoughts and how we can proceed.

Me neither, but I think we should try.
as usual you hit the spot, and almost all the proposals end here, Who is going to be in charge?
I know all of us who make proposals point to the same people and it is true that you already do to much, the initiative must come from new people
It is also true that many of those we do proposals are also we not able to do more.

I'm only an normal user so I can't contact to payment systems which offer free plans for open source community,
so the most I can do is install several of these solutions and share to test for the rest people want collaborate to create the rules system and try from my modest knowledge.
But think is preferible this start for example by Harald and host here..

Please anyone check the links of this platforms and show your opinion, Which do you consider to be a better option?

Share this post


Link to post
Share on other sites
Posted (edited)

I am ready to provide a server and domain for the implementation of such a project.
Those who are interested in installing software for this project on server, can contact me.

Softvare to example - https://opensource.com/article/17/6/open-source-localization-tools

Edited by Fredi

Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Hi Raiwa

Thanks for the feedback, here is the error I was getting:

PHP Warning:  Use of undefined constant REVIEW_TEXT_MIN_LENGTH - assumed 'REVIEW_TEXT_MIN_LENGTH' (this will throw an Error in a future version of PHP) in .../includes/languages/espanol.php on line 73

when compared to English and French lines 73 and 74 do not exist and once removed the error goes away; but I do not know if the code has been moved to another module or not.

Ron

Share this post


Link to post
Share on other sites
12 minutes ago, RonCain said:

Hi Raiwa

Thanks for the feedback, here is the error I was getting:

PHP Warning:  Use of undefined constant REVIEW_TEXT_MIN_LENGTH - assumed 'REVIEW_TEXT_MIN_LENGTH' (this will throw an Error in a future version of PHP) in .../includes/languages/espanol.php on line 73

when compared to English and French lines 73 and 74 do not exist and once removed the error goes away; but I do not know if the code has been moved to another module or not.

Ron

Ok, makes sense. Thank you

Share this post


Link to post
Share on other sites
On 1/7/2020 at 1:05 AM, domiosc said:

the actual translations they lose part of the meaning or are very long being literal translations, have typos, define missing/over and others...

Hello Vicent @domiosc,

I'm awaiting your corrections and suggestions to update the package together with Ron's fixes.

If you are not familiar with GitHub to push it there, you can always send me a PM  with the corrected files or a detailed list of your corrections. Just please do not send the complete package with your version. It would be too much work to search for your changes.

Thanks and kind regards
Rainer

Share this post


Link to post
Share on other sites

Now I'm bussy, I think to start again from 1.0.4.2 because I don't check if you fix from 1.0.4.0
After check what files modified from originals and report you

Edited by domiosc

Share this post


Link to post
Share on other sites

Uploaded Versión 1.0.4.2.r1 for OSCOM CE Phoenix 1.0.4.2.

Español para OsC CE

https://github.com/raiwa/OSCOM-CE-Phoenix-Spanish-language-idioma-espanol

Includes some minor fixes reported by @domiosc and @RonCain

Update instructions included.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Uploaded Versión 1.0.5.0. for OSCOM CE Phoenix 1.0.5.0. (1.0.4.5.)

Español para OsC CE

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Uploaded Versión 1.0.5.3. and 1.0.5.5. for OSCOM CE Phoenix 1.0.5.3. and 1.0.5.5.
(1.0.5.4 has no language changes)

Español para OsC CE

Share this post


Link to post
Share on other sites

Muchas gracias Rainer!!! Se que están pasando un mal momento en España. Ojala todo mejore pronto, cuídate mucho!!!


Please do not falsify my words. Are you interested in knowing who does it? Send me a PM.

The Phoenix Club won't allow me to join - why not?

Setting up a new Frozen site with so many nice addons available on the market. 

:heart: Community Oscommerce fan :heart:

 

Share this post


Link to post
Share on other sites

Hola,

 

Espero esten bien, aprovechando el tiempo de cuarentena, decidi crear una pagina web para mi negocio. Acabo de instalar Phoenix 1.0.5.6, instale el paquete de español de Raiwa, lo instale como predeterminado. Acabo de notar que el paquete esta diseñado para la version 1.0.5.5

 

tendre que bajar a la version anterior?

 

 

Saludos

site_4wd.jpg

Share this post


Link to post
Share on other sites
50 minutes ago, 4wdautoparts said:

tendre que bajar a la version anterior? 

For the moment, you could just leave the PI modules turned off in admin > Layout Modules > Product Info.  As they're the only new translations that I can see in includes/languages. 

https://github.com/gburton/CE-Phoenix/compare/1.0.5.5...master

A few more in admin/includes/languages but those shouldn't be blocking. 


Always back up before making changes.

Share this post


Link to post
Share on other sites
3 hours ago, 4wdautoparts said:

tendre que bajar a la version anterior?

Hola autopartes.

Tenés dos opciones. Bajar la versión 1.0.5.5 usando el link de arriba y usar el paquete de @raiwa o seguir con la 1.0.5.6 y esperar que salga el paquete de idioma más actualizado e instalarlo.

Yo esperaría un poco ya que @raiwa los actualiza muy seguido y tiene excelente soporte además de ser una persona muy amable.

Saludos

Valqui

Edited by valquiria23

Please do not falsify my words. Are you interested in knowing who does it? Send me a PM.

The Phoenix Club won't allow me to join - why not?

Setting up a new Frozen site with so many nice addons available on the market. 

:heart: Community Oscommerce fan :heart:

 

Share this post


Link to post
Share on other sites

@4wdautoparts,

Hola, espero encontrar tiempo para la actualización a 1.0.5.6 este fin de semana.

Un saludo
Rainer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×